•   
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 119
  •   
RaspBMC Kodi/XBMC test builds
#16
Thanks for sharing. It works great so far.
Only problem i have is my CEC is not working when i turn off/on my TV. I have to disable/enable it in my TV settings before...
Frontend : Raspberry Pi 2, Google Nexus Player
Ziggo TV Channel Logo Pack (Dutch)
Reply
#17
Might depend on TV and/or libcec. My Samsung is the same while my Panasonic works all the time.
The following might work (very possible):
Code:
/opt/vc/bin/tvservice -d ~/edid.dat
sudo cp ~/edid.dat /boot
and add the following to config.txt (preferably via Raspbmc settings):
Code:
hdmi_edid_file=1
hdmi_force_hotplug=1
Reboot.

Edit: You need to be directly connected to the TV for the above to work (TV on of course).
Reply
#18
@ThePolarSky
That is a possibility, but I am still uncertain since prepared/enabled might be considered the same as including the actual libraries, I have seen such discussions and decided that I don´t want to involve myself in such matters. Smile
Also, as you say, I have to make 2 builds each time, but a big factor is simply that I do not have one single DVD myself. Wink
Reply
#19
@miappa

I made the Installation with the Version from post 7

But I didn´t came from release 12.2
I had installed the latest nightlies of raspbmc before

I am still impressed
sql and Thumnails are used from my WHS now
permanently 1100 Arm 550 core and 550 sdram stable with maximum 52 Degrees Celsius
Reply
#20
(2013-10-21, 20:18)miappa Wrote: Might depend on TV and/or libcec. My Samsung is the same while my Panasonic works all the time.
The following might work (very possible):
Code:
/opt/vc/bin/tvservice -d ~/edid.dat
sudo cp ~/edid.dat /boot
and add the following to config.txt (preferably via Raspbmc settings):
Code:
hdmi_edid_file=1
hdmi_force_hotplug=1
Reboot.

Edit: You need to be directly connected to the TV for the above to work (TV on of course).

Thanks that did the trick.
Frontend : Raspberry Pi 2, Google Nexus Player
Ziggo TV Channel Logo Pack (Dutch)
Reply
#21
Hi miappa,
I've installed your NewClock3 using your procedure in post #12 above.
It works well, but when using the mouse to control video, when I move the mouse the progress bar at bottom of screen appears as expected, but I don't get the buttons ie fast forward, fast rewind, pause, stop etc. so I do get the progress bar, but not the buttons, occasionally they will briefly appear, but then disappear again. I have also tried Sams speed build and that does the same, so I don't think it is only your build. If I use the XBMC android remote the buttons will appear and work fine.
The other problem I have with this build, but none of the others (release, speed, omxbackport4) is I get caught in a reboot loop when I try to power off, instead of powering off it reboots and XBMC reloads; the only way I can shut down cleanly is to SSH in and do it manually.
Any ideas?.
Many Thanks, Kevin.
Reply
#22
Edit: Where is my manners... Hi bleep! Wink

The first issue: http://forum.xbmc.org/showthread.php?tid=172162
Report it there and see if you get a response, it seems to affect Gotham on Pi (no matter distro).

The second, which build did you install? Could you try the oter of the 2 latest and see if it is the same?
Once (but only once) when I pressed reboot XBMC restarted instead, but other than that shutdown and reboot works for me.
Reply
#23
Hi miappa,
Thanks for your quick reply :-)
I have now tried both your loads
Updated Gotham build 20131019 in post #7 (this build might break Airplay, see next build for possible fix)
Updated Gotham build 20131020 in post #12 (same as previous but with Airplay fix)
unfortunately they both get stuck in the power off reboot loop :-(
I have now reported the mouse problem to 'OpenELEC Testbuilds for RaspberryPi Part 2', hopefully it'll get picked up from there.
Thanks again.
Regards, Kevin.
Reply
#24
Wait.... do you mean that Pi reboots instead of shutting down, or that XBMC keeps trying to restart?
Reply
#25
I do a 'power off system' from XBMC I then get a blank screen for about 10 seconds and then XBMC reloads.
I can only escape by ssh'ing in and shutting down manually.
Reply
#26
Ah, ok, that is not a loop then, XBMC quits and restarts.
I think I know what this is.
The default Raspbmc skin is not updated for Gotham and some things are changed.
Try for example default Confluence (classic) skin and see if it behaves differently (it should).
If so I will adress this to Sam, I think it might be an easy fix.
Reply
#27
(2013-10-23, 15:14)miappa Wrote: Ah, ok, that is not a loop then, XBMC quits and restarts.
I think I know what this is.
The default Raspbmc skin is not updated for Gotham and some things are changed.
Try for example default Confluence (classic) skin and see if it behaves differently (it should).
If so I will adress this to Sam, I think it might be an easy fix.

http://forum.xbmc.org/showthread.php?tid...pid1505189
http://forum.xbmc.org/showthread.php?tid...pid1517618
Reply
#28
Hey Hudo,

I know about that bug, but it apparently it does not affect Raspbmc the same way (even though perhaps it should?).
Shutdown works on default Confluence and Amber with Raspbmc and Gotham (and several other skins I have tested), but not on Raspbmc modded Confluence.

Do you think it still is related?
Reply
#29
Hi miappa,
Ok I've tried Confluence and now also Amber, but they all do the same.
Select 'power off system' from XBMC I then get a blank screen for about 10 seconds, or a (usually) blue screen with 'Select ESC key for command line', then XBMC reloads.
Sorry; that didn't help :-(
Regards Kevin.
Reply
#30
Ok, good to know, thanks.
Then I guess that the bug that hudo linked to affects Raspbmc also (as it "should"), however quite random.
For me it really works and has worked since the first day I switched to Gotham (over 6 months ago).
I guess we have to wait for a fix, fortunately it´s not that big a bug.

Edit: And cheers hudo, now we (most likely) know what the issue is.
Reply
  •   
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 119
  •   
 
Thread Rating:
  • 15 Vote(s) - 4.4 Average



Logout Mark Read Team Forum Stats Members Help
RaspBMC Kodi/XBMC test builds4.415