•   
  • 1
  • 25
  • 26
  • 27(current)
  • 28
  • 29
  • 119
  •   
RaspBMC Kodi/XBMC test builds
Yes, but see to that you only switch guisettings when XBMC is not loaded in this case (you can just rename it to keep a backup).
If you do it when XBMC is loaded it will revert to whatever XBMC version you are running and therefor might "destroy" your backup.

Edit: Keep a backup of each outside the Pi (on your computer). Then you don´t have to worry to much about that.

Also, note that switching between versions is not optimal with databases and addons.
Database files has been updated and e.g the addon*.db is different as the repo is for Frodo/Gotham.
The other libraries are also different, updating should be supported but not the other way around. So if you scan something to library in Gotham it will not be added in Frodo.
And, many addons have different versions for Frodo and Gotham.

So, in theory it should actually be better to have separate .xbmc directories if you tend to switch between Frodo and Gotham a lot.
This will however influence addon settings such as Raspbmc settings etc as addon might store settings in /home/pi/.xbmc/userdata/addon_data

Personally I would recommend to try to stick with Gotham if it works for you, only switch to Frodo if there is an addon that don´t work on Gotham yet.
Reply
Ok thanks for the insights!

The only reason I'm switching is because I was afraid Gotham wouldn't be ready for day to day use yet, but I understand from your post that you're expecting Gotham to function mostly properly. (I don't think I'm using any outlandish plugins that will break.)

Will give this a try.
Reply
Ok miappa not sure if this has worked for the Amber skin widget but first I wanted to check if this means the skin completed install? It all seems to be working fine
100%[===================================>] 54,081,762 1.81M/s in 33s

2014-01-23 13:02:20 (1.57 MB/s) - `xbmc-13-20140122-nc3.tar.gz' saved [54081762/54081762]

[email protected]:~/.upgrade$ mkdir -p xbmc-13-20140122-nc3
[email protected]:~/.upgrade$ tar -xzf xbmc-13-20140122-nc3.tar.gz -C xbmc-13-20140122-nc3
[email protected]:~/.upgrade$ cd xbmc-13-20140122-nc3/xbmc-bcm/xbmc-bin/lib/xbmc/system
[email protected]:~/.upgrade/xbmc-13-20140122-nc3/xbmc-bcm/xbmc-bin/lib/xbmc/system$ cp /usr/local/lib/libdvdcss.so.2.1.0 .
cp: cannot stat `/usr/local/lib/libdvdcss.so.2.1.0': No such file or directory
[email protected]:~/.upgrade/xbmc-13-20140122-nc3/xbmc-bcm/xbmc-bin/lib/xbmc/system$ ln -sf libdvdcss.so.2.1.0 libdvdcss.so.2
[email protected]:~/.upgrade/xbmc-13-20140122-nc3/xbmc-bcm/xbmc-bin/lib/xbmc/system$ ln -sf libdvdcss.so.2 libdvdcss.so
Reply
You have missed one thing, you have not compiled libdvdcss.
I have noticed that it might work anyway (probably not with ebcrypted DVD´s though), but I recommend that you compile the library as explained in post #1.
This is only needed once / setup.
Reply
I thought I'd done that but obviously not.
So should I remove the update again. Then install the libdvdcss and try again?
Reply
No need for that, compile according to post #1 (see to that everything works out) then run the following:
Code:
cd xbmc-13-20140122-nc3/xbmc-bcm/xbmc-bin/lib/xbmc/system
cp /usr/local/lib/libdvdcss.so.2.1.0 .
ln -sf libdvdcss.so.2.1.0 libdvdcss.so.2
ln -sf libdvdcss.so.2 libdvdcss.so
Restart XBMC.
Reply
Now got this below. . And posters not showing up for new episodes in seasons

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
[email protected]:~$ cd xbmc-13-20140122-nc3/xbmc-bcm/xbmc-bin/lib/xbmc/system
-bash: cd: xbmc-13-20140122-nc3/xbmc-bcm/xbmc-bin/lib/xbmc/system: No such file or directory
[email protected]:~$ cp /usr/local/lib/libdvdcss.so.2.1.0 .
[email protected]:~$ ln -sf libdvdcss.so.2.1.0 libdvdcss.so.2
[email protected]:~$ ln -sf libdvdcss.so.2 libdvdcss.so
Reply
Sorry, you need to be in .upgrade.
Do this instead:
Code:
cd /home/pi/.upgrade/xbmc-13-20140122-nc3/xbmc-bcm/xbmc-bin/lib/xbmc/system
cp /usr/local/lib/libdvdcss.so.2.1.0 .
ln -sf libdvdcss.so.2.1.0 libdvdcss.so.2
ln -sf libdvdcss.so.2 libdvdcss.so

Regarding artwork, I should think that things already in library will not be updated. You probably have to force an update on whatever show you want to update.

Edit: Make sure you have switched to correct version.
Reply
Ok removed files from scan paths cleaned library re scanned library and then cleaned again put files back in to the scan path and re scanned and still no poster.
Will wait to see what happens when a new episode scans in.
Cheers for help but no luck do far.
Reply
It´s sort of already been confirmed working, but as I never experienced this issue myself I don´t know what to suggest or test, other than, "force" update on complete show:
Go into library, 'info' on show, Refresh and choose Yes. After it´s done, restart XBMC.
Reply
Yes the work around is ok just hoped this would solve it
Reply
Updated Gotham build, XBMC master Jan 24 + newclock3 and additional commits.
See here to compare with XBMC master.

Info:
XBMC master from Jan 24
• DVDPlayer with hardware acceleration (optional video/dvd player)
• Fix for season art (should help Amber/skin.widget users)
• Updated: Fix HLS variant selection (https & pvr)

Recommendations:
• Libdvdcss (see post #1), this might be required
• Dec update or latest firmware from master (see post #1)
Fresh guisettings.xml if you come from Frodo or old Gotham
• Recheck all settings after install

For DVDPlayer testers, see post #1 (Alternative players).

To install, SSH to Pi:
Code:
cd .upgrade
wget -O xbmc-13-20140124-nc3.tar.gz http://goo.gl/y8xviJ --no-check-certificate
mkdir -p xbmc-13-20140124-nc3
pv xbmc-13-20140124-nc3.tar.gz | tar xzf - -C xbmc-13-20140124-nc3
cd xbmc-13-20140124-nc3/xbmc-bcm/xbmc-bin/lib/xbmc/system
cp /usr/local/lib/libdvdcss.so.2.1.0 .
ln -sf libdvdcss.so.2.1.0 libdvdcss.so.2
ln -sf libdvdcss.so.2 libdvdcss.so
Activate new build in "Raspbmc Settings/Nightly…/Switch…”, choose new build + restart XBMC.
Reply
Short (and maybe stupid) question: How can I update the two files start_x.elf and fixup_xdat?
A simple copy is not working :-)
RaspBMC is installed on an USB stick
Reply
First a big thanks to miappa for maintaining those builds. This is truly great!
I have a little feedback on airplay which comes with a question.
For my brother i set up a rasp using build from january 17th. The build is working great. It s connected directly on the TV using HDMI.Everything is working perfectly there.
Now he has an audio amplifier which is not connected to the TV. His audio speakers are connected to it, so it would like airplay to be sent to the audio amplifier while movies are played (audio/video) on the TV. I immediately thought about dual output. So we used the jack to connect to the amplifier.It works great with movies, the audio goes through HDMI and jack at the same time.
Now the problem is with airplay, when using airplay the audio only output through the HDMI. I guess the audio playing through airplay might not be using the same player as video playing and so might not support dual output.
Would that work with the digital output?
If not is there anyway (today) to achieve that?

Again thanks for those build and the amazing support you bring with it !
Reply
@coliemueller
Easiest is to put your SD in your computer.
If you do it via SSH or SFTP you need root previlages.

@carmenm
If you mean audio only (not airplaying video) I believe you are correct, dual audio is probabky not working with PAPlayer (yet).
As a temporary fix you can change default audio player back to omx and see if that works.
See post #1 how to do that.
You will not get visualisation with omx though.
Reply
  •   
  • 1
  • 25
  • 26
  • 27(current)
  • 28
  • 29
  • 119
  •   
 
Thread Rating:
  • 15 Vote(s) - 4.4 Average



Logout Mark Read Team Forum Stats Members Help
RaspBMC Kodi/XBMC test builds4.415
This forum uses Lukasz Tkacz MyBB addons.