•   
  • 1
  • 62
  • 63
  • 64(current)
  • 65
  • 66
  • 119
  •   
RaspBMC Kodi/XBMC test builds
The default (system) remote.xml is located in /home/pi/.xbmc-current/xbmc-bin/share/xbmc/system/keymaps
Remember though, .xbmc-current is a symlink to the active build so I don´t recommend editing/using that as a custom keymap as it will switch back to defaut when switching build, but good to know if you want to use it as a template.

Create remote.xml and put it in the folder keymaps in your user data: /home/pi/.xbmc/userdata/keymaps/remote.xml
This will override the default actions.

The following will use smallstepback when pushing back in fullscreenvideo:
Code:
<keymap>
  <FullscreenVideo>
    <remote>
      <back>SmallStepBack</back>
    </remote>
  </FullscreenVideo>
</keymap>

Just as an example of more things you can do, here is mine remote.xml:
Code:
<keymap>

  <global>
   <remote>
    <blue>XBMC.ActivateWindow(Favourites)</blue>
    <red>info</red>
    <yellow>XBMC.ActivateWindow(Home)</yellow>
   </remote>

  <keyboard>
   <key id="252">XBMC.RunScript("script.raspbmc.settings")</key>
  </keyboard>

  </global>

  <FullscreenVideo>
    <remote>
      <zero>PlayerControl(seekpercentage(99))</zero>
      <one>PlayerControl(seekpercentage(10))</one>
      <two>PlayerControl(seekpercentage(20))</two>
      <three>PlayerControl(seekpercentage(30))</three>
      <four>PlayerControl(seekpercentage(40))</four>
      <five>PlayerControl(seekpercentage(50))</five>
      <six>PlayerControl(seekpercentage(60))</six>
      <seven>PlayerControl(seekpercentage(70))</seven>
      <eight>PlayerControl(seekpercentage(80))</eight>
      <nine>PlayerControl(seekpercentage(90))</nine>
      <back>SmallStepBack</back>
    </remote>
  </FullscreenVideo>
  
</keymap>
The keyboard part was just a test if it was possible in remote.xml and it was. You can also use <remote> and <button id="xxxx">.
To find out which id a button has (or to see if the button is used by XBMC), turn on debug logging and look for "OnKey: xxxx pressed, action is yyyy".

Edit:
Another new feature in Gotham is up and down in fullscreenvideo which now is using ChapterOrBigStepForward/ChapterOrBigStepBack which is the same as BigStepForward/BigStepBack in Frodo.

But in Gotham BigStepForward/BigStepBack will not use chapters even if they exists, so if you don´t like chapters and want 10min steps always you can remap up and down to BigStepForward/BigStepBack.


@kl1k
The following will show more info on these builds, specifically what date it was compiled (+ kernel etc.):
Code:
grep Linux .xbmc/temp/xbmc.log | head -3
Reply
(2014-03-22, 07:52)miappa Wrote: @kl1k
The following will show more info on these builds, specifically what date it was compiled (+ kernel etc.):
Code:
grep Linux .xbmc/temp/xbmc.log | head -3

Awesome. thanks.

I am running the latest version. :Smile
Reply
(2014-03-22, 00:23)kl1k Wrote: Just started using these builds after using the stable for a long long time. Very impressive. Tons faster!

BTW is there a way to determine which nightly build you are on.
a grep of the xbmc.log says:
22:14:31 22.455128 T:3037074064 NOTICE: Starting XBMC (14.0-ALPHA1 Git:Unknown). Platform: ARM Linux 32-bit
An easier way than checking logs is simply to go to system information in the GUI and look at the compiled date - eg March 17, March 20 etc.
Kodi 18.3 - Mid 2007 Mac Mini, 4GB, 2TB HD, Windows 7 SP1
Kodi 18.3 - Vero4k, Raspberry Pi 2. OSMC.
Reply
@popcornmix - those multichannel files look good with the March 20th build :-) Thanks for taking a look!
Quote:08:46:00 661.293457 T:3027575872 DEBUG: CActiveAESink::OpenSink - SinkPi Initialized:
08:46:00 661.293640 T:3027575872 DEBUG: Output Device : HDMI
08:46:00 661.293823 T:3027575872 DEBUG: Sample Rate : 96000
08:46:00 661.293945 T:3027575872 DEBUG: Sample Format : AE_FMT_FLOAT
08:46:00 661.294128 T:3027575872 DEBUG: Channel Count : 6
08:46:00 661.294312 T:3027575872 DEBUG: Channel Layout: FL,FR,FC,LFE,BL,BR
08:46:00 661.294434 T:3027575872 DEBUG: Frames : 9600
08:46:00 661.294617 T:3027575872 DEBUG: Frame Samples : 57600
08:46:00 661.294739 T:3027575872 DEBUG: Frame Size : 24

@miappa - thanks for all the regular builds :-)
Reply
I'm following this guide
link
but when I run
Code:
pv xbmc-13-20140320-nc3.tar.gz | tar xzf - -C /home/pi/.upgrade
it says:
Code:
tar: /home/pi/.upgrade: function "open" failed: File or directory not existing
tar: Error is not recoverable: exiting now
164kB 0:00:00 [ 399kB/s] [>
Reply
That could mean .upgrade doesn´t exists.
This can probably be if you haven´t run Raspbmc settings addon or never installed a nightly. It´s actually the first time I hear of it though.
Just create .upgrade first and run the instruction again.

To do it via SSH:
Code:
mkdir -p /home/pi/.upgrade

Edit: I see the counter and "open" fails. Could it be that you didn´t download the tarball or that it didn´t download it properly?
Reply
(2014-03-22, 12:54)miappa Wrote: That could mean .upgrade doesn´t exists.
This can probably be if you haven´t run Raspbmc settings addon or never installed a nightly. It´s actually the first time I hear of it though.
Just create .upgrade first and run the instruction again.

To do it via SSH:
Code:
mkdir -p /home/pi/.upgrade

Edit: I see the counter and "open" fails. Could it be that you didn´t download the tarball or that it didn´t download it properly?


Yes, I'm running a clean raspbian sd.
What is Raspbmc setting addon? and I must install a nightly before following the guide?
Open fails is the translation to English of the Italian error message.
I run
Code:
mkdir -p /home/pi/.upgrade
and now I'm moving to the next step

Thanks
Reply
This is not for Raspbian, it+´s for Raspbmc.
However, have a look here: http://www.raspberrypi.org/forum/viewtop...12#p520212
It will not be supported in this thread though.
Reply
So is hifiberry wprking in this latest reubild?
Reply
Ok, so I cannot follow this thread to have xbmc running on a standard RaspBian image? Sad
Reply
@mcgyver83
Nope... different OS´s.
But have a look at the link in my last post, Dom has made an instruction to actually use these builds with sort of a hack, but it should work.
But as I said, keeo to that thread or make your own for support, it would be to confusing to discuss that here.

@jolle1
Well, depends. Only XBMC builds here, it will support it if your Raspbmc supports it, however since there has been no standard update for this yet you are on your own (see previously in this thread, people got it working).
Reply
Hi.
First of all thanks for this great test build!

I use rPlay for mirroring iphone in raspbmc, but I have a problem, everytime i close Xbmc GUI with remote script "<key id="0x4f093">XBMC.System.Exec("/scripts/xbmc.sh")</key> <!-- alt-f4 -->"

It works great for shutting down but when XBMC GUI shuts down also services needed for keyboard.xml stops working so I cannot turn it on with same remote button script.

Do you know if it is possible to "activate" only daemons for remote handling through XBMC or just shutting down overlay in XBMC for a black picture?


rPlay will not work on standard background in XBMC thats why I need to shut it down.


Many thanks in advance
Reply
There are probably many ways of achieving this, but I have no direct solution, perhaps someone else have an idea though.
One thing is certain though, you cannot use XBMC´s remote functions when it is shut down, I am quite certain that there is no way to achieve that.

One thought that came to mind, I know that many use similar solutions for emulators, i.e. have a look here: http://forum.stmlabs.com/showthread.php?tid=13180
You should be able to use scripts that starts rplay when XBMC is shut down, and also starts XBMC when rplay is shut down.

May I suggest that you take this to the Raspbmc forum though as it is not related to these builds.
Reply
Thank you very much and sorry for asking in the test forum. That link helped a lot!

By the way, I've had trouble with subtitle download since 20140311 build but now it works again, do you know if this has to do with the sqlite difference or have i messed something up?

It usually downloaded the subtitles but in log it never "links" it to played video. But whatever it was it is fixed now in latest releases from you.

thanks
Reply
If you mean subtitles for http streams its probably this that fixed it: 4367 (PR)
Otherwise I am not sure, there have been many fixes related to subtitles.
I don´t think that sqlite has anything to do with it though, but if I include that again and it breaks let us know.
Reply
  •   
  • 1
  • 62
  • 63
  • 64(current)
  • 65
  • 66
  • 119
  •   
 
Thread Rating:
  • 15 Vote(s) - 4.4 Average



Logout Mark Read Team Forum Stats Members Help
RaspBMC Kodi/XBMC test builds4.415
This forum uses Lukasz Tkacz MyBB addons.