•   
  • 1
  • 70
  • 71
  • 72(current)
  • 73
  • 74
  • 119
  •   
RaspBMC Kodi/XBMC test builds
@miappa

Thanks for the new build

I have one question, that someone here may be able to answer: - Clean Library
Clean Library runs very fast, from 1 to 100% in under 30 seconds, where on my other media PC,Frodo installed, this can take up to 2 minutes (Same video sources).
Now the question: Clean Library removes any removed TvShow, but doesn't remove any removed episodes.
What the??

So, after I run Clean Library, any episode I have deleted from my NAS, is still shown in XBMC Library under that show.
But, any TV Show I have deleted from my NAS, the Show and Episodes are deleted from XBMC Library.

I spotted a discussion, somewhere, about Gotham using a Quick Hash (something like that) when doing a Clean Library. Could this be the issue?
Media Companion Dev.
Media Companion - Kodi / XBMC - Media Companion
Reply
(2014-04-02, 17:44)krustyreturns Wrote: Our latest release (0.2.95) is in the pvr.wmc branch of our repo:

https://github.com/krustyreturns/xbmc-pv...ee/pvr.wmc

As to whether the other addons in our repo are up to date with opdenkamp I'm not sure. Scarecrow does try to keep it current.

Eventhough it looks to be all sorted I will just chime in and say, YES i merged all changes from the official (opdenkamp) repo into our (krustyreturns) repo. The pvr.wmc branch in our repo contains the latest from master as well as our changes. For frodo, it's the pvr.wmc_frodo branch.

The reason why our latest pvr.wmc changes are not in opdenkamp's repo is because that is the official repo and Gotham is in Beta so they arent accepting new features only bugfixes, so our latest stuff (Some of which is new features) does not meet the inclusion criteria
pvr.wmc TV addon and ServerWMC Backend Development Team
http://bit.ly/ServerWMC
Reply
(2014-04-02, 19:59)vbat99 Wrote: @miappa

Thanks for the new build

I have one question, that someone here may be able to answer: - Clean Library
Clean Library runs very fast, from 1 to 100% in under 30 seconds, where on my other media PC,Frodo installed, this can take up to 2 minutes (Same video sources).
Now the question: Clean Library removes any removed TvShow, but doesn't remove any removed episodes.
What the??

So, after I run Clean Library, any episode I have deleted from my NAS, is still shown in XBMC Library under that show.
But, any TV Show I have deleted from my NAS, the Show and Episodes are deleted from XBMC Library.

I spotted a discussion, somewhere, about Gotham using a Quick Hash (something like that) when doing a Clean Library. Could this be the issue?

Here's a XBMC debug log, where I re-started XBMC, and did a Clean Library. Then I went into a show that still showed episodes known to me to be deleted, and got the "Episode is missing, do you want to remove it from Library" (something like that) message.

If anyone can check this a see what may be causing the issue, would be greatly appreciated.
Media Companion Dev.
Media Companion - Kodi / XBMC - Media Companion
Reply
Working here, thanks for including updated wmc.pvr
If I have been of help, please add to my reputation as a way of saying thanks, it's free.
Reply
I'm using 20140402-nc3 and for the life of me can't get anything to AirPlay, my devices (Macbook air, Android "AirAudio" and Windows "TuneBlade") can all see the server, and appear to connect but I get nothing from XBMC at all (no audio and nothing on the screen). Is this a known issue at this stage or should I shoot some logs through?

Have updated the firmware to the version provided in the package.

EDIT: Did a total reset and fresh install of Raspbmc, problem still there, looks like a local issue as it _was_ working, can't work out what though Sad - Please disregard the above.
Reply
I uploaded a new build yesterday but forgot to post it. Here goes:

Updated Gotham build, XBMC master from Apr 04 + newclock3 commits + one additional commit.

Some info:
• Master: Some fixes and updates
• NC3: Ability to choose different scaling kernels (more info here)
• NC3: Only extract thumbnails and video info from real video stream
• Additional: WMC PVR addon V 0.2.95 included

Firmware from April 4th included
Edit: I missed that firmware was updated. The last firmware might cause issues (crashes/freezes), if you have problems please try to revert to March 30 firmware and see if that helps.

Additional info and testing (DVDPlayer etc.), see post #1

To install XBMC build, SSH to Pi:
Code:
wget -O xbmc-13-20140404-nc3.tar.gz http://goo.gl/yAe9hI --no-check-certificate
pv xbmc-13-20140404-nc3.tar.gz | tar xzf - -C /home/pi/.upgrade
sudo cp /home/pi/.upgrade/xbmc-13-20140404-nc3/{fixup_x.dat,start_x.elf} /boot
ln -sfn /home/pi/.upgrade/xbmc-13-20140404-nc3/xbmc-bcm /home/pi/.xbmc-current
sudo reboot
Reply
Personally I am having huge problems on last build, but I am not sure if it´s the actual build, my specific setup or the last commit to newclock3.
Thought it might be time to do a fresh install, everything is fine until I add anything to the library on latest build.

XBMC freezes as soon as I add anything to the library. Running on fresh userdata works, but as soon as I add the MySQL to as.xml it freezes soon after startup.
I also tried with a fresh MySQL database, no go.
Reverting to previous build works.

It´s been difficult to fetch any logs as it freezes, if I find time I will certainly grab some logs.
But, could also be something with my setup or something that went wrong during compilation (no errors though).

Anyone else tested yet?
Reply
I can confirm that xbmc-13-20140404-nc3 causes my pi to reboot after it starts scanning a new folder in the library. I'm not using the mysql backend.

It also left me with a blank sources.xml file, I don't know if that was a code bug or file system corruption. There was nothing unusual in the logs, but I didn't have debug turned on.
Reply
Same thing here. I did a fresh install of Raspbmc and xbmc-13-20140404-nc3. The pi rebooted when scan started. That is happening with xbmc-13-20140402-nc3 too.

[EDIT]
Well, this is happening too with xbmc-13-20140330-nc3. My new install is pretty messed up and very unstable. I have an old install on the same model of SD card wich runs xbmc-13-20140330-nc3 and I have no problem with it (but I don't do massive scan with it, only new addition one by one). The only change I see is that recent releases of Raspbmc use f2fs, which is nevertheless pretty faster.
Reply
Hi,
sorry, my pi rebooted when i startet a search in youtube-addon. (also release bevor)
...this happend on 3 Raspis.

Also i recognize, that a part of addons don't work, but i think, that not a problem of this builds.

thx
doldi
Reply
Made a new build and same problem (see here).
I could reproduce it on first boot where all images was corrupted and Pi rebooted after a short while (≈30 seconds)
After reboot it was more difficult to reproduce, everything worked for a (short) while so decided to test to add a new movie to library.
That went fine, but as soon as I highlighted the new movie, no images showed and Pi rebooted after 10 seconds.
On next boot, highlight new movie showed corrupted fanart and froze. Could still SSH though, but not stop XBMC properly or even do a reboot so I had to pull the plug (same every time).

Log after adding new movie and crash/reboot: http://xbmclogs.com/show.php?id=166973
Unfortunately it only shows corruption, however xbmclogs does not show it. The last row is a bunch of squares in the real log (one very long row).

Log after second attempt, where it shows corrupted image and freezes: http://xbmclogs.com/show.php?id=166974
Unfortnately doesn´t show much either…

(syslog shows nothing)

Will test without ”Only extract thumbnails and video info from real video stream” and report back (maybe tomorrow)
Reply
Sounds like filesystem corruption and possibly bugs in the filesystem code triggering a kernel panic when reading the corrupt filesystem on subsequent boots... Have you tried ext4 instead of f2fs ?

As you read in another thread I was experiencing corruption of guisettings.xml when doing a hard reset with f2fs, I'm yet to reproduce that with ext4...
Kodi 18.3 - Mid 2007 Mac Mini, 4GB, 2TB HD, Windows 7 SP1
Kodi 18.3 - Vero4k, Raspberry Pi 2. OSMC.
Reply
Running one Pi with ext4 (main Pi, fresh install today but same problems on old install from yesterday) and the other with f2fs, same problem on both with 2 latest builds (latest not posted here).
And it´s not proper corruption, it´s more of a temporary corruption (memory). When I reverted to en earlier build, even new images that looked corrupted now was fine.
Should have mentioned, I also tried everything when you suspect corruption (fresh install, reduced OC, different power supplies and as I mentioned 2 Pi´s with 2 different file systems).

And, as you see, 3 more people reported same problem.
Edit: I take that back, seems like at least a couple might have different issues. April 2 and previous is 100 % stable for me while 3 different builds from April 4 and 5 is not.

Right now I am running an identical build with the ”Only extract thumbnails and video info from real video stream” reverted, and it works fine so far, but to early to tell yet.
Will play around with it, add new movies etc., and report back.

Edit2: I noticed that I created tarball of the wrong directory (same date equals problems) so I have not tested this properly yet.

For now, anyone that get this problem I recommend to revert/stay on April 2nd build, I´ll post a new build if I find something.
Reply
Me too.
If I goto the live-tv recording then get a reboot.

I hope the downgrade is simple. 😐
Reply
You can switch builds in Rasbmc Settings just like always. Quite easy. Wink

But if you have the same problem as I had (XBMC freezes or reboots before you have time to do anything), SSH in as soon as it´s possible and run the following:
Code:
ln -sfn /home/pi/.upgrade/xbmc-13-20140402-nc3b/xbmc-bcm /home/pi/.xbmc-current
And reboot.
The above line of course only if you have the April 2nd build installed, otherwise change it to whatever build you want to switch to.
Reply
  •   
  • 1
  • 70
  • 71
  • 72(current)
  • 73
  • 74
  • 119
  •   
 
Thread Rating:
  • 15 Vote(s) - 4.4 Average



Logout Mark Read Team Forum Stats Members Help
RaspBMC Kodi/XBMC test builds4.415
This forum uses Lukasz Tkacz MyBB addons.