•   
  • 1
  • 22
  • 23
  • 24(current)
  • 25
  • 26
  • 119
  •   
RaspBMC Kodi/XBMC test builds
I don´t think I can access it at all (geolock), but I am sure bleep and others are willing to test.
I´ll make a new build later today.
Reply
Yep, no problem :-)
Let me know.
Kevin.
Reply
@ Miappa

I always used your Test builds. And I know you told me that external soundcard support is not yours.

Unfortunately your testbuilds will kill the external soundcard support completely.

I did this 2 times :

RASPBMC 12.2 from scratch - enabling soundcard support : working but not usable - crackling and noisy
Switching to RASPBMC 13 Alpha from Dec 23 2013 : working better, with Soundblaster nearly good
Switching to your testbuild : no external sound anymore
Switching back to Sams Nightly or back to 12.2 does not help : Soundcards don´t work again although support is enabled

hmm..
I don´t have enough knowledge to see where the problem can be found Sad

It would be really great to get a testbuild with working external soundcards
I have a Soundblaster NX and a Soundbox 7.1
Reply
Unfortunately I have no idea how this works, I am also uncertain if it will break things since ActiveAE was introduced.
So I do not include Sam´s omxalsa patch at all at the moment.

There are virtually no support here for this as it´s not a XBMC feature, it´s a Raspbmc feature, so it´s important that you go to the Raspbmc forum for support regarding this.
And, I am not a developer, the work stupidboy did and Sam took over is far beyond my knowledge.

I will however from now on always announce IF omxalsa patch is included so you know what build to test, I have not always done that.

Edit: However, I believe that release version (Frodo) is the only supported version...
Reply
Updated Gotham build, based on XBMC master Jan 14 with newclock3 commits.
Similar to recent builds but with fixes for when dvdplayer defaults (addons and airplay) and some things in XBMC master.

For passtrhough and paplayer and/or dvdplayer, see this post and what to test.
OMXPlayer can still be used for audio (context menu or set in advancedsettings.xml).

If you don´t have libdvdcss already you will have to compile this as explained in post #1.
Nov/Dec update or latest firmware from master tree recommended, also explained in post #1.

To install, SSH to Pi and (note the ” .” (space + dot) in the end of the cp command!):
Code:
cd .upgrade
wget -O xbmc-13-20140113-nc3.tar.gz http://goo.gl/VBgZhZ --no-check-certificate
mkdir -p xbmc-13-20140113-nc3
tar -xzf xbmc-13-20140113-nc3.tar.gz -C xbmc-13-20140113-nc3
cd xbmc-13-20140113-nc3/xbmc-bcm/xbmc-bin/lib/xbmc/system
cp /usr/local/lib/libdvdcss.so.2.1.0 .
ln -sf libdvdcss.so.2.1.0 libdvdcss.so.2
ln -sf libdvdcss.so.2 libdvdcss.so
Then in Raspbmc, go into "Raspbmc Settings/Nightly Build Configuration/Switch Between Versions of XBMC", and choose new build + restart XBMC.

If you come from an old build or from Frodo, deleting guisettings.xml is recommended.
Also, re-check all settings as some things can change and/or revert to default.
Reply
Hi Miappa & Popcornmix,
Thank you very much, Iplayer now works fine with your latest update, xbmc-13-20140113-nc3.

Thanks again.
Kevin.
Reply
New install xbmc-13-20140113-nc3

No sound at all, PCM 16/44.1, neither HD, tried with the 3 players (context right click)
Huh
Config, audio player only:
2T HDD <USB> RPi2/Kodi <HDMI> Denon AVR-2313 <HDMI> LG TV 55UF860V
Reply
(2014-01-13, 13:14)miappa Wrote: Shouldn´t be after 'apt-get install -y gcc make', haven´t heard anyone else with this problem either.
Have you followed the instructions on first page line by line?

Yes I cut and pasted it line by line twice, strange

Turns out there was something wrong with the sdcard. Using another works fine
Reply
(2014-01-13, 22:26)MrNice Wrote: New install xbmc-13-20140113-nc3

No sound at all, PCM 16/44.1, neither HD, tried with the 3 players (context right click)
Huh

Check settings/system/audio look correct. Updating from an older build can leave some settings undefined.

Try switching to analogue and confirm that works, then switch back to hdmi.
Reply
xbmc-13-20140113-nc3
I checked the set-up was good.
I changed sound to analogue, sound PCM was good but I lost analogue video. I could ssh and I shut down it.
After some reboot, video was back (why?) and I set-up to HDMI.

Connected to AVR
First boot was low video resolution and no sound at all with 3 players. Did nothing on set-up.
Reboot and got hi video resolution, sound PCM 16/44.1 was back.
HD/MCH audio is still playing at 1 second every 2 or more.

CEC
Set-up to switch on and off the AVR when Pi start/shut down
When Pi start, it doesn't switch on the AVR
When Pi shut down it do switch off the AVR

Is there a sure method to update and have a expected behaviour?
Config, audio player only:
2T HDD <USB> RPi2/Kodi <HDMI> Denon AVR-2313 <HDMI> LG TV 55UF860V
Reply
@MrNice
Quote:Is there a sure method to update and have a expected behaviour?
Edit: perhaps I misunderstood this. Did you mean to have a working version in general? If so;
Not really, these are test builds, not official "stable" releases. For many it is quite stable though, but your setup seems very specific.
If you want to test and report on issues and/or what works, it will be appreciated. More specifics might be needed though such as debug logs etc.

But maybe you just want a working version without having to test and report. If this is the case and these builds is not working the way you want, perhaps you should stick to release version or test previous builds.
Reply
Updated Gotham build, based on Jan 14, ”clean” clone from newclock3 (though prior to the last 6 patches I see there now…)

• Everything in XBMC master (xslt commits included)
• Improved playback for high samplerate/multichannel/passthrough using paplayer

If you don´t have libdvdcss already you will have to compile this as explained in post #1.
Dec update or latest firmware from master tree recommended, also explained in post #1.

To install, SSH to Pi and (note the ” .” (space + dot) in the end of the cp command!):
Code:
cd .upgrade
wget -O xbmc-13-20140114-nc3-xslt.tar.gz http://goo.gl/YdsLjQ --no-check-certificate
mkdir -p xbmc-13-20140114-nc3-xslt
tar -xzf xbmc-13-20140114-nc3-xslt.tar.gz -C xbmc-13-20140114-nc3-xslt
cd xbmc-13-20140114-nc3-xslt/xbmc-bcm/xbmc-bin/lib/xbmc/system
cp /usr/local/lib/libdvdcss.so.2.1.0 .
ln -sf libdvdcss.so.2.1.0 libdvdcss.so.2
ln -sf libdvdcss.so.2 libdvdcss.so
Then in Raspbmc, go into "Raspbmc Settings/Nightly Build Configuration/Switch Between Versions of XBMC", and choose new build + restart XBMC.

If you come from an old build or from Frodo, deleting guisettings.xml is recommended.
Also, re-check all settings as some things can change and/or revert to default.
Reply
Quote:@MrNice

Quote:Is there a sure method to update and have a expected behaviour?

Edit: perhaps I misunderstood this. Did you mean to have a working version in general? If so;
Not really, these are test builds, not official "stable" releases. For many it is quite stable though, but your setup seems very specific.
If you want to test and report on issues and/or what works, it will be appreciated. More specifics might be needed though such as debug logs etc.

But maybe you just want a working version without having to test and report. If this is the case and these builds is not working the way you want, perhaps you should stick to release version or test previous builds.

What I mean is:
When I update to a new build and there are "bugs", I am not sure if this is a real bug or this is caused by a changed setup.
Quote:Check settings/system/audio look correct. Updating from an older build can leave some settings undefined.
It could be good to get a list of files to save before the update and replace after, maybe with a script.

I am happy to help to debug when I have the time, but I only can test audio as I don't have a CEC-TV but a monitor (1680x1050). I only use the RPi to play music.
Soon I'll learn how to grab the log and post it here.

My needs for a good music player are not done yet:
- Play PCM 13/44.1 (done)
- Play (pass-through) HD MCH (DTS, AC3, DD, etc) (done)
- CEC control with 1 remote control for config without CEC-TV (to be done)(CEC standard can work without CEC-TV)

For the last point there is CECAnyway and I am waiting for a a build including it. Any chance?
Config, audio player only:
2T HDD <USB> RPi2/Kodi <HDMI> Denon AVR-2313 <HDMI> LG TV 55UF860V
Reply
I noticed afterwards that I probably misunderstood you but wasn´t sure (sorry about that).

To clarify, these builds only contains XBMC, nothing outside of XBMC is included (it is not Raspbmc test builds, rather XBMC test builds for Raspbmc).
Quote:It could be good to get a list of files to save before the update and replace after, maybe with a script.
If you mean backup, it would be your userdata folder, namely /home/pi/.xbmc. Easiest and fastest way to backup is to create a tar archive.
If you are switching between Gotham builds you normally do not have to worry about this, but sometimes settings changes or are added and the file to keep an eye on is guisettings.xml.

If you mean that you want to be 100% certain that there are no bugs caused by changes in settings etc., delete guisettings.xml, preferably when XBMC is stopped (this will make XBMC create a new proper file when XBMC boots).

CECAnyway
This is something outside of XBMC. Perhaps a feature request for Raspbmc?
Pulse-eight; I actually goolged this and found out that you have been investigating this Smile , I had the impression that you should be able to change the logical adress to 5 (and perhaps change the port number) to get it to work solely with an AVR, but perhaps this is not so (?).

Do I understand you correct that PCM and passthough works for you now? Which player? Is this with the latest build?
Reply
Test built xbmc-13-20140114-nc3-xslt

I did the test only with default player
Sound
PCM 16/44.1 is good
MCH, center channel looks to be LF or so, RL is out from center and RR is out from RL.
Test file:
Wave
PCM
Constant
4 234 Kbps
6 channels
Front: L C R, Back: L R, LFE
44.1 KHz
16 bits

Another test file has drops for 1/4 s every few seconds:
2L38SACD_tr1_mch_96kHz.flac
Variable
7 005 Kbps
6 channels
Front: L C R, Back: L R, LFE
96.0 KHz
24 bits

The issue drop was fixed few months ago, I think. I don't understand why this is back.

CEC
No CEC power on/off for my AVR
Config, audio player only:
2T HDD <USB> RPi2/Kodi <HDMI> Denon AVR-2313 <HDMI> LG TV 55UF860V
Reply
  •   
  • 1
  • 22
  • 23
  • 24(current)
  • 25
  • 26
  • 119
  •   
 
Thread Rating:
  • 15 Vote(s) - 4.4 Average



Logout Mark Read Team Forum Stats Members Help
RaspBMC Kodi/XBMC test builds4.415
This forum uses Lukasz Tkacz MyBB addons.