•   
  • 1
  • 31
  • 32
  • 33(current)
  • 34
  • 35
  • 119
  •   
RaspBMC Kodi/XBMC test builds
(2014-02-05, 22:22)nalor Wrote: I somehow had the hope that the last dvdplayer fixes would also solve the dvd-menu problem, but unfortunately they didn't.

There are some fixes not in the last miappa build. They are in the last Milhouse openelec build.
I'm sure there will be an updated miappa build before long.
Reply
Thanks for the info!

That sounds really promising!

Looking forward to find the changes in one of the upcoming miappa-builds Smile

(and just in case someone else is also interested in details to the fixes, here's the link to the announcement of Milhouse: http://forum.xbmc.org/showthread.php?tid...pid1619652 - take a look at the last entry in the 'Build highlights' section )
Reply
Edit: Updated as I was not certain alsa was enabled in first build (probably was though). New build called *-2.

Updated Gotham build, XBMC master from Feb 06 + newclock3 commits.

Some info:
• Many fixes in master regarding MySQL and databases. NB! Music and video db versions has been bumped!
• Allow still frames to return from codec (should improve DVD menu´s)
• Allow AV sync type to be enabled
• + same newclock3 commits as previous build (koying´s libcurl/openssl PR reverted)

Recommendations:
• Libdvdcss (see post #1), this might be required
• Firmware from master, Feb 02 or later, recommended (required for some things, see post #1)
Fresh guisettings.xml if you come from Frodo or old Gotham
• Recheck all settings after install

For DVDPlayer testers, see post #1 (Alternative players).

To install, SSH to Pi:
Code:
cd .upgrade
wget -O xbmc-13-20140206-nc3-mysql-2.tar.gz http://goo.gl/IMgrOV --no-check-certificate
mkdir -p xbmc-13-20140206-nc3-mysql-2
pv xbmc-13-20140206-nc3-mysql-2.tar.gz | tar xzf - -C xbmc-13-20140206-nc3-mysql-2
cd xbmc-13-20140206-nc3-mysql-2/xbmc-bcm/xbmc-bin/lib/xbmc/system
cp /usr/local/lib/libdvdcss.so.2.1.0 .
ln -sf libdvdcss.so.2.1.0 libdvdcss.so.2
ln -sf libdvdcss.so.2 libdvdcss.so
Activate new build in "Raspbmc Settings/Nightly…/Switch…”, choose new build + restart XBMC.
Reply
Tried the new miappa-build and also the OpenELEC-Milhouse Build from yesterday, but in my case the problems with the still menu's not shown during dvd playback are not solved.
I still get only a black screen after the first trailer.... (where I get a menu with a still-background on other platforms)

Here's my debug log:
Debug Log

After looking a couple of minutes at the black screen I stopped playback and copied the logfile - hope it helps to fix this bug.

Thanks in advance!
Reply
First of all, thanx for making these builds, much appreciated.

I have the same issues as Nalor - and unfortunately the last build didn't do anything about the isue with DVD menus.
Reply
I can only confirm that on two DVD iso´s that previously somewhat worked (stalled when choosing something in menu) now works perfectly, menu´s included.

@nalor
Have you enabled "Attempt to skip introduction..."?

@jjkongen
Same question, but also, is this on all DVD´s you got? If so, even if I am not sure how to debug this, a debug log is always good.
Reply
Hi

Log file: http://xbmclogs.com/show.php?id=126191

Tried with both Attempt to skip introduction on and off, no difference in problematic ones.

I would say 60% of the menus run fine, but around 40% has flaws. In this log I've included The Drew Carey Show, Big Bang Theory, Mash and The Conjuring.

In the Drew Carey show the screen stays black for around 10 seconds and the the menu starts, the sound and menu is active because if I press enter after f.ex. 2 seconds, the episode starts.
In The Big Bang Theory: The sound is active but it takes about 30 seconds for the picture to come on, as on The Drew Carey show the sound and menu is active long before the menu picture comes on.

With Mash it starts the FBI warning and runs this fine, it then goes to the menu where the screen stays black. The menu is active because if press enter the episode starts.

In The Conjuring sound starts but no picture. I can press enter and the movie starts.

//JJ
Reply
Hi

I haven't tried the "Attempt to skip introduction..." option because maybe this would help to get into the main menu, but for example most times the submenus for bonus content are also affected by the bug - so in the end I still would have to wait for a final bugfix to this issue.

And as this kind of workaround has never been necessary on xbmc-windows (or the old xbmc4xbox) it shouldn't also be necessary on the rpi Smile

I'll continue to hope and pray that it will be fixed soon!

Thanks in advance!
Reply
Updated Gotham build, XBMC master from Feb 08 + newclock3 commits + additional fixes.

Some info:
Setting related fixes (not in master)
Libdvdread/nav/css bumped (not in master)
• Fix for manual search in subtitle services
• + same newclock3 commits as previous build (koying´s libcurl/openssl PR reverted)

Recommendations:
• Libdvdcss (see post #1), this might be required
• Firmware from master (Feb 02 or later) recommended (required for some things) (see post #1)
Fresh guisettings.xml if you come from Frodo or old Gotham
• Recheck all settings after install

For DVDPlayer testers, see post #1 (Alternative players).

To install, SSH to Pi:
Code:
cd .upgrade
wget -O xbmc-13-20140208-nc3.tar.gz http://goo.gl/tY4YRr --no-check-certificate
mkdir -p xbmc-13-20140208-nc3
pv xbmc-13-20140208-nc3.tar.gz | tar xzf - -C xbmc-13-20140208-nc3
cd xbmc-13-20140208-nc3/xbmc-bcm/xbmc-bin/lib/xbmc/system
cp /usr/local/lib/libdvdcss.so.2.1.0 .
ln -sf libdvdcss.so.2.1.0 libdvdcss.so.2
ln -sf libdvdcss.so.2 libdvdcss.so
Activate new build in "Raspbmc Settings/Nightly…/Switch…”, choose new build + restart XBMC.
Reply
Im getting dependencies not met with MySql connector/python (previous build). Can I disable? Dont know what it does
[Image: thin.jpg]
Reply
I think there is a bug with video streams:
When you pause any internet video stream like YouTube and resume it, it will play fine for about 30seconds. But then the image will freeze and the audio will play a loop from the pause break. When you skip forward/backward it will resume playing fine.

I don't know when this bug happened first. Perhaps with introducing the new buffer method.
It doesn't occur with local video files from a usb device. I can't test streaming from a local device.

Last firmware.
Nightly build #469.
Omxplayer.
Reply
@ fernandovg
This is a service that is installed together with one of your addons. There are many versions and yours is apparently not updated.
You could try to find out what addon is using this service and see if there is an updated version for Gotham.

@namtih
Sounds like a bug if you can reproduce it, but difficult to know what is causing it and if there is an issue with the addon or XBMC (or both).
Debug log should show what´s going on.
Reply
(2014-02-09, 10:44)namtih Wrote: I think there is a bug with video streams:
When you pause any internet video stream like YouTube and resume it, it will play fine for about 30seconds. But then the image will freeze and the audio will play a loop from the pause break. When you skip forward/backward it will resume playing fine.

I don't know when this bug happened first. Perhaps with introducing the new buffer method.
It doesn't occur with local video files from a usb device. I can't test streaming from a local device.

Sounds like this issue (reported with iplayer)
http://forum.stmlabs.com/showthread.php?tid=7577

As far as I know it's always been there and affects all platforms.
I'd be interested if it's any better when configuring dvdplayer as the default player.
Reply
I stand corrected. The issue doesn't occur with the YouTube addon. So it's likely an issue in combination with the iplayer you have mentioned.
I've used the video addon "spiegel.tv". Here is a log with the omxplayer:
http://pastebin.com/njT5zVA4

The issue also occurs with the dvdplayer. But with the difference that also the image/picture jumps back and that it only jumps back once and then plays fine.
http://pastebin.com/0FU23HGC

Info: I had to delete some parts from the logs as it exceeds the maximum file limit.
All lines like this, which occurs very often:
17:20:08 27775.328125 T:2818565184 DEBUG: COpenMaxVideo::ClearPicture - 0xa99a3540
17:20:08 27775.328125 T:2818565184 DEBUG: COpenMaxVideo::GetPicture 0xa96f3340->1 (0xa7ffdb80)
17:20:08 27775.347656 T:2818565184 DEBUG: COpenMaxVideo::ReturnOpenMaxBuffer 0xa98f2dd8 (2)
17:20:08 27775.347656 T:2818565184 DEBUG: COpenMaxVideo::ReturnOpenMaxBuffer FillThisBuffer(0xa98f2dd8) 0xa9544170->0
Reply
First off, thanks for the fix for non-square pixels (I'm assuming it's this that fixed the aspect ratio of recorded tv.) Since that I've been using DVD Player fulltime and love it!

Question, has something changed with the Lirc keymaps in the last couple of builds? With both the 6th and 8th builds, XBMC is no longer responding to the KEY_BACK and KEY_HOME actions, though all others seem fine. A switch back to the build from the 4th and they work as expected. An extract from my log...

Code:
19:14:11 215.895935 T:3038363648   DEBUG: LIRC: Update - NEW at 190631:66 0 KEY_HOME devinput (KEY_HOME)
19:14:11 216.294556 T:3038363648   DEBUG: LIRC: Update - NEW at 191030:66 0 KEY_HOME_UP devinput (KEY_HOME_UP)
19:14:11 216.322220 T:3038363648   DEBUG: LIRC: Update - NEW at 191058:9e 0 KEY_BACK devinput (KEY_BACK)
19:14:11 216.660721 T:3038363648   DEBUG: LIRC: Update - NEW at 191396:9e 0 KEY_BACK_UP devinput (KEY_BACK_UP)
19:14:12 216.843140 T:3038363648   DEBUG: LIRC: Update - NEW at 191578:69 0 KEY_LEFT devinput (KEY_LEFT)
19:14:12 216.844025 T:3038363648   DEBUG: OnKey: 169 (0xa9) pressed, action is Left
19:14:12 217.201416 T:3038363648   DEBUG: LIRC: Update - NEW at 191937:69 0 KEY_LEFT_UP devinput (KEY_LEFT_UP)
19:14:12 217.308228 T:3038363648   DEBUG: LIRC: Update - NEW at 192042:6a 0 KEY_RIGHT devinput (KEY_RIGHT)
19:14:12 217.309143 T:3038363648   DEBUG: OnKey: 168 (0xa8) pressed, action is Right
19:14:13 217.675461 T:3038363648   DEBUG: LIRC: Update - NEW at 192411:6a 0 KEY_RIGHT_UP devinput (KEY_RIGHT_UP)

Thanks again for these builds.
Reply
  •   
  • 1
  • 31
  • 32
  • 33(current)
  • 34
  • 35
  • 119
  •   
 
Thread Rating:
  • 15 Vote(s) - 4.4 Average



Logout Mark Read Team Forum Stats Members Help
RaspBMC Kodi/XBMC test builds4.415
This forum uses Lukasz Tkacz MyBB addons.