•   
  • 1
  • 50
  • 51
  • 52(current)
  • 53
  • 54
  • 119
  •   
RaspBMC Kodi/XBMC test builds
(2014-03-07, 20:08)Dilligaf Wrote: Try putting it in advancedsettings.xml it shouldn't be overwritten there
Thx, solved the problem partially. XBMC is still muted entering the audio settings, but after a restart HifiBerry is working again as default.

I'm more worried about the stuttering that the kernel 3.10.32 introduced. It seems that every 10 seconds a couple of frames are freezing. They are not marked as dropped.

I see it also in the OpenGL visualisation playing audio files. Exactly every 10 seconds.
Don't see anything in the (debug) logs, at that time.
Does anyone else experience this?
Code:
[email protected]:~$ vcgencmd version
Feb 28 2014 16:43:10
Copyright (c) 2012 Broadcom
version a9ba6435869933cdfd1ad5631b6b9a97affd8806 (clean) (release)

uname -a
[email protected]:~$ uname -a
Linux raspbmc 3.10.32+ #648 PREEMPT Fri Feb 28 16:29:56 GMT 2014 armv6l GNU/Linux

XBMC
Latest Mar 6 miappa build
Reply
Where's the best place I can add MillhouseVH texturecache script to start after xbmc.bin is up?

I am using this for turning off the TV via CEC after 15 minutes of inactivity, so this needs to run every reboot
Current command is
Code:
/home/pi/texturecache.py @logfile=/home/pi/t4.txt @debug=yes @xbmc.host=localhost '@bin.tvservice=/home/pi/mytv.sh

I've added this to rc.local as
Code:
sleep 20 && /home/pi/texturecache.py @logfile=/home/pi/t4.txt @debug=yes @xbmc.host=localhost '@bin.tvservice=/home/pi/mytv.sh
which seems to work.

But is this the correct location?

Thanks in advance.Big Grin
Media Companion Dev.
Media Companion - Kodi / XBMC - Media Companion
Reply
rc.local would have been my suggestion, it´s what I have used when playing around with scripts on boot.
But I am certainly no expert, perhaps someone else with better knowledge will jump in, but this question is far better suited for the Raspbmc forum: http://forum.stmlabs.com/forumdisplay.php?fid=7
Reply
Thanks miappa

I have it working now.

My Pi now tells my TV to turn off after 420 seconds, with any remote key waking up the TV.
Without the "virtual suspend" the only draw-back is the XBMC is shut-down on tv off, and XBMC is re-started when a key is pressed. This means if you were on 'Tomorrow People' in TV Shows when this activates, you start back at the beginning of your TV list when it restarts.

Hopefully "virtual suspend" will be fixed and added back to test builds later down the track.
Media Companion Dev.
Media Companion - Kodi / XBMC - Media Companion
Reply
(2014-03-06, 22:53)miappa Wrote: To install XBMC build, SSH to Pi:
Code:
cd .upgrade
wget -O xbmc-13-20140306-nc3.tar.gz http://goo.gl/69gZd4 --no-check-certificate
...
Shouldn't we advice people to install `ca-certificates` instead of using `wget --no-check-certificate` all the time
The reason people have difficulties downloading with wget is because `ca-certificates` isn't installed by default on Raspbmc.

Most people probably play media with these great XBMC builds on the Pi, the Pi has an educational task too.
I would say:
- trust certificates (NSA!) and use them
- don't use ` --no-check-certificate ` by default
-
Code:
sudo apt-get install ca-certificates

I think the `ca-certificates` package should be installed by default in Raspbmc, what would be the best way to bring this to Sam's attention?
Reply
Thought about this but don´t want to force people to modify Raspbmc to be able to run these builds.
I know, dvdcss was an issue so I had to do something, and firmware is another thing you might have to modify, but I try to keep it as default as possible.

There is a feature suggestion at the Raspbmc forum, might be a good idea to post there.

Edit: Though, come to think of it, since dvdcss is pretty much needed I could actually add it to that instruction. Sort of makes sense too since wget is used there as well. Will think about it...
Reply
sorry if i missed this somewhere, but i remember a while back dual audio (both HDMI and analog at the same time) was working on raspbmc, i havent tried it on the main release, i just was trying to enable it on the latest nightly here and found it missing. did i miss that getting removed from raspbmc? thanks
Reply
Dual audio is only working with OMXPlayer for the moment.

Edit: Sorry, you meant that it is not available in Settings? It should be (named Dual audio output). Remember to enable Advance or Expert settings level.
Reply
(2014-03-08, 12:57)miappa Wrote: Thought about this but don´t want to force people to modify Raspbmc to be able to run these builds.

IMHO installing a package from the default repositories isn't hacking Raspbmc, just installing an (missing) available program, needed to let wget do its jobs safely and securely.

Thx anyway.

I installed a new kernel to get the HifiBerry working with rpi-update, old kernel is automatically backed up in boot.bak en /lib/modules.bak.
I tried to revert that manually, and got my default kernel running again without a fresh install. Apparently working fine.

But the rpi-update also writes new files to /opt/vc, for which a backup isn't made. I guess those files are GPU related. Are they linked to a specific kernel or just general improvements?

@popcornmix, what are your thoughts about downgrading a kernel this way?
Reply
(2014-03-08, 14:36)miappa Wrote: Dual audio is only working with OMXPlayer for the moment.

Edit: Sorry, you meant that it is not available in Settings? It should be (named Dual audio output). Remember to enable Advance or Expert settings level.

yeah i didnt see it in settings, i have looked for somewhere to enable advanced settings but must be blind, i cant find it Smile i will continue to look thanks
Reply
Bottom left of settings windows where it says "Settings Level" click on it to change level to Advanced or Expert. This is with Confluence skin, if usin another skin it may not be supported.
If I have been of help, please add to my reputation as a way of saying thanks, it's free.
Reply
ah i see it now, had to switch to confluence to enable it and then switch back to the skin i am using, thanks for pointing this out to me

edit
seems it isnt working anymore? i amon confluence skin, i have music playing, i have dual audio output checked, speakers hooked upto the analog out, but no music is coming thru, only thru hdmi on tv, \\. if i set output to analog then my speakers are working...am i doing something wrong?
Reply
Again, dual audio only works with OMXPlayer.
Either use "Play using..." -> OMX... or set OMX as default in advancedsettings (see post#1).
The later is needed for internet streams and airplay.
Reply
ah my bad, i see now that default now papplayer, ok so it is working nicely...except that it isnt synched, 1 is a little faster than the other, but that is not your issue Big Grin
thanks for your help
Reply
Hey Miappa, please - can You help me?

In this (very fast working!) build the sound have the same problem like the (last) - among the streams thera are for a half second terrible "White noise"
I've testes some adjustment in System analog without dual Audio/HDMI with dual Audio ....think - alll 've been tested.

I want the "all-in-one device suitable for every purpose" :-) .....no. i am happy if the standart works fine.

Liebe Grüße
doldi
Reply
  •   
  • 1
  • 50
  • 51
  • 52(current)
  • 53
  • 54
  • 119
  •   
 
Thread Rating:
  • 15 Vote(s) - 4.4 Average



Logout Mark Read Team Forum Stats Members Help
RaspBMC Kodi/XBMC test builds4.415
This forum uses Lukasz Tkacz MyBB addons.