•   
  • 1
  • 60
  • 61
  • 62(current)
  • 63
  • 64
  • 119
  •   
RaspBMC Kodi/XBMC test builds
(2014-03-17, 05:17)sirhcjw Wrote: I am seeing a strange version on my raspbmc after I updated to the latest build form here today xbmc-13-20140315.

It shows as XBMC 14 alpha 1 in the system info page.

Can anyone explain this to me please.

Cheers

Chris

my thoughts exactly! shouldnt this be built on Gotham BETA1??
Reply
@RalphUp
See my answer in post #904.
Edit: And no, there aren´t anything that limits test builds to betas here (or anything really), I´ll post whatever test builds I feel necessary, but right now it´s the same anyway.


@DBMandrake
My thought was that this can be the case, but obviously I am not certain.
So no need to try to fix it in that build until you have tested the next on (should have it ready within a couple of hours).

Edit: Regarding delay, have a look in /scripts/xbmc-watchdog
Reply
(2014-03-17, 16:49)miappa Wrote: Edit:
Wait... See discussion here (avahi): 4414 (PR)
Maybe this is the cause and the updated version will help. Wait until next build instead and test.
Adding a delay to /scripts/xbmc-watchdog.sh didn't seem to help, however I have noticed that the crash point is non-deterministic and stops at a different point each time. For example here are two additional runs (each from a full reboot) where the crash and log file termination occurs at a different point:

http://paste.debian.net/88194/

http://paste.debian.net/88195/

I'll wait for the next build before running around doing any further testing.

Edit: sorry I just noticed I turned advanced debugging off before I took those two logs, although I guess the point remains that they didn't both stop in the same place.


(2014-03-17, 17:43)miappa Wrote: @DBMandrake
My thought was that this can be the case, but obviously I am not certain.
So no need to try to fix it in that build until you have tested the next on (should have it ready within a couple of hours).

Edit: Regarding delay, have a look in /scripts/xbmc-watchdog
Snap Smile
Kodi 18.3 - Mid 2007 Mac Mini, 4GB, 2TB HD, Windows 7 SP1
Kodi 18.3 - Vero4k, Raspberry Pi 2. OSMC.
Reply
Updated Gotham build, XBMC master from Mar 17 + newclock3 commits + additional commits.

Some info:
• Now in master: DVD various fixes related to libdvdnav issues and skip to menu
• NC3: [omxplayer] When in dual audio mode, make one output the slave
• NC3: Updated Airplay/iOS7.x fix (PR #4414) + removed old airplay patches
• Additional/SQLite: Updated SQLite version
• Additional/SQLite: Use mmap to accelerate SQLite file accesses

Firmware from March 15 included (no need to update separately):

Additional info and testing (DVDPlayer etc.), see post #1

To install XBMC build, SSH to Pi:
Code:
wget -O xbmc-13-20140317-nc3.tar.gz http://goo.gl/cBQTPx --no-check-certificate
pv xbmc-13-20140317-nc3.tar.gz | tar xzf - -C /home/pi/.upgrade
sudo cp /home/pi/.upgrade/xbmc-13-20140317-nc3/{fixup_x.dat,start_x.elf} /boot
ln -sfn /home/pi/.upgrade/xbmc-13-20140317-nc3/xbmc-bcm /home/pi/.xbmc-current
cd /home/pi/.upgrade/xbmc-13-20140317-nc3/xbmc-bcm/xbmc-bin/lib/xbmc/system
cp /usr/local/lib/libdvdcss.so.2.1.0 .
ln -sf libdvdcss.so.2.1.0 libdvdcss.so.2
ln -sf libdvdcss.so.2 libdvdcss.so
sudo reboot
Reply
My apologies if this is the wrong place.. I have just moved over from the official latest Raspbmc to the most recent test build, but I haven't been able to get any audio passthrough working. I have tried both DTS and DD files and all I get is downmixing to PCM. I notice that the option to specify passthrough is now gone from the menu and i guess this is now autodetected. My Pi can see that my amplifier can decode these formats because...


[email protected]:~$ tvservice -a
PCM supported: Max channels: 6, Max samplerate: 192kHz, Max samplesize 24 b
AC3 supported: Max channels: 8, Max samplerate: 48kHz, Max rate 640 kb/s.
DTS supported: Max channels: 8, Max samplerate: 48kHz, Max rate 1536 kb/s.
DTS_HD supported: Max channels: 8, Max samplerate: 192kHz, Max rate 8 kb/s.
[email protected]:~$


I haven't changed anything hardware-wise since my upgrade from stock raspbmc which decoded DTS and DD fine.
Other than this I LOVE these testbuilds. Everything else is working snappier than even and I have menu sounds for the first time.

Any help would be gratefully appreciated
Reply
No, not auto detected and not gone.
You need to enable advanced or expert settings level (new in Gotham).
Not all skins are updated for Gotham, stock Confluence has the option though.
Reply
Brilliant thanks. All working perfectly. Thanks for your hard work!
Reply
(2014-03-17, 17:43)miappa Wrote: @DBMandrake
My thought was that this can be the case, but obviously I am not certain.
So no need to try to fix it in that build until you have tested the next on (should have it ready within a couple of hours).
I can confirm that today's March 17 build fixes both the crash on first launch of the March 15 build I reported, AND the airplay fix works perfectly as well.

Excellent ! Big Grin
Kodi 18.3 - Mid 2007 Mac Mini, 4GB, 2TB HD, Windows 7 SP1
Kodi 18.3 - Vero4k, Raspberry Pi 2. OSMC.
Reply
I'm unable to have video over airplay with March 17 build exept for the youtube application, everything else is audio only even if the icon is displayng the xbmc icon as a tv and not a speaker.

ok, another try and know is working, don't know why.
Reply
Working fine here..

Did it work before?
If so, what build did it work on?
Where are you streaming from?
What player are you using?
Debug log?
Reply
this is the first try
im streaming from ipad air ios 7.0.4 and iphone 4 same ios
i'm using omxplayer in raspbmc and standard ios videopalyer

know it's working, I think the problem was that I was trying to play a file that I had not actually on the device but in my iCloud (so I was doing a streaming of a streaming, and the result was only audio on xbmc and video on the apple device), while with a movie physically on the device everything works.

I would benefit going from omx to dvd?
Reply
(2014-03-18, 13:26)Supersimo88 Wrote: know it's working, I think the problem was that I was trying to play a file that I had not actually on the device but in my iCloud (so I was doing a streaming of a streaming, and the result was only audio on xbmc and video on the apple device), while with a movie physically on the device everything works.

Is this a video purchased from itunes? They won't work (DRM).
If it is your own video, can you airplay it to xbmc on another platform (e.g xbmc on windows running gotham beta 2).
Reply
I wasn't thinking about DRM, yes it's an itunes purchase.
Reply
what about going from omx to dvd?
i'll have some benefit?
Reply
(2014-03-18, 14:47)Supersimo88 Wrote: what about going from omx to dvd?
i'll have some benefit?

What's the question?
For DRM, no. It won't play on any xbmc system.
Reply
  •   
  • 1
  • 60
  • 61
  • 62(current)
  • 63
  • 64
  • 119
  •   
 
Thread Rating:
  • 15 Vote(s) - 4.4 Average



Logout Mark Read Team Forum Stats Members Help
RaspBMC Kodi/XBMC test builds4.415
This forum uses Lukasz Tkacz MyBB addons.