•   
  • 1
  • 76
  • 77
  • 78(current)
  • 79
  • 80
  • 119
  •   
RaspBMC Kodi/XBMC test builds
I had that removed already, I rebooted again but now via XBMC gui instead of the console, not sure if that makes a difference, but i do see the sub sites now! thanks
Reply
NB! This build has the wrong PVR addons, I believe I compiled the Frodo branch. Next build will fix this.

Updated Gotham build, XBMC master from Apr 10 + newclock3 commits + additional commits and changes.

A few fixes in master + the following:

NC3:
• [omxplayer] Remove unused framerate functions
• [rpi] Include ntsc frequencies in list of supported resolutions
• [omxplayer] Allow a framerate callback from GPU to trigger a hdmi mode change
• [omxplayer] Add ability to log more timestamp info in extra debug settings
• [omxplayer] Request to be notified about framerate changes
* See comment from popcornmix below

PR´s not in master yet, but included in NC3:
• Curl multi-session fixes, see here
• fix crash when changing language and skin zoom

Same additional changes etc. as in previous build.

Firmware from April 11 included:
• video_decode: Fixes for fifo timestamps and frame interval tracking
• Encode: Add support for saving inline motion vectors from gsh
• DSI display support

Additional info and testing (DVDPlayer etc.), see post #1

To install XBMC build, SSH to Pi:
Code:
wget -O xbmc-13-20140411-nc3.tar.gz http://goo.gl/bRCUld --no-check-certificate
pv xbmc-13-20140411-nc3.tar.gz | tar xzf - -C /home/pi/.upgrade
sudo cp /home/pi/.upgrade/xbmc-13-20140411-nc3/{fixup_x.dat,start_x.elf} /boot
ln -sfn /home/pi/.upgrade/xbmc-13-20140411-nc3/xbmc-bcm /home/pi/.xbmc-current
sudo reboot

Popcornmix:
Quote:Couple of new things to test. The list of refresh rates now contains pal and ntsc variants (e.g. 24 and 23.98).
If most of your content is 23.98 you can set the system refrsh to 23.98 and you won't have the hdmi switching delay when playing most content.

If you set "adjust refresh rate to match video" to always and then play a file with a framerate that changes, or is incorrectly reported in container
(e.g. mediainfo reports different framerate/original framerate because video is 23.98fps, but actual frames are at 25fps) then TV will adjust refresh rate when this is discovered.

This may mean the TV adjusts at start, and then again after few seconds.
There is a chance this could false alarm, so report if any video triggers this when you don't believe it should.

Changing "adjust refresh..." to on start/stop should avoid the new behaviour.
Reply
I no have the last testbuild. Just an observation. The iptvsimple addon is now the old version 1.6 and an upgrade, well, doesn't upgrade.

EDIT: I meant "now" not "no". I should have my post proofread before I post. ;-)
Reply
I don't know if you mean that something as changed or if you just noticed that the newest version is not included.
Nothing has changed though, pvr addons are from opdenkamp's repo and that addon has not changed in at least 3 months: https://github.com/opdenkamp/xbmc-pvr-ad...ter/addons

So in these builds version 1.9.3 is included and has been for at least 3 months.

Edit2:
Deleted added comment.
I checked the build I was suspicious about + the last 5 builds. They all have iptvsimple v1.9.3 included.
Check what version of XBMC you are running, Frodo uses iptvsimple v1.6.1 if I am not mistaken.
And you might want to delete addons**.db and force refresh.
Reply
I will delete addons**.db and have a look.

EDIT: Just did. Nothing changed. Stuck with an non-upgradable older version of iptvsimple. Really.
Reply
I installed the latest build and noticed that VDR VNSI client stopped working. I deleted Addons*.db and after a reboot, noticed that apparently all PVR clients are broken:

Code:
14:22:12 139.802856 T:2840589376 WARNING: Unable to resolve: XBMC_VDR_vnsi.pvr ADDON_Announce, reason: /home/pi/.upgrade/xbmc-13-20140411-nc3/xbmc-bcm/xbmc-bin/share/xbmc/addons/pvr.vdr.vnsi/XBMC_VDR_vnsi.pvr: undefined symbol: ADDON_Announce
14:22:12 139.803391 T:2840589376   ERROR: Unable to resolve exports from dll /home/pi/.upgrade/xbmc-13-20140411-nc3/xbmc-bcm/xbmc-bin/share/xbmc/addons/pvr.vdr.vnsi/XBMC_VDR_vnsi.pvr
14:22:12 139.824127 T:2840589376 WARNING: UpdateAndInitialiseClients - failed to create add-on VDR VNSI Client, status = 6
14:22:12 139.826538 T:2840589376 WARNING: UpdateAndInitialiseClients - failed to load the dll for add-on VDR VNSI Client, disabling it
14:22:12 139.829376 T:2900763712  NOTICE: Thread AddonStatus pvr.vdr.vnsi start, auto delete: true

Repeats for each addon, notice the "undefined symbol".
If I return to my previous installed build (20140406), everything works again - well at least the vdr.vnsi addon.

Edit: wrong branch of the opdenkamp repo, perhaps?
Reply
Edit: I deleted my comment to not confuse things, and I was completely wrong. I see the problem now.
The last build (which was the only one I did not check) does have the wrong addons so you were probably correct tournedos.

However, I did see some weird behavior, but I will post a new build shortly and exchange the last one.

@Gregoire
I thought you said "I no have the last..." as in "I don´t have the last...", stupid me, of course you meant "now".
Therefor I didn´t check the latest build :S My apologies.
Reply
(2014-04-10, 09:25)miappa Wrote: The builds are always shipped with a default advancedsettings.xml (located in .../xbmc-bcm/xbmc-bin/share/xbmc/system).
These settings will be used unless you overwrite settings with your own advancedsettings.xml in your userdata.
Thanks for your answer!
Reply
Why doesn't Live TV work with nPVR Gotham/Pi/RaspBMC.

My tuners are on a "server" machine running Windows7. Live TV works fine in Frodo and on Windows7/Gotham clients. Also tried Openelec/Gotham on the Pi, same result.

I have tried Gotham Beta 1 through 3, as well as the April 12 nightly (with the bad sound).

All I get is "tuner is no longer available" on the Pi.

The only replies I get on other forums is: me, too from 1 or 2 people.
Reply
Sorry, have no ides.
AFAIK it works much better on Gotham for most people.

Did you try any of the test builds here?
If you are going to try it, do not use the one from April 11 as it includes the wrong addons.

Edit: Also, the firmware update has not been pushed yet so if you install nightlies (Beta´s too) via Raspbmc Settings without updating the firmware manually you will have issues.
The builds here includes the updated firmware.
Reply
Updated Gotham build, XBMC master from Apr 13 + newclock3 commits including some PR´s not yet in master.

Some info:
• Master: A few fixes and updates
• NC3: [omxplayer] Fix for 3d video in mono mode
• NC3: [omxplayer] Ignore occasionally valid pts values, they cause live tv stutter
• Additional: Correct PVR addons included

For more info on recent changes, updates and what´s being tested, see previous builds from April 9 and April 11

Firmware from April 12 included

Additional info and testing (DVDPlayer etc.), see post #1

To install XBMC build, SSH to Pi:
Code:
wget -O xbmc-13-20140413-nc3.tar.gz http://goo.gl/xhtCDY --no-check-certificate
pv xbmc-13-20140413-nc3.tar.gz | tar xzf - -C /home/pi/.upgrade
sudo cp /home/pi/.upgrade/xbmc-13-20140413-nc3/{fixup_x.dat,start_x.elf} /boot
ln -sfn /home/pi/.upgrade/xbmc-13-20140413-nc3/xbmc-bcm /home/pi/.xbmc-current
sudo reboot
Reply
Just updated from xbmc-13-20140406-nc3 to xbmc-13-20140413-nc3 and have noticed that the official iOS XBMC remote app can no longer connect.

I get "Authentication Failed. Incorrect Username or Password. Check your settings". Username and password is correct in guisettings.xml and the UI. Tried reverting back to 406 and it works again.

Also tried connecting to the remote control webserver from Google Chrome - I'm presented with an Authentication Required dialogue which won't accept my username and password, so definitely something broken.
Kodi 18.3 - Mid 2007 Mac Mini, 4GB, 2TB HD, Windows 7 SP1
Kodi 18.3 - Vero4k, Raspberry Pi 2. OSMC.
Reply
Not going to help, but working fine here.
Both from phone and ipad, ios 6 and 7, and both with Constellation and the official app.

I don't use password though.
Reply
Any progress with IOS 7 airplay video function?
Reply
(2014-04-13, 23:09)miappa Wrote: Not going to help, but working fine here.
Both from phone and ipad, ios 6 and 7, and both with Constellation and the official app.

I don't use password though.
I use a non default username and password. Anyway I've fixed it - even though the username and password were still in guisettings.xml and worked when reverting to the old build, when I went into the GUI the username was in fact blank...(could have sworn it wasn't when I first checked)

Re-entered the username (password was already there) and its now working. If I had to guess I would say that the username key name for guisettings.xml must have changed in the new version so it's not checking the same key as the old version thus seeing a blank username...
Kodi 18.3 - Mid 2007 Mac Mini, 4GB, 2TB HD, Windows 7 SP1
Kodi 18.3 - Vero4k, Raspberry Pi 2. OSMC.
Reply
  •   
  • 1
  • 76
  • 77
  • 78(current)
  • 79
  • 80
  • 119
  •   
 
Thread Rating:
  • 15 Vote(s) - 4.4 Average



Logout Mark Read Team Forum Stats Members Help
RaspBMC Kodi/XBMC test builds4.415
This forum uses Lukasz Tkacz MyBB addons.