•   
  • 1
  • 96
  • 97
  • 98(current)
  • 99
  • 100
  • 119
  •   
RaspBMC Kodi/XBMC test builds
the m3u refresh all the time, witht the new url of the .ts files
Reply
Obviously I'm testing them wrong and have no idea what I'm doing, I'll give up then. Smile

Edit: I'd originally downloaded the m3u and had been testing that. Testing with the m3u url in VLC still results in video and intermittent audio - lots of "lost" audio buffers according to the codec statistics dialog. There is frequent stuttering/buffering of video (20Mb/s connection).
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
ahh? are you being sarcastic? :O I really need some help Sad
Reply
(2014-10-02, 02:41)henryperu77 Wrote: ahh? are you being sarcastic? :O I really need some help Sad

No not really Smile I don't use video ts streams so don't really know how they work!
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
you said its maybe a ffmpeg 2.4.1 problem..., it is possible to update it on raspbmc? and use the one included on kodi for windows..
Reply
OK I've had another go at this....

I created a file called "test.m3u" and pasted the url location of the first m3u (https://ott.totalplay.com.mx/TPHLSWeb/M3...40&f=.m3u8), so that the file contains just the url.

If I now play this file using all acceleration options (omx-h264 is shown in the Codec OSD) it plays absolutely fine in OpenELEC #1001 - continuous smooth streaming of audio and video.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
So its a raspbmc problem :O
Reply
(2014-10-02, 03:18)henryperu77 Wrote: So its a raspbmc problem :O

Probably not.
I have tested this with Kodi on three different platforms (OSX, iOS and Raspbmc) and they all behave the same for me (plays ≈4 seconds of each).
It did behave somewhat better with VLC, but the sources doesn´t seem to be very good though.

I also tried wha Milhouse tested last (and I oly pasted the URL, nothing else) and it did NOT work for me on iOS and OSX (plays ≈4 seconds). Not at home so cannot test on Raspbmc now, but Im pretty sure it will behave the same.
All tested on latest nightly.

If anyone is interested, here is a debug log from OSX playing the m3u that henryperu77 provided, then my own test-m3u with only 1 URL in it: http://pastebin.com/8s6ygaRj

Anyway, I see the problem, but on several platforms... however I have no idea if the problem is the m3u´s, the sources or Kodi(?).
Reply
Just out of curiosity, tested that on latest helix master on my linux system. Works like a charm no drops, perfectly fine, nothing. Looking at your logfiles I see some "asked for packet with nothing available" - it seems like a network issue on your side? Limited downstream or bad connection to the server? The average bitrate seems < 1 Mbit/s so not very likely. But as it happens on all your clients that are most likely connected via the same network?

Image

Edit: Kept it running for 5 minutes in sum - nothing, all fine, though I did not like the content :-)
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
First I tested at home where I have 100/100MBit connection (very good I might add, no problems at all).
Everything but the Pi is wireless though, but I also have a very good router with 300Mbit wifi that very seldom gives me any trouble.

The second test (with the debug log) is from work where I have 10/10Mbit connection (fibre), still wifi though.

However, it does look like it starts buffering and then stops instead (I can see the buffering dialoge for half a second), so either way it seems to be a problem.
I would be very surprised if it was a network issue from my side, perhaps it´s a mirror/region problem with the sources?
Reply
(Maybe this needs it's own thread - although this will probably be my last post on this subject in this thread)

This is a debug log of OpenELEC #1001 playing the test.m3u, which is simply:
Code:
https://ott.totalplay.com.mx/TPHLSWeb/M3U8LiveFile?format=2&profile=313&lan=2&rows=40&f=.m3u8

I'm using a 2Mbs up/20Mbps down ADSL connection, wired to the Pi over CAT5.

Ignore the ffmpeg errors between 149.179169 and 185.995605 - I had "extract thumbs" enabled and Kodi was trying to extract nonsense from a file named xbmc.bin... grrr.

Navigate to the folder containing the .m3u: 221.269180
Playback commences: 229.665604

It works, and plays smoothly. There are however regular ffmpeg debug messages complaining about lack of global network initialization and RBSP data - they seem to correspond with each new ts but don't affect playback, at least not for now...
Code:
08:24:49 383.761566 T:2874143824   DEBUG: ffmpeg[AB4FF450]: [hls,applehttp] HLS request for url 'http://200.76.77.237:80/LIVE/H01/CANAL435/PROFILE03-322/1102-20141002T022122.ts', offset 0, playlist 0
08:24:49 383.762054 T:2874143824   DEBUG: ffmpeg[AB4FF450]: Using network protocols without global network initialization. Please use avformat_network_init(), this will become mandatory later.
08:24:49 384.257172 T:2874143824   DEBUG: Previous line repeats 1 times.
08:24:49 384.257355 T:2874143824   DEBUG: ffmpeg[AB4FF450]: [NULL] Current profile doesn't provide more RBSP data in PPS, skipping
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
I wonder if there's any difference in behaviour with how it is launched?
I launched with:
Code:
./play "https://ott.totalplay.com.mx/TPHLSWeb/M3U8LiveFile?format=2&profile=313&lan=2&rows=40&f=.m3u8"
The play script is here

And it played fine for me.
Reply
Here's a modified version of the play script that works on OpenELEC (and may still work on Raspbmc): http://sprunge.us/eZQO

diff:
Code:
--- a/play 2014-10-02 11:01:58.118474962 +0100
+++ b/play 2014-10-02 11:01:14.419323341 +0100
@@ -5,13 +5,15 @@
   local strlen=${#string}
   local encoded=""

-  for (( pos=0 ; pos<strlen ; pos++ )); do
+  pos=0
+  while [ $pos -lt $strlen ]; do
      c=${string:$pos:1}
      case "$c" in
         [-_.~a-zA-Z0-9] ) o="${c}" ;;
-        * )               printf -v o '%%%02x' "'$c"
+        * )               o="$(printf '%%%02x' "'${c}")" ;;
      esac
-     encoded+="${o}"
+     encoded="${encoded}${o}"
+     pos=$((pos+1))
   done
   echo "${encoded}"    # You can either set a return variable (FASTER)
   REPLY="${encoded}"   #+or echo the result (EASIER)... or both... :p

Using this script, the stream plays fine on OpenELEC #1001, same as in post #1466 along with repeated network/RBSP messages.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
Milkhouse how i implement that play script on raspbmc?
Reply
(2014-10-02, 15:19)henryperu77 Wrote: Milkhouse how i implement that play script on raspbmc?

Code:
wget http://sprunge.us/eZQO -O ~/play && chmod +x ~/play

then
Code:
~/play "https://ott.totalplay.com.mx/TPHLSWeb/M3U8LiveFile?format=2&profile=313&lan=2&rows=40&f=.m3u8"
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
  •   
  • 1
  • 96
  • 97
  • 98(current)
  • 99
  • 100
  • 119
  •   
 
Thread Rating:
  • 15 Vote(s) - 4.4 Average



Logout Mark Read Team Forum Stats Members Help
RaspBMC Kodi/XBMC test builds4.415
This forum uses Lukasz Tkacz MyBB addons.