•   
  • 1
  • 99
  • 100
  • 101(current)
  • 102
  • 103
  • 119
  •   
RaspBMC Kodi/XBMC test builds
(2014-10-14, 13:56)popcornmix Wrote:
(2014-10-14, 13:51)feuille_de_lune Wrote: Indeed, I only have a DIGI and aplay always answered me that and before it seemed to works well. So it's a little strange.

Can you try disabling GPU accelerated resampling?

It's currently in settings/system/audio/resample quality, although these builds may pre-date that, in which case it may be in setting/video/acceleration.

Yep, I'll do it until I'll be at home. Smile
Reply
(2014-10-14, 09:03)miappa Wrote: @henryperu77
What DBMandrake says will work. The reason is that the .upgrade folder must be created which it will be if you run the Raspbmc Settings addon (one time) before you install any of these builds.

@Gregoire
I believe that you have misunderstood this thread completely. No one has anything to go on with the little to none info you provided, and saying that you will only provide proper info after final release... well, will only irritate people to be honest.

@DeJuan N. Onley
Just like previous poster you didn´t say anything about anything really. At least provide media info and what content is not working properly, but preferably a debug log too.
Personally I have no such issues, but I use mostly h264 content and omxplayer.

@Fraludio
No one has a magic crystal ball here. Provide more info if you anyone to look into it.

@feuille_de_lune
I don´t think that any Kodi/XBMC build will help you if your underlaying OS is not fully compatible (or your settings) with your sound card. The builds you install here is only Kodi/XBMC builds, they do not change or update anything else (except for the GPU firmware).
You should go here: http://forum.osmc.tv/showthread.php?tid=...#pid110771

@all
This thread is meant to help with testing new features, but also to prevent bugs in any future stable releases.
If you think about how many different setups there are, all the different content + all the different settings you can have; only reporting ”it doesn´t work properly” will not help anybody, yourselves included.
If you have no information at all to provide no one will be able to help you, and you will not help out getting a betteer Kodi which is pretty much the point of this thread.

If you just want to test for yourselves, please do. But if you want help or if you want to help out, provide information. Otherwise it´s quite pointless.

"Maybe in the future, when the problem still exists, I'll report this properly." But now I do not have the time. Maybe in the mean time someone with the same issues will submit according to your request. I rephrased it for you. I hope you still enjoy working on kodi.
Reply
Updated Helix build, Kodi/XBMC master from Oct 14 + newclock4 commits.

Kodi/XBMC Master:
Master changelog
• Adapt addon gui version to 5.3.0

NB!
Addons and skins may need an update to be compatible.
Sync to addon gui version bump for the bundled PVR addons is NOT included so they might not work. I´ll include it in next build if not already merged.

Newclock4 additions:
• [rbp] Fix for orientation handling of Pi textures
• [ResamplePi] Fix for 24bit audio
• CacheStrategy: remove usage of emulated win32 functions, switch to internal VFS

GPU firmware from Oct 12 included:
• audio_mixer: Add more support for 24-bit formats
• audioplus: Always use 48kHz for pwm when de-popping is enabled
• platform: Reorganise so config.txt is parsed before gpioman is set up
• config: Remove gpio_pads config. Drive strength can be set through gpioman
• audio_mixer: Check port number with resample parameter

To install Kodi/XBMC build, SSH to Pi:
Code:
wget -O kodi-14-20141014-nc4.tar.gz http://goo.gl/lSP6R8 --no-check-certificate
pv kodi-14-20141014-nc4.tar.gz | tar xzf - -C /home/pi/.upgrade
sudo cp /home/pi/.upgrade/kodi-14-20141014-nc4/{fixup_x.dat,start_x.elf} /boot
ln -sfn /home/pi/.upgrade/kodi-14-20141014-nc4/xbmc-bcm /home/pi/.xbmc-current
sudo reboot

See post #1 for more info
Reply
Hi miappa,

Been bumping into a problem. Some of my tv shows don't have audio since yesterday. Someone advised me to try your build and see if it would solve the problem. Flashed it - but unfortunately without luck.

Saw in your release notes that you have been working on audio improvements. Is it a known problem that people have been experiencing issues with sound lately? According to popcornmix the cause could be that raspbmc has been updated but not updated the firmware correctly.

Added a link to my other post below, just in case it might spike your interest. Curious to hear your thoughts, many thanks in advance!

http://forum.xbmc.org/showthread.php?tid=206380
Reply
@suikerchiller
This is quite certainly an isolated issue at your end. And you have the same issues on release Gotham version (where you came from) so really nothing to do with these test builds.
I saw your threads and also popcornmix´s comment regarding the firmware, however you had the release version of the firmware which shouldn´t really be a problem.

I would test to rename your userdata folder (the .xbmc folder located in /home/pi) to see if there are any problems with your settings etc.
Edit: Explanation, you need to reboot and XBMC will create a new userdata with stock settings.
My guess is that some settings are wrong, but could also be that something is corrupted or broken.

P.S: I am not a developer, I am just sharing test builds. Most of the release comments you see are from the newclock4 branch which is popcornmix´s testing branch.
Reply
@miappa thanks for the tip, it's working again... Only one downside, just have to go through the annoying recalibration / configuration part :-)

For some reason I'm bumping into a problem I encountered for quite some time before, which is that the 'reboot' function now causes my tv to shut off and doesn't reboot the pi. When I ssh into the pi it's still running.
Code:
sudo reboot now
will do the trick though. FYI - didn't have this issue on the last official build of raspbmc.

Known problem or am I just doing something stupid?
Reply
Yes, it is a known problem on these test builds since a while back, shutdown and reboot does not work from GUI, it will only restart Kodi/XBMC.
It should as you say work on the last release version of Raspbmc though.

If you don´t want your TV to be turned off on Kodi/XBMC exit, change your CEC settings in Settings - System - Input devices - Peripherals - CEC adapter.
Personally I just switch everything to off or ignore except for actual CEC (I use my TV remote), but if you don´t use CEC at all you can just turn it off all together.
Reply
(2014-10-14, 13:56)popcornmix Wrote:
(2014-10-14, 13:51)feuille_de_lune Wrote: Indeed, I only have a DIGI and aplay always answered me that and before it seemed to works well. So it's a little strange.

Can you try disabling GPU accelerated resampling?

It's currently in settings/system/audio/resample quality, although these builds may pre-date that, in which case it may be in setting/video/acceleration.

I tried this trick and it seems to work. I can set the passthrough. I had to overclock cpu to 1GHz to have good perf on playing HD content.

I have 2 others problems :
-> xbmc doesn't see my hifiberry at first boot, I have to restart the xbmc to make it seen by xbmc.
-> My tvheadend doesn't start at all without saying anything. I checked the option in "raspberry configuration", I've to search some information to understand that.
Reply
(2014-10-14, 20:39)miappa Wrote: Updated Helix build, Kodi/XBMC master from Oct 14 + newclock4 commits.

Kodi/XBMC Master:
Master changelog
• Adapt addon gui version to 5.3.0

NB!
Addons and skins may need an update to be compatible.
Sync to addon gui version bump for the bundled PVR addons is NOT included so they might not work. I´ll include it in next build if not already merged.

Newclock4 additions:
• [rbp] Fix for orientation handling of Pi textures
• [ResamplePi] Fix for 24bit audio
• CacheStrategy: remove usage of emulated win32 functions, switch to internal VFS

GPU firmware from Oct 12 included:
• audio_mixer: Add more support for 24-bit formats
• audioplus: Always use 48kHz for pwm when de-popping is enabled
• platform: Reorganise so config.txt is parsed before gpioman is set up
• config: Remove gpio_pads config. Drive strength can be set through gpioman
• audio_mixer: Check port number with resample parameter

To install Kodi/XBMC build, SSH to Pi:
Code:
wget -O kodi-14-20141014-nc4.tar.gz http://goo.gl/lSP6R8 --no-check-certificate
pv kodi-14-20141014-nc4.tar.gz | tar xzf - -C /home/pi/.upgrade
sudo cp /home/pi/.upgrade/kodi-14-20141014-nc4/{fixup_x.dat,start_x.elf} /boot
ln -sfn /home/pi/.upgrade/kodi-14-20141014-nc4/xbmc-bcm /home/pi/.xbmc-current
sudo reboot

See post #1 for more info

I can test addon for Tvheadend server because of this error Sad

Quote:21:52:26 4658.060547 T:2807034944 ERROR: PVR - Add-on 'Tvheadend HTSP Client' is using an incompatible GUI API version. XBMC minimum GUI API version = '5.3.0', add-on GUI API version '5.0.1'

It seems to be a clear reason ^^" the Tvheadend HTS client can't start.
Reply
(2014-10-14, 20:39)miappa Wrote: Kodi/XBMC Master:
Master changelog
• Adapt addon gui version to 5.3.0

NB!
Addons and skins may need an update to be compatible.
Sync to addon gui version bump for the bundled PVR addons is NOT included so they might not work. I´ll include it in next build if not already merged.
(2014-10-17, 22:05)feuille_de_lune Wrote: I can test addon for Tvheadend server because of this error Sad

Quote:21:52:26 4658.060547 T:2807034944 ERROR: PVR - Add-on 'Tvheadend HTSP Client' is using an incompatible GUI API version. XBMC minimum GUI API version = '5.3.0', add-on GUI API version '5.0.1'

It seems to be a clear reason ^^" the Tvheadend HTS client can't start.

I corrected my problem by adding this import :

Code:
<import addon="xbmc.gui" version="5.3.0"/>

to the file "addons/pvr.hts/addon/addon.xml.in" in xbmc-pvr-addons sources before rebuild it.
I installed the new version of "TVHeadend HTSP Client" and, at first view, it seems to work well.
Reply
Hi thanks for your builds but when I press up or down on a live stream which seeks the video to 600 the raspberry pi freezes. How do I fix that?
Reply
Updated Helix build, Kodi/XBMC master from Oct 18 + newclock4 commits.

Kodi/XBMC Master:
Master changelog
• [PVR] bump add-ons

Newclock4 additions:
• [mmal] Exit preroll when we have some decoded frames
• [omxplayer] Restore flush/accurate seek flags to fix issue with edl skipping

GPU firmware from Oct 17 included:
• dpi: Add options to alter dpi settings through dpi_output_format
• arm_loader: Avoid gpioman spam when POWER_LOW is not defined

To install Kodi/XBMC build, SSH to Pi:
Code:
wget -O kodi-14-20141019-nc4.tar.gz http://goo.gl/NUcIMC --no-check-certificate
pv kodi-14-20141019-nc4.tar.gz | tar xzf - -C /home/pi/.upgrade
sudo cp /home/pi/.upgrade/kodi-14-20141019-nc4/{fixup_x.dat,start_x.elf} /boot
ln -sfn /home/pi/.upgrade/kodi-14-20141019-nc4/xbmc-bcm /home/pi/.xbmc-current
sudo reboot

See post #1 for more info
Reply
(2014-10-19, 20:57)miappa Wrote: Updated Helix build, Kodi/XBMC master from Oct 18 + newclock4 commits.

This release include the corrections for my addons' problem or not ?

Angel
Reply
(2014-10-20, 10:40)feuille_de_lune Wrote: This release include the corrections for my addons' problem or not ?

This is included, however I also saw this which is not included.
So I don´t think that your fix is included.

As far as I understand some PVR addons use dialogues and needs to include import of xbmc.gui (also correct version for the Kodi build) which the HTS client seems to lack in previous versions.
Reply
Hey miappa i have a seek problem on live streams when i press up it freezes the raspberry pi
Reply
  •   
  • 1
  • 99
  • 100
  • 101(current)
  • 102
  • 103
  • 119
  •   
 
Thread Rating:
  • 15 Vote(s) - 4.4 Average



Logout Mark Read Team Forum Stats Members Help
RaspBMC Kodi/XBMC test builds4.415