Mapping HP remote?

I have an HP mce remote that looks like the one below. The remote is working great with xbmx, but I have a problem with three buttons.


Number1 switches displays. I think it sends "Fn+F4", but I'm not sure!
Number 2 and 3 are not working at all.

I have checked them using "showkey", but it doesn't show any key; yet the IR receiver flashes -- means a command is sent?!

Thank youSmile
Firstly: that's a really nice remote!

MCE button-to-keypress mappings are actually specified in the Windows registry. That's the bad news.

The good news, is that there are tools to do this for you:

Standard procedure for mapping keys with an MCE Remote is to use the XBMC MCE Add-On ( ) (remember to run XBMC 'as Administrator' before running the addon since it needs registry access). It allows you to change (or blank) what key is pressed by a given button on an MCE remote. (That's more good news - and this add-on is really easy to use, have used it a number of times with success ;-) )

Possibly a bit of bad news is that the buttons you describe look non-standard and hence may not be available for specifying in the addon. In which case you could try the tools specified here to map them:

Also this remote (with a bit of config info) is mentioned on the wiki:

As a last resort if you don't have luck, you could google your remote model to find the registry codes associated with those buttons and override them manually in the registry. Or alternatively: ignore the buttons which don't work - which may actually be less painful than hacking the registry! ;-)
Thanks for you replySmile

The second link you have provide is the one I actually fallow to set up my remote -- It was so easy to use. Everything is working good except for those three buttons shown above.
I have found this thread, but I don't understand how to add the codes?!
Two questions:
1. what is exat model nubmer of your remote? My remote si RC1804912/06, it was written on the label under battery cover
2. what operating system?
Assuming you're using Windows (otherwise the registry tool wouldn't have worked ;-), here's some detail about the registry setting that is modified when mapping buttons.

And here's more detail on how this registry setting works. Caution: it's all Hex; you'll have to figure out what codes the three buttons are sending (that's the first byte for each button); and then specify a new keypress to simulate when that button is pressed (that's that last three bytes)...
Okay guys, I solved my problem. Thank you so much for your help.

Here is how I solved:

I checked this file (thanks KoMiKoSmile), and I found that there are three buttons code missing in my registry. Keep in mind that each remote has its own codes, so find the right one.

For number 1, in the picture above, it's widescreen 0x81
For number 2 it's return 0x80
For number 3 it's photo 0x6F

So I simply added those codes to my registry file, and now I can see these buttons in "MCE Remote Mapper Tool". All the buttons are working now, and I can map or re-map them as I like.

I hope this will help othersSmile

Thank you
You are welcome Smile
thank you guys, this helped me map those three buttons on my RC1804912/06 5 years later Smile

Logout Mark Read Team Forum Stats Members Help
Mapping HP remote?0
This forum uses Lukasz Tkacz MyBB addons.