Win XBMC and Power DVD 13 as external player
#1
Hello

I simple try to start PDVD 13 as an external player. For testing purpose i use a simple .cmd file.
My OS ist Windows 7 64bit and i use Frodo 12.2.

content of startpdvd13.cmd
"C:\Program Files (x86)\CyberLink\PowerDVD13\PowerDVD13.exe" f:

part of my playercorefactory
<player name="testplayer" type="ExternalPlayer" audio="false" video="true">
<filename>C:\Program Files (x86)\XBMC_Frodo\powerdvd.cmd</filename>
<args>"{1}"</args>
<hidexbmc>true</hidexbmc>
<hideconsole>true</hideconsole>
</player>

If i execute the startpdvd13.cmd from the command line Powerdvd 13 starts and plays the disc. If i use XBMC to execute the startpdvd13.cmd nothing happens.
I played with hidexbmc and hideconsole and fullscreen XBMC or windowed XBMC but Powerdvd 13 doesn't start.
I use the same simple script with different paths for TMT6. TMT6 starts without any problems. So i assume PDVD is the issue.

xbmc.log
15:56:31 T:740 NOTICE: CExternalPlayer::ExecuteAppW32: "C:\Program Files (x86)\XBMC_Frodo\powerdvd.cmd" "Y:\test.iso"
15:56:32 T:740 NOTICE: CExternalPlayer::ExecuteAppW32: WAIT_OBJECT_0
15:56:32 T:740 NOTICE: CExternalPlayer:Tonguerocess: XBMC cannot stay hidden for a launcher process

Any idea why i can't execute PowerDVD 13 within XBMC?
Reply
#2
Have you tried not using the batch file? I mean, put the full path to PowerDVD into the <filename>, leave <args> as is, and take out <hideconsole>.

If that doesn't help, you can try this thread. There is lots of stuff in there to help.
Acer Aspire Revo 3610 w/Libreelec -> HDMI -> Yamaha RX-V467 -> HDMI -> Toshiba 47L7200U
HP Stream Mini w/Win10 -> HDMI -> Sony KDL-50W800C -> S/PDIF -> Sony HT-CT80
Reply
#3
Jub. I tried to execute the player direct from the playercorefactory. The result is the same. PDVD 13 doesn't start. A short flash and back to XBMC.
TMT6 starts without any problems from the playercorefactory.

I read the thread recently but found no hints so far.
Reply
#4
The only thing that comes to mind is perhaps trying to use START in your batch file:
Code:
start /wait /d "C:\Program Files (x86)\CyberLink\PowerDVD13" "C:\Program Files (x86)\CyberLink\PowerDVD13\PowerDVD13.exe" %1

Or equivalent paths and executables of what the PowerDVD actual shortcut specifies. Hidexbmc and hideconsole false.

Short of that, perhaps investigate what command line options PowerDVD 13 has available. Maybe that could provide clues.

Good luck.

[edit]
Ok, perhaps you are executing the wrong powerdvd executable. Check out this thread at Cyberlink's forums for command lines options.
Acer Aspire Revo 3610 w/Libreelec -> HDMI -> Yamaha RX-V467 -> HDMI -> Toshiba 47L7200U
HP Stream Mini w/Win10 -> HDMI -> Sony KDL-50W800C -> S/PDIF -> Sony HT-CT80
Reply
#5
Hello

I read the thread at Cyberlink's forum. But the Version 13 of PDVD have no PDVDLaunchPolicy.exe. I searched the complete system and didn't find such exe.
So i tried powerdvd13.exe with the options in the thread. No luck. I use the trial version because i first want to test.
I'm very unhappy with the result. I purchased TMT5 and TMT6 and it's working fine.
I read some threads about PDVD and they claim PDVD have a better picture. So i want to test.

I tried to execute PDVD13 from 2 different PCs with different hardware and OS 32bit/64bit the result is the same. At the second PC i'm able to execute PDVD13 but the batch file i use to execute closes and XBMC comes back to front. So i assume PDVD detaches and the XBMC assumes the player is closed.

The .cmd was for testing purpose. Normally I use a self written .NET app to play an ISO or Bluray. In the code i use prozess.waitforexit to wait for the exit of the external player before i close my .NET app.
After i start PDVD13 my app closes. With TMT6 my app stays open. So i guess PDVD13 detaches.

So far i found no solution.
Reply
#6
Hi. I'm also using PDVD 13 with XBMC "Frodo" v.12.2 on Windows 8.1. I cannot also make PDVD 13 run. I've been searching the forum for a solution and stumbled on this thread. I'm afraid I cannot contribute anything useful as I don't have any scripting skills... I'm just a user. So, I'm subscribing to this thread in the hope that you find a solution. I'm using a version of PDVD 13 that is capable of 3D and Bluray disc viewing and I'd love very much to use it to play my 5TB (and counting...) HD&3D movie, video and music files. God speed!
Reply
#7
I stumbled on this thread. Accordingly, PDVD 13 works fine.

(2013-10-26, 19:46)milli Wrote:
(2013-10-26, 13:28)Lupin 3rd Wrote: Hi Guys,
some one here tested this script with new PowerDVD13?
I do and do not work.

any idea?

I'm using powerdvd13 to play blu-ray discs and it works fine. But it may not work for playing blu-ray folder as they have removed the support of taking index.bdmv as a parameter as I understand.

here is what i have in my playdisc.bat.

Code:
"C:\Program Files (x86)\CyberLink\PowerDVD13\PDVDLP.exe" %1 /LaunchProgram PowerDVDCinema

I launch it in cinema mode so that it is more remote friendly. You can skip launchprogram parameter if you prefer classic mode. You would have to disable all GUI sounds in XBMC otherwise it does not release audio for powerdvd to use.
Reply
#8
I've been trying to get powerdvd13 to start through xbmc on windows 8 for the last couple days
reading through all the xbmc threads that were relevant and finally using

playercorefactory.xml:

<playercorefactory>
<players>
<player name="powerDVD13" type="ExternalPlayer" audio="false" video="true">
<filename>C:\Program Files (x86)\Cyberlink\PowerDVD13\PDVDLP.exe</filename>
<args>"{1}"</args>
<hidexbmc>True</hidexbmc>
<hideconsole>true</hideconsole>
</player>
</players>

<rules action="prepend">
<rule filename="*3D*" player="powerDVD13"/>
</rules>
</playercorefactory>


It launches great straight into 3d and audio in powerdvd is also fine but xbmc starts beeping constantly
Any suggestions for stopping this?

Currently I shutdown xbmc in task manager,

Thanks

Shoot - no I'm wrong - This simply launches everything through powerdvd13 and hangs xbmc (starts beeping). Shutting of GUI sounds eliminates the beeping but obviously it's much better if I can find a way to launch powerdvd only for 3d and leaving gui sounds on.

So Another update, Using a Gotham build prevents XBMC from freezing and beeping when I use the above xml but still it just launches every file with powerdvd13 not just those with 3D in the title. Anybody see why?
Reply
#9
All I want to do is launch every video file I open in PowerDVD13. Mitch, I copied your script in my xml document in userdata folder. What am I doing wrong?
Reply
#10
This is what my log says:

19:56:04 T:4184 ERROR: ExternalPlayer Error: filename element missing from: <player name="PowerDVD13" type="ExternalPlayer" audio="false" video="true" />
19:56:04 T:4184 ERROR: Error creating player for item G:\My Videos\Movies\2.Guns.2013.720p.BluRay.x264.AAC-PxHD.Mobies.mp4 (File doesn't exist?)
19:56:04 T:4184 ERROR: Playlist Player: skipping unplayable item: 0, path [G:\My Videos\Movies\2.Guns.2013.720p.BluRay.x264.AAC-PxHD.Mobies.mp4]
19:56:04 T:984 NOTICE: Thread Background Loader start, auto delete: false


This is what I got in playercorefactory script:

<playercorefactory>
<players>
<player name="PowerDVD13" type="ExternalPlayer" audio="false" video="true" />
<filename>C:\Program Files (x86)\CyberLink\PowerDVD13\Movie\PowerDVD Cinema.exe</filename>
<args>"{1}"</args>
<hidexbmc>true</hidexbmc>
<hideconsole>true</hideconsole>
<warpcursor>none</warpcursor>
</players>
</playercorefactory>


PLEASE HELP. Been at this all freaking day.
Reply
#11
Hi all Smile


I have a problem whilst launching Power DVD 13 for Bluray Disc playback.
I'm using the following playercorefactory.xml, which launches the player just how I'd like, the only problem is that the audio bypasses my AVR and plays through the TV.
If I launch Power DVD 13 directly, and not via XBMC, the audio plays via the AVR. If I play a video file via XBMC, the audio plays via the AVR. The problem only exists when playing the BD via the external player method.
I have also tried disabling GUI audio as suggested above, but I still have the problem.

Does anyone have any idea what I might be doing wrong?

Thanks
Kelvin

Quote:<playercorefactory>
<players>
<player name="PowerDVD" type="ExternalPlayer" audio="false" video="true">
<filename>C:\Program Files (x86)\CyberLink\PowerDVD13\PDVDLP.exe</filename>
<args>"{1}"</args>
<hidexbmc>true</hidexbmc>
<hideconsole>true</hideconsole>
<warpcursor>none</warpcursor>
</player>
</players>
<rules action="prepend">
<rule filetypes="bd" filename=".*" player="PowerDVD"/>
</rules>
</playercorefactory>
Reply



Logout Mark Read Team Forum Stats Members Help
XBMC and Power DVD 13 as external player0
This forum uses Lukasz Tkacz MyBB addons.