Surely this has been sorted? -start of audio missing from tracks?
#1
Hello,

I am using a stable pi running openelec 3.2.3 ,and trying to add some cd rips in FLAC to the library
I am using XLD , and ripping to an external usb HDD.
Once an album has been ripped, and I try to play it via xbmc, the tracks all play but ''miss'' the first 'half second' or so, of audio.
None of them play from the very beginning.
I have copied some of the tracks to my mac and they play perfectly with other software.
Am I doing anything wrong?
The library on the external drive is accessed via SMB, but if I copy ,say, one track to the sd card itself ( to make sure its not related to a network problem ), it still misses the first snippet of audio?
Has anyone seen this - I hope I am not repeating a well worn problem here

Thanks for any replies

pootler
Reply
#2
Does the same happen with menu sounds? It xcould be the 'stream silence' option, you can enable it via advancedsettings.xml
Reply
#3
Is this hdmi audio? It is likely your receiver (or TV) takes a second to sync.
There has recently been support for "stream silence" which keeps the receiver active for a given specified length of time (e.g. 5 minutes) which means the next track played won't miss the start of audio.

You do need a very new build for this to work correctly.
e.g. this openelec gotham build should work
https://drive.google.com/file/d/0B-6zmED...sp=sharing

but it may be best to wait a little for it to appear in a more stable build.
Reply
#4
Thank you for your replies - genuinely appreciated.

Yes - it is HDMI audio.
I shall try the build you suggest popcornmix.
Is it the same fix as suggested by teedubb?

Must admit though ,I am a little bit surprised this 'funny' has not been highlighted before by others Smile - I would have thought what I am doing is pretty basic xbmc stuff?

Thats not taking away from the wonderful work you guys do!

Thanks very much

pootler
Reply
#5
Yeah both the same thing - in frodo its a advancedsetting and in Gotham its a menu option with the ability to configure the timeout.
Reply
#6
(2013-11-04, 23:22)teeedubb Wrote: Yeah both the same thing - in frodo its a advancedsetting and in Gotham its a menu option with the ability to configure the timeout.

Thanks teeedubb!
Reply
#7
(2013-11-04, 22:23)popcornmix Wrote: Is this hdmi audio? It is likely your receiver (or TV) takes a second to sync.
There has recently been support for "stream silence" which keeps the receiver active for a given specified length of time (e.g. 5 minutes) which means the next track played won't miss the start of audio.

You do need a very new build for this to work correctly.
e.g. this openelec gotham build should work
https://drive.google.com/file/d/0B-6zmED...sp=sharing

but it may be best to wait a little for it to appear in a more stable build.

I think your last line is correct.
This build does seems a bit ''flakey'' Smile
Unfortunately, it doesn't seem to solve the problem though.
I set the ''device alive'' option to ''always'' and also tried ''10 minutes'' - still missing the first snippet of audio?
It also now ''hunts for hmdi connection when i stop a video, and when I try to access any other libraries,etc ( over SMB also)
Breaks my VDR dependencies as well!

I shall wait for another build i guess Sad

thanks for your help.

pootler
Reply
#8
(2013-11-04, 23:13)pootler Wrote: Must admit though ,I am a little bit surprised this 'funny' has not been highlighted before by others Smile - I would have thought what I am doing is pretty basic xbmc stuff?

It has, but it never really gained any traction.
http://forum.xbmc.org/showthread.php?tid=142808
Reply



Logout Mark Read Team Forum Stats Members Help
Surely this has been sorted? -start of audio missing from tracks?0
This forum uses Lukasz Tkacz MyBB addons.