•   
  • 1
  • 115
  • 116
  • 117(current)
  • 118
  • 119
  • 121
  •   
Release gdrive - Google Drive Video/Music Add-on
(2018-08-24, 17:20)audioce0 Wrote: So I did end up getting the Python script to work out for what I was trying to do. I had to make a few tweaks but it was exactly what I was looking for!
Just wanted to say thanks again! Really appreciate the work you put into this add-on and everything else. It's made my setup work out better than it could ever be.
I sent you a little donation, not much but it's what I could spare. Wish I could send more!
 thank you, it is very much appreciated !
Reply
(2018-08-25, 18:12)keithcq71 Wrote: Downloaded python .Opened defaut py . Localhost wont connect. Im new to this so excuse my stupidty
 What OS are you running this on?  As discussed over private message, I'm willing to spin up that GCE for you with everything configured, but I was busy on Friday and today, it won't be ready until end of the weekend.
Reply
Windows 10 . OK
Reply
Hi:
I install Kodi and the add-on in Mac. When I try to set up an account I get a message to enter an ip (190.xxx.xxx.xxx:8011) to confirm the link, but it is not accessible. I try to follow the other steps to log in but at the moment of confirming I get a message of "This application has not been authorized to work on this account". It must be because I have an institutional account (@ myschool.edu) How can I solve this?
Reply
Your gsuite admin has disabled app access.  You need to use a different account.
Reply
(2018-08-28, 06:16)dmdsoftware Wrote: Your gsuite admin has disabled app access.  You need to use a different account.
 Hi try a different account (@gmail.com) but the same text:
"Se ha inhabilitado temporalmente el inicio de sesión con Google en esta aplicación
Todavía no hemos verificado esta aplicación para que pueda usar el inicio de sesión de Google."
Reply
(2018-08-25, 18:12)keithcq71 Wrote: Downloaded python .Opened defaut py . Localhost wont connect. Im new to this so excuse my stupidty

I have it set up on Windows. Did you ever get it to work? Were you using the correct port?
Reply
I'm little stuck with configurin decrypt. Could you help me on this? I have a Team Drive where content is uploaded with rclone encrypted mount. How do I configure gdrive addon to decrypt?

Btw, when using decrypt, the content doesn't have to be downloaded fully, decrypt is done on the fly, correct?
Thanks
Reply
Is it possible to have strm stored in my google drive for playback? Also I update a lot and manually updating is the only option due to no automic strm creation ? I prefer this addon over the other one .
Reply
Hi, First of all, thank you for the great plugin and for the support, i have been reading since page 95 and you are always answering all the questions.
Thanks for that. 

I am trying to login on my Amazon Stick with kodi installed, without any luck so far. 
I have tried the enroll method but it seems my router is blocking something because I cannot reach that url. 
So I decided to use the Own Auth method. 
I created the Credentials. 
Paste everything and check 4 times already for mistakes  (the credential are sooo long). 

The only thing I am not sure is what is the username we need to use. 
The client id is right, the secret is right, and when I use the url from your instructions: 
http://dmdsoftware.net/GoogleSetupOAUTH2...AUTH2.html

this URL: 

Code:
To authorize your login with the OAUTH2, visit the following URL, substituting [CLIENT_ID] with your client ID -- 

https://accounts.google.com/o/oauth2/aut...&client_id=[CLIENT-ID] 

It gives me another long code that I paste on the space below the username. 

Is all this correct? 
Is there anything left to do? 

Thanks


----------------- edit - problem solved. 
The issue with auto enroll was that the ip suggested is wrong, so I just need to go to IP_ADDRESS:8011/enroll and ignore the ip suggested and everything worked as expected!

Now I need to find how to add this as source, if this is possible. 
But so far so good. 
Thanks!
Reply
After installing the plugin, some devices will require a reboot before the IP:8011/enroll method will work.  If the URL doesn't resolve from another device, reboot the device and upon startup of KODI, the URL should work.
Reply
(2017-07-27, 14:00)dmdsoftware Wrote:
(2017-07-27, 13:53)dabinn Wrote: Hi,
Does anyone here encounter an issue that subtitle didn't loaded with the video? It happened to me recently, and everytime it happened, the video needs to be re-open many times to make the subtitle show up. I also heard of 2 friends have the same issue.

Newer versions of the plugin reduce the timer between starting video and playback of video. That affects the subtitles success on loading. It was another user's ask in order to make subtitles work on 17.3 . It also makes videos playback faster.

Provide details on version of plugin, version of kodi, etc, if you want further assistance.     
KODI v17(auto-update), lastest gdrive-addon 0.8.66/0.8.52 both tested
I have the subtitle issue for over 1 year, it seems to begin with KODI 17 (about May 2017~June 2017), thought ddurdle has a fix for it on 0.8.38, but it still work not well now.
I wrote a Chinese gdrive-addon tutorial on my blog before, some people replied that article saying they also have issue with subtitle from June 2017.
I installed KODI+gdrive-addon on many units, include 2 Window 10 PCs, 3 Android TVs (Nvidia Shield, Sony Bravia, Xiaomi Mi box), Android Phones. All of them have following issue:
* The external subtitle file (srt, ass..ect) has about 80% change not loading at first time.
* If I stop the video, and play it again, the subtile is 100% chance to load  (I have turn on offline SRT setting)
* If I play the video to the end, the subtitle of next auto-played video is 100% chance to load.
* If I click the 'Next' button, or press the 'Next' button on the remote controller, the subtitle of next video 100% NOT loaded.
* If I open the playlist interface while playing, select another file to play, the subtitle also NEVER loaded.
Beside the common issue, there are some difference between the units:
* Windows PC seems have slightly higher chance to load subtitle successfully. (not sure)
* My current using android phone has belowe 10% change to load a subtitle, even for the 2nd time play and with offlien SRT(has confirm it was downloaded).

I am going to trace the code and try to figure out if there is a better solution. Any help would be greatly appreciated.
------------
Update:
After change from 3G network to WiFi, my android phone loads the subtitles much much better. (about 70% success, no mater with or without offline SRT )
It seems caused by different net speed (and loading speed).
I also checked patch 0.8.38, it seems not quite right:
default.py
            ## contribution by dabinn <--- This reminds me that I have sent a patch to fix 'next file' issue before (patch 0.7.47) :p
            # handle situation where playback is skipped to next file, wait for new source to load
            if player.isPlaying():
                xbmc.sleep(100)  <--- patch 0.8.38 changes this from 1000 to 100, may be the main cause that 'next file' does not load subtitle again.

            # load captions
            if  (settings.srt or settings.cc) and service.protocol == 2:
                while not (player.isPlaying()):
                    xbmc.sleep(1000) <------ patch 0.8.38 does not change this, so that waiting time not really reduced as expect.

                files = cache.getSRT(service)
                for file in files:
                    if file != '':
                        try:
                            #file = file.decode('unicode-escape')
                            file = file.encode('utf-8')
                        except:
                            pass
                        player.setSubtitles(file)

            xbmc.sleep(100) <------------ patch 0.8.38 add 0.1 second sleep here, the waiting time becomes a little longer than before.
---------
I'll try to do more playback test with different waiting time and different network condition.
Reply
(2017-07-27, 14:00)dmdsoftware Wrote:
(2017-07-27, 13:53)dabinn Wrote: Hi,
Does anyone here encounter an issue that subtitle didn't loaded with the video? It happened to me recently, and everytime it happened, the video needs to be re-open many times to make the subtitle show up. I also heard of 2 friends have the same issue.

Newer versions of the plugin reduce the timer between starting video and playback of video. That affects the subtitles success on loading. It was another user's ask in order to make subtitles work on 17.3 . It also makes videos playback faster.

Provide details on version of plugin, version of kodi, etc, if you want further assistance.      
 After modifying some code, it seems all issues listed in my last post are fixed.
Test many times with PC and android phone, both 3G network and wifi, all load subtitle without fail.
'Next file' and 'playlist interface while playing, select another file to play' issue also fixed.
--------
update:
After more experiences, I found :
* The root cause should be: the 1000ms waiting time inside "while not (KODI and player.isPlaying())" was not triggered when the player was already 'Playing'.
* More the waiting time, more stable. And the waiting time does not affect video loading speed, it just affects when the subtitle appears. 
* Some small files seems takes longer while loading (KODI try to cache them?), and need longer waiting time.
--------
Finally:
Remove all waiting time and use player.playStatus to replacec player.isPlaying(), now the subtitle loading is very accurate.
Download modified engine.py here: 
https://drive.google.com/open?id=1FVFxN3...5B0jMtBjs-
(If the link failed to open, copy the link and paste to the browser)
Reply
(2018-11-21, 19:00)dabinn Wrote:
(2017-07-27, 14:00)dmdsoftware Wrote:
(2017-07-27, 13:53)dabinn Wrote: Hi,
Does anyone here encounter an issue that subtitle didn't loaded with the video? It happened to me recently, and everytime it happened, the video needs to be re-open many times to make the subtitle show up. I also heard of 2 friends have the same issue.

Newer versions of the plugin reduce the timer between starting video and playback of video. That affects the subtitles success on loading. It was another user's ask in order to make subtitles work on 17.3 . It also makes videos playback faster.

Provide details on version of plugin, version of kodi, etc, if you want further assistance.       
 After modifying some code, it seems all issues listed in my last post are fixed.
Test many times with PC and android phone, both 3G network and wifi, all load subtitle without fail.
'Next file' and 'playlist interface while playing, select another file to play' issue also fixed.
--------
update:
After more experiences, I found :
* The root cause should be: the 1000ms waiting time inside "while not (KODI and player.isPlaying())" was not triggered when the player was already 'Playing'.
* More the waiting time, more stable. And the waiting time does not affect video loading speed, it just affects when the subtitle appears. 
* Some small files seems takes longer while loading (KODI try to cache them?), and need longer waiting time.
--------
Finally:
Remove all waiting time and use player.playStatus to replacec player.isPlaying(), now the subtitle loading is very accurate.
Download modified engine.py here: 
https://drive.google.com/open?id=1FVFxN3...5B0jMtBjs-
(If the link failed to open, copy the link and paste to the browser) 

Thank you for the code change.
Reply
When I try to authorize gdrive with another device I keep getting “sign in with google temporarily disabled for this app”
Reply
  •   
  • 1
  • 115
  • 116
  • 117(current)
  • 118
  • 119
  • 121
  •   



Logout Mark Read Team Forum Stats Members Help
gdrive - Google Drive Video/Music Add-on12
This forum uses Lukasz Tkacz MyBB addons.