•   
  • 1
  • 7
  • 8
  • 9(current)
  • 10
  • 11
  • 86
  •   
[RELEASE] NetfliXBMC - Unofficial Netflix Add-on (Win/OSX/Linux)
Getting this when I export "My List" to library..

Code:
10:00:09 T:2760   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.WindowsError'>
                                            Error Contents: (3, 'The system cannot find the path specified', u'C:\\Users\\xbmc\\AppData\\Roaming\\XBMC\\userdata\\addon_data\\plugin.video.netflixbmc\\library\\TV\\DreamWorks How to Train Your Dragon...\\Season 1')
                                            Traceback (most recent call last):
                                              File "C:\Users\xbmc\AppData\Roaming\XBMC\addons\plugin.video.netflixbmc\default.py", line 723, in <module>
                                                addMyListToLibrary()
                                              File "C:\Users\xbmc\AppData\Roaming\XBMC\addons\plugin.video.netflixbmc\default.py", line 350, in addMyListToLibrary
                                                addSeriesToLibrary(videoID, title, "", False)
                                              File "C:\Users\xbmc\AppData\Roaming\XBMC\addons\plugin.video.netflixbmc\default.py", line 544, in addSeriesToLibrary
                                                os.mkdir(seasonDir)
                                            WindowsError: (3, 'The system cannot find the path specified', u'C:\\Users\\xbmc\\AppData\\Roaming\\XBMC\\userdata\\addon_data\\plugin.video.netflixbmc\\library\\TV\\DreamWorks How to Train Your Dragon...\\Season 1')
                                            -->End of Python script error report<--
Reply
v1.1.7:
- Fixed adding "My List" to library

(2013-12-15, 18:30)locoguano Wrote: Getting this when I export "My List" to library..

Code:
10:00:09 T:2760   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.WindowsError'>
                                            Error Contents: (3, 'The system cannot find the path specified', u'C:\\Users\\xbmc\\AppData\\Roaming\\XBMC\\userdata\\addon_data\\plugin.video.netflixbmc\\library\\TV\\DreamWorks How to Train Your Dragon...\\Season 1')
                                            Traceback (most recent call last):
                                              File "C:\Users\xbmc\AppData\Roaming\XBMC\addons\plugin.video.netflixbmc\default.py", line 723, in <module>
                                                addMyListToLibrary()
                                              File "C:\Users\xbmc\AppData\Roaming\XBMC\addons\plugin.video.netflixbmc\default.py", line 350, in addMyListToLibrary
                                                addSeriesToLibrary(videoID, title, "", False)
                                              File "C:\Users\xbmc\AppData\Roaming\XBMC\addons\plugin.video.netflixbmc\default.py", line 544, in addSeriesToLibrary
                                                os.mkdir(seasonDir)
                                            WindowsError: (3, 'The system cannot find the path specified', u'C:\\Users\\xbmc\\AppData\\Roaming\\XBMC\\userdata\\addon_data\\plugin.video.netflixbmc\\library\\TV\\DreamWorks How to Train Your Dragon...\\Season 1')
                                            -->End of Python script error report<--
Did you used adding my list to library before? If yes, was it generally working for you? Just some new items are causing the error? Does the parent folders exist (TV / DreamWorks How to Train Your Dragon...)? If you try it again, you always get the same error? Adding single movies/shows/seasons is working for you? I now fixed adding my list to library, so it still continues if it has problems with some movie/show.
Reply
Seems to be working perfectly under 1.1.7.
Thanks.

(2013-12-15, 18:48)AddonScriptorDE Wrote: Did you used adding my list to library before? If yes, was it generally working for you? Just some new items are causing the error? Does the parent folders exist (TV / DreamWorks How to Train Your Dragon...)? If you try it again, you always get the same error? Adding single movies/shows/seasons is working for you? I now fixed adding my list to library, so it still continues if it has problems with some movie/show.

Actually, it worked fine on my laptop under Ubuntu 13.10. My HTPC runs Win 7 and that is where the issue occurred. This was the first time I tried to export on the Win 7 pc.

Even after removing "Dreamworks..." it was hanging on other videos. Now it works great.
Reply
(2013-12-15, 19:12)locoguano Wrote: Seems to be working perfectly under 1.1.7.
Thanks.

(2013-12-15, 18:48)AddonScriptorDE Wrote: Did you used adding my list to library before? If yes, was it generally working for you? Just some new items are causing the error? Does the parent folders exist (TV / DreamWorks How to Train Your Dragon...)? If you try it again, you always get the same error? Adding single movies/shows/seasons is working for you? I now fixed adding my list to library, so it still continues if it has problems with some movie/show.

Actually, it worked fine on my laptop under Ubuntu 13.10. My HTPC runs Win 7 and that is where the issue occurred. This was the first time I tried to export on the Win 7 pc.

Even after removing "Dreamworks..." it was hanging on other videos. Now it works great.
Nice! Smile I just added some try catch statements because i had no idea what caused the error for you. Maybe it was just some strange coincidence...
Reply
To all Linux/OSX users:
I got no feedback about the xdotool / cliclick implementation yet...
Did someone tried it? Is it working as it should?
Reply
(2013-12-15, 19:58)AddonScriptorDE Wrote: To all Linux/OSX users:
I got no feedback about the xdotool / cliclick implementation yet...
Did someone tried it? Is it working as it should?

Yes! I use xdotool and it works fine. Less delay would work, if I pick the wrong show and close the browser I need to wait a bit before it will let me do something.

I have a nuisance problem where upon returning from the browser XBMC displays the message "Remote Share" "Could not connect to network server", even though everything worked fine. I am using Gotham nightly on Ubuntu 13.10.

Here are the logs that correlate with that message:
Code:
10:34:51 T:139722829514496    INFO: CPythonInvoker(12, /home/rpress/.xbmc/addons/plugin.video.netflixbmc/default.py): script successfully run
10:34:51 T:139722829514496    INFO: Python script stopped
10:34:51 T:139722829514496   DEBUG: Thread LanguageInvoker 139722829514496 terminating
10:34:51 T:139723246913280   DEBUG:  WaitOnScriptResult - plugin exited prematurely - terminating
10:34:51 T:139724680128384   ERROR: GetDirectory - Error getting plugin://plugin.video.netflixbmc/?mode=playVideo&name=12%2f15%2f13%20-%20Futurama%3a%20Season%2010%3a%20%22The%20Inhuman%20Torch%22&thumb=%2fhome%2frpress%2f.xbmc%2fuserdata%2faddon_data%2fplugin.video.netflixbmc%2fcache%2fcovers%2f70295197.jpg&url=70295197
10:34:51 T:139724680128384   ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.netflixbmc/?mode=playVideo&name=12%2f15%2f13%20-%20Futurama%3a%20Season%2010%3a%20%22The%20Inhuman%20Torch%22&thumb=%2fhome%2frpress%2f.xbmc%2fuserdata%2faddon_data%2fplugin.video.netflixbmc%2fcache%2fcovers%2f70295197.jpg&url=70295197) failed
10:34:51 T:139724680128384   DEBUG: CGUIMediaWindow::GetDirectory (plugin://plugin.video.netflixbmc/?mode=listViewingActivity&thumb&url)
10:34:51 T:139724680128384   DEBUG:   ParentPath = [plugin://plugin.video.netflixbmc/]

Thank you for your work! Netflix has been the last piece to have an all-in-one solution.
Reply
(2013-12-15, 20:48)presslab Wrote:
(2013-12-15, 19:58)AddonScriptorDE Wrote: To all Linux/OSX users:
I got no feedback about the xdotool / cliclick implementation yet...
Did someone tried it? Is it working as it should?

Yes! I use xdotool and it works fine. Less delay would work, if I pick the wrong show and close the browser I need to wait a bit before it will let me do something.
Thanks for the feedback. When i find some time i will try to tune the timings. Or i will give the user the chance to change it...

(2013-12-15, 20:48)presslab Wrote: I have a nuisance problem where upon returning from the browser XBMC displays the message "Remote Share" "Could not connect to network server", even though everything worked fine. I am using Gotham nightly on Ubuntu 13.10.
Mm, some other user also mentioned this message. Don't really know where it comes from.
I only sometimes get a xbmc message when playing via the library. And i guess i can't do anything against it (except using a custom playercorefactory.xml).
Reply
I am using the Yatse Android remote. How much pain am I asking for to try to use this plugin with that remote?
Reply
Also, I noticed that when you load Chrome in kiosk mode, the frame rates of Netflix are slightly choppy. The only fix to this is to use the mouse to click on the full screen button. This is at 1080P in Mavericks and Frodo 12.2 w/Mavericks fix.

Is there a way to force an automatic full screen shortcut/keystroke script upon load of a video through NetfliXBMC when Chrome launches?

As well, I've been experimenting with Better Touch Tool on OSX to try to remap the Apple Remote to send keystrokes to Chrome to perform the following commands:

Apple Remote = Keystroke
Play/Pause = either Enter or Spacebar
Left = Left Arrow (rewind)
Right = Right Arrow (fast forward)
Menu = Esc then CMD+Q (stop and close window to return to XBMC)

For the life of me, I cannot get any of these to work except for the close window function, unless I manually click on the Chrome window with the mouse function. Does NetfliXBMC load up Chrome but still keep XBMC as the active window? If so, is there a way to make Chrome be active window?

If any of you have a better program/script to control NetfliXBMC with the Apple Remote while still keeping the default Apple Remote control of XBMC, please let me know.

Thanks!
Reply
(2013-12-16, 03:11)debianlinux Wrote: I am using the Yatse Android remote. How much pain am I asking for to try to use this plugin with that remote?
Sorry, i don't really understand your question. But i have no Android device anyway...

(2013-12-16, 07:16)BrennanD Wrote: Also, I noticed that when you load Chrome in kiosk mode, the frame rates of Netflix are slightly choppy. The only fix to this is to use the mouse to click on the full screen button. This is at 1080P in Mavericks and Frodo 12.2 w/Mavericks fix.
It's not related to the kiosk mode. I also noticed it on 1 of 2 osx testing systems when not in fullscreen mode, but it's the same when running Chrome normally.
You can also press the 'f' key to enter fullscreen mode...

(2013-12-16, 07:16)BrennanD Wrote: Is there a way to force an automatic full screen shortcut/keystroke script upon load of a video through NetfliXBMC when Chrome launches?
Unfortunately not under OSX, except with simulating the mouse (but if i implement automation, i would only do it by sending keystrokes).
Cliclick can only send some special keys. If you know some other app, which runs on most used osx versions and is able to simulate mouse/keyboard, let me know.

(2013-12-16, 07:16)BrennanD Wrote: For the life of me, I cannot get any of these to work except for the close window function, unless I manually click on the Chrome window with the mouse function. Does NetfliXBMC load up Chrome but still keep XBMC as the active window? If so, is there a way to make Chrome be active window?
This is the normal Browser/Silverlight behavior. Chrome is active/focused and can collect keystrokes. That is why you can close the browser via CMD+Q. But to control the Netflix Player, you need to click on the screen. For this reason, i implemented cliclick support. If you have it installed, the cursor gets hidden and the Player focused so you can directly control it without mouse. See first post...

(2013-12-15, 17:26)AddonScriptorDE Wrote:
(2013-12-15, 06:14)BrennanD Wrote: My fix to this (OSX Mavericks, Froto 12.2 and Chrome) was to initially load up Netflix with Chrome through OSX and log into Netflix and use as normal web browsing viewing. After I went to http://whatsmyuseragent.com and replaced the result in bold in the default.py file in the "useragent" line (located in /Users/(Your OSX User Folder)/Library/Application Support/XBMC/addons/plugins.videos.netflixbmc).
I also added the custom UserAgent to OSX/Chrome because of some reported problems without. But i got no further feedback from the user, so i now reverted the changes.
Is v1.1.6 now working again for you (without modifying the UA)? If not, i'll add a solution for using a custom UA, which is permanently stored in the addons userdata dir...
Just for confirmation: Is it working now?
Reply
I guess I know the answer but still ill ask is this working on raspberry pi running openelec i'm using dns service tu watch us content
Reply
(2013-12-16, 09:32)AddonScriptorDE Wrote:
(2013-12-16, 03:11)debianlinux Wrote: I am using the Yatse Android remote. How much pain am I asking for to try to use this plugin with that remote?
Sorry, i don't really understand your question. But i have no Android device anyway...

(2013-12-16, 07:16)BrennanD Wrote: Also, I noticed that when you load Chrome in kiosk mode, the frame rates of Netflix are slightly choppy. The only fix to this is to use the mouse to click on the full screen button. This is at 1080P in Mavericks and Frodo 12.2 w/Mavericks fix.
It's not related to the kiosk mode. I also noticed it on 1 of 2 osx testing systems when not in fullscreen mode, but it's the same when running Chrome normally.
You can also press the 'f' key to enter fullscreen mode...

(2013-12-16, 07:16)BrennanD Wrote: Is there a way to force an automatic full screen shortcut/keystroke script upon load of a video through NetfliXBMC when Chrome launches?
Unfortunately not under OSX, except with simulating the mouse (but if i implement automation, i would only do it by sending keystrokes).
Cliclick can only send some special keys. If you know some other app, which runs on most used osx versions and is able to simulate mouse/keyboard, let me know.

(2013-12-16, 07:16)BrennanD Wrote: For the life of me, I cannot get any of these to work except for the close window function, unless I manually click on the Chrome window with the mouse function. Does NetfliXBMC load up Chrome but still keep XBMC as the active window? If so, is there a way to make Chrome be active window?
This is the normal Browser/Silverlight behavior. Chrome is active/focused and can collect keystrokes. That is why you can close the browser via CMD+Q. But to control the Netflix Player, you need to click on the screen. For this reason, i implemented cliclick support. If you have it installed, the cursor gets hidden and the Player focused so you can directly control it without mouse. See first post...

(2013-12-15, 17:26)AddonScriptorDE Wrote:
(2013-12-15, 06:14)BrennanD Wrote: My fix to this (OSX Mavericks, Froto 12.2 and Chrome) was to initially load up Netflix with Chrome through OSX and log into Netflix and use as normal web browsing viewing. After I went to http://whatsmyuseragent.com and replaced the result in bold in the default.py file in the "useragent" line (located in /Users/(Your OSX User Folder)/Library/Application Support/XBMC/addons/plugins.videos.netflixbmc).
I also added the custom UserAgent to OSX/Chrome because of some reported problems without. But i got no further feedback from the user, so i now reverted the changes.
Is v1.1.6 now working again for you (without modifying the UA)? If not, i'll add a solution for using a custom UA, which is permanently stored in the addons userdata dir...
Just for confirmation: Is it working now?

I'm on 1.1.7 and the Silverlight plugin loads up in Chrome without any issues. Thanks.
Reply
Hi all.

Pulling my hair out here. I have installed this addon on OSX and I can't see it listed in Programs or any reference to errors in log files. I have configured it etc and tried reboots, all to no avail. It simple doesn't appear.

Chrome Launcher did install and does appear in Programs and can be configured, but fails to launch.

Any advice on where to start looking for issues appreciated.
Reply
(2013-12-16, 11:40)Doktor-X Wrote: I guess I know the answer but still ill ask is this working on raspberry pi running openelec i'm using dns service tu watch us content
Looks like Pipelight won't run on the RPi. But if it's possible someday, this addon will also work.

(2013-12-16, 14:24)BrennanD Wrote:
(2013-12-16, 09:32)AddonScriptorDE Wrote: Just for confirmation: Is it working now?
I'm on 1.1.7 and the Silverlight plugin loads up in Chrome without any issues. Thanks.
Okay, thanks. Just wanted to make sure that it is running without modifying the UA, so that other osx users have no problems to set it up...

(2013-12-17, 01:41)Veng Wrote: I have installed this addon on OSX and I can't see it listed in Programs or any reference to errors in log files. I have configured it etc and tried reboots, all to no avail. It simple doesn't appear.
It's listed under Videos->Addons.

(2013-12-17, 01:41)Veng Wrote: Chrome Launcher did install and does appear in Programs and can be configured, but fails to launch.
If you have problems with it, please have a look at the Chrome Launcher thread.
There should not be much problems if Chrome is installed in "Applications"...
Reply
Looks like this is addons going to get some real interest with lifehackers write up!
Reply
  •   
  • 1
  • 7
  • 8
  • 9(current)
  • 10
  • 11
  • 86
  •   



Logout Mark Read Team Forum Stats Members Help
[RELEASE] NetfliXBMC - Unofficial Netflix Add-on (Win/OSX/Linux)7
This forum uses Lukasz Tkacz MyBB addons.