[RELEASE] NetfliXBMC - Unofficial Netflix Add-on (Win/OSX/Linux)
(2014-01-06, 21:50)jcato Wrote: The latest update undid some code changes that I had made, that for me, makes this plugin not work.

First, every movie and tv show has a 't' at the end of its title preventing XBMC scrapers from recognizing the show. About line 345 I changed:
Forgot to change it there too. Fixed it.

(2014-01-06, 21:50)jcato Wrote: Second, the plugin appends the year to the title. This is needed for movies, but prevents the TV scraper from recognizing the show. I moved the following line (about 353) to before the call to addMovieToLibrary (line 364). I also added the if statement in case year is blank. This puts the year on movies, but not tv shows.
I thought the year was needed for some shows. I now removed it. Let's see if it's working fine without.

(2014-01-06, 21:50)jcato Wrote: Finally, if a show expires or is removed from My List it is still in the library. So, I added code to delete all movie and tv show folders before exporting My List:
Does not really make sense. I added some movies that are not in my list. With your changes, these stuff would get lost...

(2014-01-07, 09:33)MorningWood Wrote: The plugin seems to be working for me on Crystalbuntu 2 for the ATV but when the Chrome browser launches, it asks to sign in. Any work around for this?
Maybe just sign in? Netflix should remember it...

(2014-01-09, 05:58)capomatt Wrote: Seems like there should be an easy fix for this because I read through the whole thread and I'm the only one with this problem which makes me think I probably have a simple setting in Chrome I might need to change.
You can simply use the "Use own user profile" setting in Chrome Launcher. That will solve your issues.

(2014-01-09, 05:58)capomatt Wrote: As a side note, it's a little annoying how the mouse cursor it still visible in the IE window so I found a little program called AutoHideMouseCursor that lets you set a timer for having the mouse disappear after a certain time period. Set mine for 10 seconds.
Is my Control Utility not working for you?

(2014-01-10, 12:58)rickelodeon Wrote: The Add on works great!

I have tested here with XBMC Frodo & Netflix Netherlands.
One question:

After watching a movie or choosing the back button on the left hand upper screen, I am directed to the mainpage of Netflix itself.
Is there a way to get back to XBMC?
No, sorry. You have to close the browser via alt+f4 or use my control utility.

(2014-01-10, 12:58)rickelodeon Wrote: When I exit Netflix (ALT+F4) my XBMC is minimized. It would be great to get back to XBMC.

I'm using a windows computer (Windows XP) connected with a RGB kabel to my Plasma and a wireless keyboard.
Try activating: System->System->Video Output->Use a fullscreen window rather than true fullscreen

(2014-01-11, 06:13)cgrey Wrote: Awesome plugin - thanks for all your effort.

Am I the only one experiencing this? No matter what I search for (using the search function), I get "no results found". I've tried search for movies and tv shows that I know for sure exist, both full and partial titles - for example "Top" and "Top Gear" both return no results, while Top Gear is definitely a show on Netflix. Same with "House" or "House of Cards" - just two examples.
(2014-01-23, 17:57)Motopsychoz Wrote: I installed this plug in and I can't seem to get the search feature to work. No matter what search criteria I enter, it returns nothing. Am I doing something wrong? Thanks
Mmm, working fine here. Are you living outside the US?

(2014-01-13, 19:42)kcarson Wrote: Hi, I'm in the UK with a subscription DNS giving me access to US netflix so would expect english. Strangely some TV shows expand to give seasons or episodes, a lot don't though. Dr Who works ok, Walking Dead doesn't. Walking dead plays OK when set to play automatically rather than give season/episode view.

I'll switch on some debug and check the log again, and also have a look at the html source.
Yes. Some DNS are not working. No solution yet.

(2014-01-17, 06:38)SkOrPn Wrote: Wow, I can't believe I just found this XBMC addon. Its like a dream come true, lol. Thank You!

However, I do have one question and surprisingly I cant seem to find the answer after reading every page. I am on Windows 8.1 and I use Netflix exclusively in IE11 because of its HTML5 playback. In fact, it is the ONLY reason I use IE so Netflix is set as the home page and I keep IE11 running in RAM so that it is instantaneous at everything. I do not have SilverLight installed and do not want to install it if I do not have to. Does this just call up the browser in full screen and does not care if the browser uses SilverLight or HTML5? Or does this add-on actually require SilverLight to be installed? SilverLight was obviously abandoned by Microsoft, so I would much prefer to use Internet Explorers built-in HTML5 player.

Any idea if this will work with HTML5? Thanks again, I love this Netflix in XBMC idea Big Grin
Should work the same. Would be nice if you can try it and give us some feedback...

(2014-01-19, 09:42)TerranQ Wrote:
(2014-01-19, 00:31)fillerguy Wrote: Has anybody solved this error? I see a few people here are having the same issue. Fresh OS install (Windows), install XBMC, install this plug-in and it won't work - log shows URLError: <urlopen error [Errno 8] _ssl.c:490: EOF occurred in violation of protocol> errors

edit : if I copy everything from my working machine (C:\Users\AppData\Roaming\xbmc) overwriting everything on the machine that doesn't work, it fixes the problem. Seems this add-on requires something else to be installed in order to work.

Nope, I still haven't solved it. I've never been able to get this addon working
Are you using a proxy? If so, it must support SSL.
Don't know what else could cause SSL problems...

(2014-01-19, 13:55)hstegeman Wrote: I am having problems adding the tv serie
Generation war (2013) or Unsere Mütter, unsere Väter (2013)
to my xbmc library.

http://www.imdb.com/title/tt1883092/

The result is that the tv serie Breaking bad has been added.
I removed the year from tvshows in v1.2.4. Please try again.

(2014-01-21, 21:11)Etnies Wrote: Is there anyway for this to work with the xbmc app instead of a remote? I have it working perfect with a remote but using an iPad for the bedroom setup but obviously need the alt f4 kill window command.. I could use logmein and do it that way but it's a bit messy

Thanks


By the way great Add on registered just for it
Not yet. But I'll try to implement a solution for this.

(2014-01-22, 10:29)404error Wrote: Is there a way to add all the content from Netflix to the XBMC-Library and keep it up to date? I've only seen the option for one movie at a time.
No, only single movies/shows or your list...

(2014-01-23, 19:39)locomot1f Wrote: also, the new pipelight has some improvements to GPU Acceleration:
Quote:--[AMD GPU Acceleration]--
The Silverlight plugin still has some problems on AMD graphics card and the GPU acceleration is therefore disabled by default if Pipelight detects neither a NVIDIA nor Intel graphic card. We were now able to track down the problem to the drawing call ordering which is different between Windows and Wine's D3D layer. Stefan Dösinger is working for Codeweavers on a patchset to implement the same behaviour as on Windows, which also solves this problem. Nevertheless, applying around 200 patches on Wine makes maintaining much more complicated and we are therefore going to wait till they landed which hopefully shouldn't take too long. In the meantime we added the value 2 to the PIPELIGHT_GPUACCELERATION environment variable which will enforce the same drawing ordering as on Windows by waiting till the drawing commands are finished. This costs some performance but should be still perform better on newer cards than no gpu acceleration at all. To test it, simply start your browser from a terminal in the following manner:

PIPELIGHT_GPUACCELERATION=2 firefox

is there a way to do this? or is this for the Chrome Launcher?
Sounds like they are still working on this, so i won't add it. I guess they will directly implement it when it's fully working.
For now, you can test it yourself by replacing "/usr/bin/google-chrome" by "PIPELIGHT_GPUACCELERATION=2 /usr/bin/google-chrome" in Chrome Launcher's default.py.
Reply


Messages In This Thread
Search empty? - by cgrey - 2014-01-11, 06:13
RE: [RELEASE] NetfliXBMC - Inofficial Netflix Add-on (Win/OSX/Linux) - by AddonScriptorDE - 2014-01-26, 02:48
Not working on windows 7 - by dandiodati - 2014-02-26, 21:55
Problems with this addon - by builderjer - 2014-11-30, 19:55


Logout Mark Read Team Forum Stats Members Help
[RELEASE] NetfliXBMC - Unofficial Netflix Add-on (Win/OSX/Linux)7
This forum uses Lukasz Tkacz MyBB addons.