•   
  • 1
  • 54
  • 55
  • 56(current)
  • 57
  • 58
  • 86
  •   
[RELEASE] NetfliXBMC - Unofficial Netflix Add-on (Win/OSX/Linux)
(2014-09-20, 05:42)dversion Wrote: Woah hey! did internet explorer support get taken out!?

I needed it because i have my pc hooked up to my tv as a second monitor (where xbmc runs) and internet explorer opened up on the tv when i used this app, I also had a program that would automatically switch the default playback device to the tv if it saw IE open up.

Unless this is put back in does anyone have a solution for a two monitor setup?

^Exactly This.

I use the same setup, xbmc on second monitor with IE running on second monitor, Chrome used as my standard browser on other monitor.
At the moment, I have to just drag chrome between screens depending on what Im doing. Previously had issues with remote control and IE, noticed Chrome works fine with remote control, so thats a plus!

Would love to work out a way of NetfliXBMC launching chrome on second monitor, then for standard chrome use it opens on first monitor... but so far cant find any way of doing this. IE was my workaround...
Anyone have any ideas or suggestions? thanks (and thanks for this great add on btw)
Reply
Hi,

I am quite new to this. I have installed pipelight, enabled the silver-light plugin. Installed chrome launcher and NetfliXBMC. I have configured NetfliXBMC and run this. It allows me to login and view movies. However when I hit enter to select a title it says wprking and timesout. please help.
Reply
(2014-09-20, 14:56)ssufii Wrote: Hi,

I am quite new to this. I have installed pipelight, enabled the silver-light plugin. Installed chrome launcher and NetfliXBMC. I have configured NetfliXBMC and run this. It allows me to login and view movies. However when I hit enter to select a title it says wprking and timesout. please help.

The same problem with me, please help
Reply
Hi guys I was wondering if anyone else was had an issue with netflixbmc crashing when closed on win7. I works fine until i hit (alt f4) to close and the screen goes blank.
Reply
This was working perfectly with ie on win8 before the update to 1.3. Now I can't get chrome to launch most of the time. Or I get multi tabs open error. Remote control commands that I had set up through eventghost don't work anymore either. I've updated chrome to beta version 38+ too.

Any suggestions? Any way to get version 1.2.9 back?
Reply
(2014-09-19, 13:09)AddonScriptorDE Wrote: [quote='jawilljr' pid='1796927' dateline='1411092180']
Just to let you know, your addon works with Chrome 37 stable in Ubuntu 14.04. Of course you need the libnss files in 14.04.
Thanks for your feedback. Also nice to hear that v37 is working too. I only found info about Chrome >=38, so I'll leave it as required.

Read the comments here.

Quote:With Chrome 37 stable it works perfectly. Just don't forget about restarting Chrome. There is no actual need for Dev anymore since the latest update. Don't forget to enable EME chrome://flags/#enable-encrypted-media !

Anyway I can't wait for Ubuntu to update those files. No more User Agent string!
Reply
(2014-09-20, 19:43)ullms Wrote: This was working perfectly with ie on win8 before the update to 1.3. Now I can't get chrome to launch most of the time. Or I get multi tabs open error. Remote control commands that I had set up through eventghost don't work anymore either. I've updated chrome to beta version 38+ too.

Any suggestions? Any way to get version 1.2.9 back?

+1. It's great the author is updating the script but I don't think forcing us to use Chrome is necessary. I also had this working perfect under 8.1 with eventghost & IE. Can we at least have access to 1.2.9 ?
Reply
v1.3.1:
- Added more personal stuff to Suggestions
- Fixed Suggestions for multi-profile accounts
- Fixed bug with empty search results
- Readded support for IExplorer (HTML5 only supported in combination with Win 8.1)
- Added notification to inform users about new HTML5 Player / required Chrome version
- Webremote: changed xdotool key-definitons
- Improved downloading of tmdb content

(2014-09-19, 18:02)HenryFord Wrote:
(2014-09-19, 13:09)AddonScriptorDE Wrote:
(2014-09-19, 10:06)HenryFord Wrote: Nice Smile Hope I get it to work this time. Just to be sure: It should work on Helix or is this currently not supported? Thanks a ton!
Not tested - but it should work on helix. At least I hope so.
Okay, after my tests:
The addon itself works, I just have to disable "Get covers & fanart images from TVDB" as this breaks the addon. If I enable this option, the addon gets stuck on "Loading metadata" - If I cancel this, Kodi crashes completely.

Also Chrome does not open in Kiosk-Mode nor in Fullscreen, but I can live with that.
I'll also test it under helix next week.

(2014-09-19, 19:36)-Dis Wrote: Added
if not singleProfile:
setProfile()
to
def wiHome(type):
Thanks for mentioning. I forgot to add it...

(2014-09-19, 19:36)-Dis Wrote: Would it be possible to get the popular on Netflix and recommendations for the user to netflixbmc?
Added to v1.3.1

(2014-09-19, 21:17)boe2 Wrote: Ok, I managed to fix the problem. On my system the keynames for xdotool are case sensitive

from line 849 and onwards in default.py, I changed to code to this:
Thanks. I'm not really sure if I tested the webremote stuff under Linux. Changed in 1.3.1

(2014-09-19, 21:17)boe2 Wrote: Do you accept pull requests on github, or do you rather want to keep this in own hands? I have some python experience, but this is my first time working with XBMC addons.
You can keep posting here or use github. But I'm not really frequently visiting github.

(2014-09-19, 22:06)Tha_soh Wrote: I've installed NetfliXMBC on my Raspberry Pi that is using openELEC. I've also installed Chrome.
Chrome >=38 is required, which is not available for the RPi/OpenElec. See first post.

(2014-09-20, 00:27)Keizo_Nishi Wrote: But it doesn't put XBMC on top again. that is the only issue i got.
Mmm. Maybe activating "Use a fullscreen window rather than true fullscreen" via "Settings->System->Video Output" solves this.

(2014-09-20, 00:33)mr.willem Wrote: I don't know if anyone else is expecting the problem that audio is not working on Linux (xbmc, ALSA) but to suspend the audio I made a small workaround last night in the code of the plugin.
(2014-09-20, 01:06)kubax Wrote: still can't get audio from my videos. The interesting thing here is, that when i start chrome with xpra (X window redirection) i get sound over HDMI when i head over to netflix and start streaming a movie on my wifes notebook.
You can try turning "Keep audio device alive" off via "Settings->System->Audio Output".

(2014-09-20, 05:42)dversion Wrote: Woah hey! did internet explorer support get taken out!?

I needed it because i have my pc hooked up to my tv as a second monitor (where xbmc runs) and internet explorer opened up on the tv when i used this app, I also had a program that would automatically switch the default playback device to the tv if it saw IE open up.

Unless this is put back in does anyone have a solution for a two monitor setup?
(2014-09-20, 13:46)rjonesdj Wrote: ^Exactly This.

I use the same setup, xbmc on second monitor with IE running on second monitor, Chrome used as my standard browser on other monitor.
At the moment, I have to just drag chrome between screens depending on what Im doing. Previously had issues with remote control and IE, noticed Chrome works fine with remote control, so thats a plus!

Would love to work out a way of NetfliXBMC launching chrome on second monitor, then for standard chrome use it opens on first monitor... but so far cant find any way of doing this. IE was my workaround...
Anyone have any ideas or suggestions? thanks (and thanks for this great add on btw)
I tried it on a multi-monitor setup with Chrome and worked perfectly. Just open Chrome manually and put it on the second monitor. Then close Chrome. It will then be started on that monitor next time.
If you are using Chrome for other things than NetfliXBMC and don't want to change your settings/behaviour, you can also use a seperate profile.

(2014-09-20, 11:58)itsmyworld18200 Wrote: Hello I need Help. I installed XBMC on my Apple Tv 1 and succesfully installed NEtfilxbmc. ALl goes right and I select the movie, but than it shows 'WORKING' and after that nothing. it goes back to movies menu. The movies are not playing. I am on Gotham and installed XBMC on apple TV directly and not on USB.
AppleTV (iOS) is not supported. Chrome >=38 is required. See first post.

(2014-09-20, 14:56)ssufii Wrote: I am quite new to this. I have installed pipelight, enabled the silver-light plugin. Installed chrome launcher and NetfliXBMC. I have configured NetfliXBMC and run this. It allows me to login and view movies. However when I hit enter to select a title it says wprking and timesout. please help.
(2014-09-20, 15:53)itsmyworld18200 Wrote: The same problem with me, please help
Silverlight/Pipelight is no longer required/supported. See first post.

(2014-09-20, 17:45)loknez Wrote: Hi guys I was wondering if anyone else was had an issue with netflixbmc crashing when closed on win7. I works fine until i hit (alt f4) to close and the screen goes blank.
When using Windows in combination with the Control Utility, you have to quit Chrome via a mapped key. When using Alt+F4, the Control Utility does not get closed.
Of course, you can also disable the Control Utility and then close Chrome via Alt+F4.

(2014-09-20, 19:43)ullms Wrote: This was working perfectly with ie on win8 before the update to 1.3. Now I can't get chrome to launch most of the time. Or I get multi tabs open error. Remote control commands that I had set up through eventghost don't work anymore either. I've updated chrome to beta version 38+ too.

Any suggestions? Any way to get version 1.2.9 back?
(2014-09-21, 00:20)fillerguy Wrote: +1. It's great the author is updating the script but I don't think forcing us to use Chrome is necessary. I also had this working perfect under 8.1 with eventghost & IE. Can we at least have access to 1.2.9 ?
I readded support for IExplorer because it also supports HTML5 DRM in combination with Win 8.1...
Reply
Even with your stupid warning, it still works with the latest Chrome stable in Linux.

I will provide more links if you want me to.
Reply
You say you added support for Iexplorer back with win 8.1, how do we use it? I didn't see anything in the settings to change the preferred browser.

Thanks!

(2014-09-21, 03:41)AddonScriptorDE Wrote: v1.3.1:
- Added more personal stuff to Suggestions
- Fixed Suggestions for multi-profile accounts
- Fixed bug with empty search results
- Readded support for IExplorer (HTML5 only supported in combination with Win 8.1)
- Added notification to inform users about new HTML5 Player / required Chrome version
- Webremote: changed xdotool key-definitons
- Improved downloading of tmdb content

(2014-09-19, 18:02)HenryFord Wrote:
(2014-09-19, 13:09)AddonScriptorDE Wrote: Not tested - but it should work on helix. At least I hope so.
Okay, after my tests:
The addon itself works, I just have to disable "Get covers & fanart images from TVDB" as this breaks the addon. If I enable this option, the addon gets stuck on "Loading metadata" - If I cancel this, Kodi crashes completely.

Also Chrome does not open in Kiosk-Mode nor in Fullscreen, but I can live with that.
I'll also test it under helix next week.

(2014-09-19, 19:36)-Dis Wrote: Added
if not singleProfile:
setProfile()
to
def wiHome(type):
Thanks for mentioning. I forgot to add it...

(2014-09-19, 19:36)-Dis Wrote: Would it be possible to get the popular on Netflix and recommendations for the user to netflixbmc?
Added to v1.3.1

(2014-09-19, 21:17)boe2 Wrote: Ok, I managed to fix the problem. On my system the keynames for xdotool are case sensitive

from line 849 and onwards in default.py, I changed to code to this:
Thanks. I'm not really sure if I tested the webremote stuff under Linux. Changed in 1.3.1

(2014-09-19, 21:17)boe2 Wrote: Do you accept pull requests on github, or do you rather want to keep this in own hands? I have some python experience, but this is my first time working with XBMC addons.
You can keep posting here or use github. But I'm not really frequently visiting github.

(2014-09-19, 22:06)Tha_soh Wrote: I've installed NetfliXMBC on my Raspberry Pi that is using openELEC. I've also installed Chrome.
Chrome >=38 is required, which is not available for the RPi/OpenElec. See first post.

(2014-09-20, 00:27)Keizo_Nishi Wrote: But it doesn't put XBMC on top again. that is the only issue i got.
Mmm. Maybe activating "Use a fullscreen window rather than true fullscreen" via "Settings->System->Video Output" solves this.

(2014-09-20, 00:33)mr.willem Wrote: I don't know if anyone else is expecting the problem that audio is not working on Linux (xbmc, ALSA) but to suspend the audio I made a small workaround last night in the code of the plugin.
(2014-09-20, 01:06)kubax Wrote: still can't get audio from my videos. The interesting thing here is, that when i start chrome with xpra (X window redirection) i get sound over HDMI when i head over to netflix and start streaming a movie on my wifes notebook.
You can try turning "Keep audio device alive" off via "Settings->System->Audio Output".

(2014-09-20, 05:42)dversion Wrote: Woah hey! did internet explorer support get taken out!?

I needed it because i have my pc hooked up to my tv as a second monitor (where xbmc runs) and internet explorer opened up on the tv when i used this app, I also had a program that would automatically switch the default playback device to the tv if it saw IE open up.

Unless this is put back in does anyone have a solution for a two monitor setup?
(2014-09-20, 13:46)rjonesdj Wrote: ^Exactly This.

I use the same setup, xbmc on second monitor with IE running on second monitor, Chrome used as my standard browser on other monitor.
At the moment, I have to just drag chrome between screens depending on what Im doing. Previously had issues with remote control and IE, noticed Chrome works fine with remote control, so thats a plus!

Would love to work out a way of NetfliXBMC launching chrome on second monitor, then for standard chrome use it opens on first monitor... but so far cant find any way of doing this. IE was my workaround...
Anyone have any ideas or suggestions? thanks (and thanks for this great add on btw)
I tried it on a multi-monitor setup with Chrome and worked perfectly. Just open Chrome manually and put it on the second monitor. Then close Chrome. It will then be started on that monitor next time.
If you are using Chrome for other things than NetfliXBMC and don't want to change your settings/behaviour, you can also use a seperate profile.

(2014-09-20, 11:58)itsmyworld18200 Wrote: Hello I need Help. I installed XBMC on my Apple Tv 1 and succesfully installed NEtfilxbmc. ALl goes right and I select the movie, but than it shows 'WORKING' and after that nothing. it goes back to movies menu. The movies are not playing. I am on Gotham and installed XBMC on apple TV directly and not on USB.
AppleTV (iOS) is not supported. Chrome >=38 is required. See first post.

(2014-09-20, 14:56)ssufii Wrote: I am quite new to this. I have installed pipelight, enabled the silver-light plugin. Installed chrome launcher and NetfliXBMC. I have configured NetfliXBMC and run this. It allows me to login and view movies. However when I hit enter to select a title it says wprking and timesout. please help.
(2014-09-20, 15:53)itsmyworld18200 Wrote: The same problem with me, please help
Silverlight/Pipelight is no longer required/supported. See first post.

(2014-09-20, 17:45)loknez Wrote: Hi guys I was wondering if anyone else was had an issue with netflixbmc crashing when closed on win7. I works fine until i hit (alt f4) to close and the screen goes blank.
When using Windows in combination with the Control Utility, you have to quit Chrome via a mapped key. When using Alt+F4, the Control Utility does not get closed.
Of course, you can also disable the Control Utility and then close Chrome via Alt+F4.

(2014-09-20, 19:43)ullms Wrote: This was working perfectly with ie on win8 before the update to 1.3. Now I can't get chrome to launch most of the time. Or I get multi tabs open error. Remote control commands that I had set up through eventghost don't work anymore either. I've updated chrome to beta version 38+ too.

Any suggestions? Any way to get version 1.2.9 back?
(2014-09-21, 00:20)fillerguy Wrote: +1. It's great the author is updating the script but I don't think forcing us to use Chrome is necessary. I also had this working perfect under 8.1 with eventghost & IE. Can we at least have access to 1.2.9 ?
I readded support for IExplorer because it also supports HTML5 DRM in combination with Win 8.1...
Reply
(2014-09-21, 03:41)AddonScriptorDE Wrote: v1.3.1:
- Added more personal stuff to Suggestions
- Fixed Suggestions for multi-profile accounts
- Fixed bug with empty search results
- Readded support for IExplorer (HTML5 only supported in combination with Win 8.1)
- Added notification to inform users about new HTML5 Player / required Chrome version
- Webremote: changed xdotool key-definitons
- Improved downloading of tmdb content
Thanks so much!!! Works great Big Grin Never thought of such a nice xbmc integration

(2014-09-21, 04:18)jawilljr Wrote: Even with your stupid warning, it still works with the latest Chrome stable in Linux.

I will provide more links if you want me to.
What's wrong with you? The message was very helpful: I had the addon installed but did not noticed any update. Only because of the notification I knew that I had to update Chrome.
I had Chrome installed before (don't know which version), and only after installing the beta the HTML5 UI was used. Before only Silverlight. I'm using Win8.1.

(2014-09-21, 05:09)ivwshane1 Wrote: You say you added support for Iexplorer back with win 8.1, how do we use it? I didn't see anything in the settings to change the preferred browser.
http://imgur.com/OptnTpo
Works fine for me. Only Enter / OK on MCE remote is not working for me via IE. So I keep using Chrome.
Reply
Quote:What's wrong with you? The message was very helpful: I had the addon installed but did not noticed any update. Only because of the notification I knew that I had to update Chrome.
I had Chrome installed before (don't know which version), and only after installing the beta the HTML5 UI was used. Before only Silverlight. I'm using Win8.1.

Because I hate it when devs don't listen. And I see you are using Windows. Right now Chrome 37 stable works in Linux with Netflix. Don't know about Windows. Me I did not have to update Chrome. Don't know about Windows. Why use Beta when Stable works?

What is is wrong with the Dev?

I will provide more links, if necessary.
Reply
(2014-09-21, 06:16)jawilljr Wrote:
Quote:What's wrong with you? The message was very helpful: I had the addon installed but did not noticed any update. Only because of the notification I knew that I had to update Chrome.
I had Chrome installed before (don't know which version), and only after installing the beta the HTML5 UI was used. Before only Silverlight. I'm using Win8.1.

Because I hate it when devs don't listen. And I see you are using Windows. Right now Chrome 37 stable works in Linux with Netflix. Don't know about Windows. Me I did not have to update Chrome. Don't know about Windows. Why use Beta when Stable works.
I needed to install Chrome beta to get it working, so the statement of the dev is absolutely right Confused
Maybe also Chrome 30 works with Netflix, but to get the advantages of the new HTML5 UI, you need a newer Chrome version.
If you google for "netflix chrome html5" you'll find a lot of info that Chrome beta is required.

(2014-09-21, 06:16)jawilljr Wrote: What is is wrong with the Dev?
Nothing is wrong with the dev! He is providing brilliant software for free and people like you are only complaining here!
Go trolling somewhere else!!!
Reply
(2014-09-21, 06:30)ravenxx Wrote:
(2014-09-21, 06:16)jawilljr Wrote:
Quote:What's wrong with you? The message was very helpful: I had the addon installed but did not noticed any update. Only because of the notification I knew that I had to update Chrome.
I had Chrome installed before (don't know which version), and only after installing the beta the HTML5 UI was used. Before only Silverlight. I'm using Win8.1.

Because I hate it when devs don't listen. And I see you are using Windows. Right now Chrome 37 stable works in Linux with Netflix. Don't know about Windows. Me I did not have to update Chrome. Don't know about Windows. Why use Beta when Stable works.
I needed to install Chrome beta to get it working, so the statement of the dev is absolutely right Confused
Maybe also Chrome 30 works with Netflix, but to get the advantages of the new HTML5 UI, you need a newer Chrome version.
If you google for "netflix chrome html5" you'll find a lot of info that Chrome beta is required.

Read the comments.

The article also says that you need Chrome-dev ver 37 to get Netflix in Linux to work. Now that it is stable, no problem. Like I said I don't know about Windows.

Quote:What is is wrong with the Dev?
Nothing is wrong with the dev! He is providing brilliant software for free and people like you are only complaining here!
Go trolling somewhere else!!!

Notihing wrong about the dev. He is doing an excellent job, just listen.

Like I said, why use beta when you don't have to.
Reply
(2014-09-21, 07:01)jawilljr Wrote: Read the comments.

The article also says that you need Chrome-dev ver 37 to get Netflix in Linux to work. Now that it is stable, no problem. Like I said I don't know about Windows.
As you (and the linked article) say, you'll need Chrome dev or beta. Stable Chrome versions are currently not working!
So you are complaining because the dev has written "beta version is required" instead of "beta or dev version is required"?
Reply
  •   
  • 1
  • 54
  • 55
  • 56(current)
  • 57
  • 58
  • 86
  •   



Logout Mark Read Team Forum Stats Members Help
[RELEASE] NetfliXBMC - Unofficial Netflix Add-on (Win/OSX/Linux)7
This forum uses Lukasz Tkacz MyBB addons.