•   
  • 1
  • 60
  • 61
  • 62(current)
  • 63
  • 64
  • 86
  •   
[RELEASE] NetfliXBMC - Unofficial Netflix Add-on (Win/OSX/Linux)
Hi,

thanks for this plugin. Using it for a bit now, but I have two major issues:

* Xbmc blanks the screen while chrome is playing. Is it possible to inhibit the screen saver while the addon is running?

* I tried to map lirc remote keypresses to some keyboard events to control the player window. This seems to work, however xbmc still accepts those keypresses too. Is it possible to change the browser invokation in xbmc to a blocking call, so xbmc wouldn't move around behind the scenes? Maybe that would solve the first issue too.

Other then that, I'm quite impressed how reliably it works. There's only a few hiccups when reaching the end of a list. I get a "script error" instead of a proper indication that I reached the end.
Reply
(2014-09-24, 10:02)Tinellus Wrote: I've tried openbox and compiz (as it's the windowmanager I'm using in the gnome sessions) in the script.sh.

As I said, that's not the problem since everything's working fine when directly running chrome launcher (or launching just the script for that matter)

FYI, I have another computer (laptop) with the exact same settings and there it's not happening...(!) I even tried copying the NetfliXBMC default.py and script.sh files from the laptop to the HTPC system... no avail...

Thanks anyway, though

Hi Tinellus,
Did you got your system to work?
I have a similar issue (screen going black with no way to go back to XBMC).
But mine is strange: sometimes I won't have the issue when exiting Chrome and everything will be fine and sometime I will have this black screen. It might happen after closing Chrome twice, like it can happen after 10 times.
I am running XBMC 13.2 in openbox (Ubuntu 14.04) with the script. No issues at all using just chrome launcher.
This has to do with the latest update and switching to a newer version of Chrome and using HTML5. I never had an issue before.
Reply
(2014-10-01, 21:39)mzanetti Wrote: Hi,

thanks for this plugin. Using it for a bit now, but I have two major issues:

* Xbmc blanks the screen while chrome is playing. Is it possible to inhibit the screen saver while the addon is running?

* I tried to map lirc remote keypresses to some keyboard events to control the player window. This seems to work, however xbmc still accepts those keypresses too. Is it possible to change the browser invokation in xbmc to a blocking call, so xbmc wouldn't move around behind the scenes? Maybe that would solve the first issue too.

Other then that, I'm quite impressed how reliably it works. There's only a few hiccups when reaching the end of a list. I get a "script error" instead of a proper indication that I reached the end.

If this is on a linux system you'll have to go to desktop and turn off screen saver and screen blanking. XBMC isn't the cause for it to go black. Also google lightson.sh. Its a script that runs to keep the system from going black when no keypresses are found.
Image
Reply
(2014-10-02, 05:22)Frozin Wrote:
(2014-10-01, 21:39)mzanetti Wrote: Hi,

thanks for this plugin. Using it for a bit now, but I have two major issues:

* Xbmc blanks the screen while chrome is playing. Is it possible to inhibit the screen saver while the addon is running?

* I tried to map lirc remote keypresses to some keyboard events to control the player window. This seems to work, however xbmc still accepts those keypresses too. Is it possible to change the browser invokation in xbmc to a blocking call, so xbmc wouldn't move around behind the scenes? Maybe that would solve the first issue too.

Other then that, I'm quite impressed how reliably it works. There's only a few hiccups when reaching the end of a list. I get a "script error" instead of a proper indication that I reached the end.

If this is on a linux system you'll have to go to desktop and turn off screen saver and screen blanking. XBMC isn't the cause for it to go black. Also google lightson.sh. Its a script that runs to keep the system from going black when no keypresses are found.

Well, there isn't any desktop running, I'm using xbmc standalone on a dedicated media box. It's really xbmc that blanks the screen. I know I could disable that in the xbmc settings, however I really want to use that feature as it'll burn in my plasma tv otherwise if I fall asleep while watching something. It really seems that xbmc launches the browser as a entirely disconnected process and doesn't know anything about it. Continues to process lirc keypresses in the background and blanking the screen/shutting down the pc on inactivity while instead it should be blocking until the browser window closes again.
Reply
When I select a movie or series, the browser (chrome) opens, but before the content starts playing, the browser skips to the ordinary netflix selection page. I have to alt+left my way back to the playback.
Does anyone have an idea what I should do?
Reply
(2014-10-01, 21:39)mzanetti Wrote: * Xbmc blanks the screen while chrome is playing. Is it possible to inhibit the screen saver while the addon is running?

* I tried to map lirc remote keypresses to some keyboard events to control the player window. This seems to work, however xbmc still accepts those keypresses too. Is it possible to change the browser invokation in xbmc to a blocking call, so xbmc wouldn't move around behind the scenes? Maybe that would solve the first issue too.

I've been able to solve those issues with the following hacks in the plugin:

At the beginning of the playVideoMain() function I call
Code:
xbmc.executebuiltin('InhibitIdleShutdown(true)')
xbmc.executebuiltin("LIRC.Stop()")

and at the end I clean that up with:
Code:
xbmc.executebuiltin("LIRC.Start()")
xbmc.executebuiltin('InhibitIdleShutdown(false)')

However, in order to make the method wait for the video to finish, I replaced the osLinux part with this:
Code:
path = "/usr/bin/google-chrome"
        fullUrl = getFullPath(path, url, userAgent)
        chromeProcess = subprocess.Popen(fullUrl, shell=True)

        while chromeProcess.poll() == None:
            try:
                time.sleep(1)
                subprocess.Popen('xdotool mousemove 9999 9999', shell=True)
            except:
                pass

Effectively not using ChromeLauncher to launch it, but calling Popen directly in here and wait for the process to end using poll(). I guess it would be better to still use the ChromeLauncher plugin and get some notification when it's done, but being a noob with xbmc addon development I couldn't find a way to do that.

Moving the xdotool part inside this loop works around the screen blanking issue (besides fixing the issue that the plugin hangs for 15 seconds if you start playback and immediately exit again Smile ). Unfortunately xbmc doesn't seem to offer a builtin method for inhibiting its screen blanking functionality.

Here's the full modified file: http://paste.ubuntu.com/8487872/

Would be cool if some of this would make it into future releases Smile
Reply
I have some trouble with running this Add-On on a Raspberry PI.

Chromium is installed and a Symlink to "google-browser" was created. Also the xdotool is installed.
But when i want to start a movie in the right bottom is a loading symbol is showing without any results.

In my user.log the following errors a reported:
Quote:Oct 5 14:27:47 raspbmc xbmc: Error: Can't open display: (null)
Oct 5 14:27:47 raspbmc xbmc: Failed creating new xdo instance
Oct 5 14:27:47 raspbmc xbmc: [1851:1851:2069877850:ERROR:nss_util.cc(692)] Failed to load NSS libraries.
Oct 5 14:27:47 raspbmc xbmc:
Oct 5 14:27:47 raspbmc xbmc: (chromium:1847): Gtk-WARNING **: cannot open display:
Oct 5 14:27:52 raspbmc xbmc: Error: Can't open display: (null)
Oct 5 14:27:52 raspbmc xbmc: Failed creating new xdo instance
Oct 5 14:27:57 raspbmc xbmc: Error: Can't open display: (null)
Oct 5 14:27:57 raspbmc xbmc: Failed creating new xdo instance

Any suggestions, whats wrong or missing?
Reply
Most likely you don't have an xserver running at all.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
Isn't a xserver running when the Kodi interface is visible?
Reply
Not on the PI - it uses a framebuffer, nothing else.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
(2014-09-25, 16:27)ICEx Wrote:
(2014-09-25, 00:23)AddonScriptorDE Wrote:
(2014-09-24, 22:23)ICEx Wrote: I used to have this working, but had to reinstall windows. Now, I only get a script error when trying to run. Fresh install of Windows 8.1, Gotham 13.2, NetfliXBMC, chrome launcher. Chrome launcher works fine with leanback.

log: http://pastebin.com/2d61HC0P

Any ideas about what could be causing this?

Thanks
Looks like you have problems with ssl. If you are using a proxy, make sure it supports https/ssl.

No proxy, but I'm using DNS servers from Ad-free time! and switching back to google's let NetfliXBMC launch. Now the only issue is that when I close the Netflix window (ctrl-w, alt-f4, numpad 0) XBMC crashes.

this is the full log from starting XBMC to the crash, looks like the last bit of NetfliXBMC is at line 620
http://pastebin.com/m60mcj1p

I had to change two things in order to get this to run with Ad-free time.

edit the default.py

change

content = opener.open(urlMain+"/Login").read()

to

content = opener.open(urlMain+"/").read()

and change

url = "http://api-global.netflix.com/desktop/odp/episodes?languages="+language+"&forceEpisodes=true&routing=redirect&video="+seriesID+"&country="+country

to

url = "http://api-global.netflix.com/desktop/odp/episodes?languages="+language+"&forceEpisodes=true&routing=redirect&video="+seriesID+"&country=US"
Reply
(2014-10-05, 16:28)fritsch Wrote: Not on the PI - it uses a framebuffer, nothing else.
Ok, and what could i do, to get the Add-on running on the raspberry?
Reply
(2014-10-01, 10:03)michael7oliver Wrote:
(2014-09-26, 19:13)michael7oliver Wrote: I'm getting an error saying my password / username is not correct. This is definitely not the case. My log is pasted below, any ideas?

http://xbmclogs.com/show.php?id=303027

Any thoughts on this error?

I'd love to get answer on this. Do I need to provide any further information?
Reply
Been trying to search this thread for answer but its like looking for a needle in the hay.

SETUP: Windows 8.1, latest Chrome, Gotham 13.2, Chrome launcher, NetfliXBMC

Whats not working? When it switches from XBMC to Chrome i dont get fullscreen. Its still looks like a browser. MCE remote is working and if i push BACK it takes me back to XBMC. If i start playing again it opens anoter tab over the first one and playing can not be resumed bacuse to many tabs. What am i doing wrong?
Reply
Looks likes Netflix finally removed Ubuntu User agents checks.

I tried it in 12.04 (Precise) and 14.04 (Trusty) they both work.

All you need to do is update your system to the latest libnss, and the latest Chrome stable. They are in Ubuntu's repositories. No PPA needed. No User Agent needed.

Of course, after confirmation, please remove the User Agent in your ADDon for Linux.
Reply
  •   
  • 1
  • 60
  • 61
  • 62(current)
  • 63
  • 64
  • 86
  •   



Logout Mark Read Team Forum Stats Members Help
[RELEASE] NetfliXBMC - Unofficial Netflix Add-on (Win/OSX/Linux)7
This forum uses Lukasz Tkacz MyBB addons.