• 1(current)
  • 2
  • 3
  • 4
  • 5
  • 14
  •   
  Thread Closed
From Subtitles add-on to subtitles service. The no-trouble How-to.
#1
So, you just installed or upgraded your XBMC installation to the latest nightly and now can’t get the Subtitles downloader to work, right? Don’t worry. You didn't lose your touch. It has simply evolved and the process to get it working has changed slightly.

Sit tight and read this quick how-to to know, well that, “How-to”.

From XBMC 13alpha10 (builds from Dec, 2 2013 and after) the subtitles downloading add-on has been inserted in the core of XBMC as a service. This means that you no longer have to manually install the XBMC Subtitles Add-on.

Instead you have to configure the appropriate options in the Settings menu.

To start, just after installing XBMC, go to System->Video->Subtitles. As you can see there is a new bunch of stuff there.

IMPORTANT: You have to use a pretty up-to-date skin or the new options won’t be implemented yet. To be safe work with confluence until you do this one-time setup.
IMPORTANT 2: In order for the Subtitles options to appear you have to select, at least, Standard Settings Level (the latest option in the left menu, near the bottom). They won’t appear in Basic mode.
Image
Once all that is out of the way this is what you should get:
Image
If you don’t see this options, or not all of them (in one install I was missing the "Default TV/Movie Service" option), then you are using an old build and it won’t work.

The marked part is the subtitles download related stuff. There you must:
  • Select the languages you want to get when searching for subtitles. For the time being there is no way of selecting order (or main language for that matter) so the search results will be shown in whatever order your service of choice (we’ll come to that) decides it fits.[EDIT]Already implemented.
  • Select default Service for TV Episodes and Movies. Here you can also download additional subtitle services:
Image

And that should be it. Some things you should probably know:
  • There is no option for “manual search” in this version. We know you want it but for the time being it is what it is.[EDIT] Already implemented.
  • Each subtitles module might have additional settings (for example you have options to enter your login info in podnapisi). To change this you have to go to each service options through System->Add-ons->Enabled Add-ons->Subtitles and there pick your service and select Configure:
Image
For the time being there are only a bunch of services ported to this new paradigm so you’ll probably have to wait a while for your favorite service to get ported. Please be patient.

Oh, and one more thing. Please, spare us the crying babies parade of service petition. We know everybody has it's own personal favorite service without which they can't live. But my answer there always will be the same: If you want a specific service on, do it yourself or go find someone to do it for you. We don't create services on command.
Always read the XBMC Online Manual,Frequently Asked Questions and search the forum before posting.
For troubleshooting and bug reporting use -> Log file.

#2
good work!!
#3
Should also be wikified and put under gotham FAQ
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
#4
Is there a way to know what addons are submitted? I actually need one specific addon and i don't know if it's there or not and i have no way to check it (now or in the future) without installing the updated version
#5
Not atm (we're still at alpha state). But in the future I'm confident you would be able to check it in the new add-ons section on the XBMC website (http://addons.xbmc.org/category/subtitles/). Right now we're just days ago since these mayor changes were introduced. It will take some time for developers of subtitle services to take notice and update their work.

Anyway, as you should know, alpha versions shouldn't be used for production systems. Just for the adventurous testers willing to suffer even the breaking of full functions.
Always read the XBMC Online Manual,Frequently Asked Questions and search the forum before posting.
For troubleshooting and bug reporting use -> Log file.

#6
hopefully we will get the addic7ed provider back which was unfortunately removed from the old addon Sad
HTPC LibreELEC 8.0 - Xperience1080+
RPi Rev 2 XBian - Arctic Zephyr
#7
(2013-12-13, 11:10)[email protected] Wrote: hopefully we will get the addic7ed provider back which was unfortunately removed from the old addon Sad

Unlikely, it will definitely not go into official repo
#8
@jurrabi, I have two subtitle services (Opensubtitles is one of them) and both show "5.115707e-310 subitle found"

Should the services return the number of subtitle founds or this is somethig that XBMC does?

UPDATE: found na error in translation. Missed %d string

XBMC alpha 11 (Dec-09 build)

Another question. I have a service that used to call XBMC Subtitles whenever the video has no external subtitles. How can I call it now?

def onPlayBackStarted( self ):
if not xbmc.getCondVisibility("VideoPlayer.HasSubtitles"):
print "no subs"
xbmc.executebuiltin('XBMC.RunScript(script.XBMC.subtitles)')


Dont know if is still possible but it would be a nice feature inside XBMC if user choose to always download subtitles.

Thanks and thanks amet for this small script.
Dont know if you still remember of it.
Image
#9
Hello,

I just switched to the latest nightly Build, but one thing is strange with the new subtitles add-on, I configured everything as described but my Remote Shortcut is not working anymore:

Logfile says: DEBUG: OnKey: ctrl-o (0x1f04f) pressed, action is RunScript(script.xbmc.subtitles)

But it does not do anything ...

Is there a new method to call the new add-ons ?

Thanks for some help.
#10
(2013-12-17, 14:26)drcrane Wrote: Hello,

I just switched to the latest nightly Build, but one thing is strange with the new subtitles add-on, I configured everything as described but my Remote Shortcut is not working anymore:

Logfile says: DEBUG: OnKey: ctrl-o (0x1f04f) pressed, action is RunScript(script.xbmc.subtitles)

But it does not do anything ...

Is there a new method to call the new add-ons ?

Thanks for some help.
ActivateWindow(SubtitleSearch)
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
#11
Thanks
Image
#12
I I just updated after some time, to XBMC 13.0 ALPHA12 Git:fb46BB7.
I cannot download any subs anymore, so I went searching the forum to solve this.
However , I found the TV show and Movie service options in the system-->video-->subtitles screen, but I can't choose any services there.
If I select the item I get an empty screen, wit nothing to pick from (on both TV-show and Movie items...)
Any thoughts of what I might be doing wrong here?

Regards
Jerry
#13
did you install the services?
#14
I had thought of that, but I'm not sure which services to install for this ?
I can't seem to find any that are related to subs anywhere Huh

edit :
also If I open the "Default TV service" or "Default Movie service" , the following menu is empty, and when I select "get more..." the next menu is also empty.
#15
Go system them to addons then subtitle addons
Image
  • 1(current)
  • 2
  • 3
  • 4
  • 5
  • 14
  •   
  Thread Closed
 
Thread Rating:
  • 1 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
From Subtitles add-on to subtitles service. The no-trouble How-to.51