Thread Closed
  •  Previous
  • 1
  • 10
  • 11
  • 12
  • 13
  • 14(current)
 
Thread Rating:
  • 1 Vote(s) - 5 Average
From Subtitles add-on to subtitles service. The no-trouble How-to.
Please identify where in that log you search for a subtitle?
If I have helped you or increased your knowledge, click the 'thank user' button to give thanks :) (People with less than 20 posts won't see the "Thank you" button.)
Installed the service OpenSubtitle and adjustment were inserted data for logging their website.After starts of the film click on the button (small screen) and then click on the "subtitles" After that appears Opensubtitle service and the message "Searching subtitle ..." and so is until tomorrow Smile

P. S. Yesterday happened to me a coincidence that the first "Search" found the subtitles (english) because I configured the settings.Now then tried with subtitles by Serbs, Croatia, Bosnia and Herzegovina, but the result was "Searchin subtitle ......" Repeat the back to adjust subtitles "English" and again the same result "Searchin subtitle ......" Sad
And a Debug Log with all that is where?
I hope that my problem here http://pastebin.com/CEGvNbyJ
refers to the number of post #191
Thank you all for your patience !!
Hi everyone,

Like others, I'm having trouble getting subtitles to work since the last big change.
The subtitle features in the previous versions of XBMC were really great, and will be in the future. As for now, it is a pain.

I've read the 1st post, and as many docs as I could find. Nothing works completely.

I'm using xmbc on a raspberry with raspmbc, and on a HTPC, on ubuntu (XBMC 13.2).

As for the subtitle services, I have 3 issues to talk about

1st : Temp dirs don't seem to be created. So all the subtitle services I've tried fail with
Code:
Error Contents: [Errno 2] No such file or directory: '/home/pi/.xbmc/userdata/addon_data/service.subtitles.XXXXX/temp/'
I've commented the recreations of temp dirs, and the scripts can go on.

2nd : Opensubtiles.org (updated today) fails with message :
Code:
16:13:04 T:2667574336   ERROR: GetDirectory - Error getting plugin://service.subtitles.opensubtitles/?action=download&link=http://dl.opensubtitles.org/en/download/subad/src-api/xxxxxxxxxx/5880611/xxxxxxxxx&ID=1954459004&filename=The.Walking.Dead.S05E04.HDTV.x264-KILLERS.srt&format=srt
I can say that I can download the zip file manually from the command-line, with the same user as xbmc. Maybe it expects the file to be a plain srt file. Or is it again a temp dir issue ?

3rd : Super subtitles fails with message :
Code:
15:59:46 T:2667574336   ERROR: OnDownloadComplete - Saving of subtitle /home/pi/.xbmc/userdata/addon_data/service.subtitles.supersubtitles/temp/Once_Upon_a_Time_-_04x06_-_Family_Business.DIMENSION.English.C.orig.Addic7ed.com.srt to special://temp/Once.Upon.a.Time.2011.S04E06.HD.TV-DIMENSION.en.srt failed
NOTICE: special://temp/ is mapped to: /home/pi/.xbmc/temp (wich is obvioulsy read-writable for pi user.)

I hope this will help you to help us.
Hello! I know it's taboo to ask questions and not hail the new subtitle mechanism, but I just wonder, "search by parent folder" will never be implemented again will it?
No, not really... Since the focus is on movies that are already loaded in the library and name/season/episode is already abailable to us.
Hi,
Sorry if this has already been answered (I'm new).
I watch many online streaming contents.
When online services don't find the right subtitles I want to point to a specific fodler and select a specific .srt (even if it has a different filename). With older Subtitles system was easy. With new I wasn't able to do that I even selected a custom folder but It doesn't give me the chance to browse in it.
Any help is appreciated.

Thanks.

Pino.
Hi everyone,

I've installed Kodibuntu this weekend. Everything works fine, except the plug-ins. When I try to search for subtitles, it starts searching but nothing happens... Same issue with YouTube, starts opening stream and nothing happens.
Is there a possibitly that I have to grant a user rigths on a specific location?
debug log (wiki)
If I have helped you or increased your knowledge, click the 'thank user' button to give thanks :) (People with less than 20 posts won't see the "Thank you" button.)
Hi, I,m playing with strm,s built with Hive addon (http://forum.kodi.tv/showthread.php?tid=208702) for building my colection in Kodi.

The addon creates the strm with this structure:

A file called whatever.strm that contents:

plugin://plugin.video.hive/?mode=video&title=VIDEO_TITLE&filename=CODE

So, if I do an scraper, Kodi tries to find movie from name of strm file and does well.

But, once movie is in colection, subtitles addon searches subtitles from VIDEO_TITLE inside strm file instead of searching exactly the movie that has been recognized by scraper.

Is there a way for changing that behaviour?
Might be the wrong spot to post but, when watching a tv show, say season one. If the season. Kicks off with part 1 and 2, usually part one shows both parts in one. Now the problem is, subtitles still follows the number order, basically the subs are now for the show ahead, not current. I hope I explained it right.
(2015-02-18, 11:16)Vestiaz Wrote: ...
So, if I do an scraper, Kodi tries to find movie from name of strm file and does well.

But, once movie is in colection, subtitles addon searches subtitles from VIDEO_TITLE inside strm file instead of searching exactly the movie that has been recognized by scraper.

Is there a way for changing that behaviour?

The problem is with the video plugin. Subtitles download don't use Library data, but video playing data. For normal library files the player fills that with library info.

But when a plugin plays content, it decides how to populate playing data. Yours is giving the video VIDEO_TITLE as name, hence your problems.

There are other video plugins that do a better job and work fine.

So your prayers should be directed to the plugin creator...

PS. Will everybody stop asking question in this Tutorial thread?
Always read the XBMC Online Manual,Frequently Asked Questions and search the forum before posting.
For troubleshooting and bug reporting use -> Log file.

Closed. Use the forum to post your issue.
Always read the XBMC Online Manual,Frequently Asked Questions and search the forum before posting.
For troubleshooting and bug reporting use -> Log file.

  •  Previous
  • 1
  • 10
  • 11
  • 12
  • 13
  • 14(current)
  Thread Closed



From Subtitles add-on to subtitles service. The no-trouble How-to.51