•   
  • 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  • 9
  •   
[Tutorial] Hyperion Ambilight on Linux and OpenELEC x64
#61
git clone --recursive https://github.com/tvdzwan/hyperion.git instead of the git clone https://github.com/tvdzwan/hyperion.git

Tell me how it goes. You might try this:
Build Hyperion on a separate device and move the files over to openelec.

I'll look into this more when I get a chance.
Reply
#62
There it is:
http://bite-in.com/hyperion/Hyperion_OpenELEC_x64.tgz

It is x64 build only. Extract it to /storage/hyperion and run with:
Code:
/storage/hyperion/bin/hyperiond.sh /storage/hyperion/config/hyperion.config.json


To autoran it add:
Code:
/storage/hyperion/bin/hyperiond.sh /storage/hyperion/config/hyperion.config.json </dev/null >/dev/null 2>&1 &

into /storage/.config/autostart.sh

Note:
You need this addon https://github.com/tvdzwan/hyperion/wiki...t-for-RPi)

Update2:
Now there is also a working hyperion-x11 included in the package. Just download again.
Also do not forget to read README file included in the package for command.
Reply
#63
It's running fine on my Chromebox !

thank you sir. Tongue

if i wanna use the x11 file for light in menu, do i still need the boblight x11 or can i use the hyperioin-x11 in the bin folder?!

i tried both and non of them seems to work :/

this is my autostart file
Code:
/storage/hyperion/bin/hyperiond.sh /storage/hyperion/config/hyperion.config.json </dev/null >/dev/null 2>&1 &
DISPLAY=:0.0 /storage/hyperion/bin/hyperion-x11 -f -x > /dev/null 2>&1 &

edit: i tried i with the boblight-x11 from the openelec addon
Reply
#64
Ok now there is a working hyperion-x11 included in the package included in the openelec package.
Reply
#65
(2015-05-16, 14:49)meowmoo Wrote: It's running fine on my Chromebox !

I got hyperion to run on an openelec chromebox with a lightpack, but I think the led configuration is messed up. The first 5 led strips light up and change color, but the other 5 don't (one of the other 5 is stuck with red leds). I changed the default config to 30 leds (since each strip has 3 leds) hoping that'll work, but no...any suggestions?
Reply
#66
Finally figured it out! Had to change it to a 10 led set up.

https://github.com/apollo40/Lightpack.tv...onfig.json
This helped a lot.

Btw, what's the significance of the x-11 file?
Reply
#67
Hello,

thank you for the guide. I compiled and made hyperion on a Ubuntu 14.04.2 x86 virtual machine,
but when I run hyperion with the default configuraiton it exits with the following error:

Code:
[email protected]:/home/ubuntu# /usr/bin/hyperiond /etc/hyperion.config.json
Application build time: May 25 2015 13:01:07
QCoreApplication initialised
Selected configuration file: /etc/hyperion.config.json
ColorTransform 'default' => [0; 49]
Device configuration:
{
        "colorOrder" : "rgb",
        "name" : "MyPi",
        "output" : "/dev/spidev0.0",
        "rate" : 250000,
        "type" : "ws2801"
}

Unable to create device ws2801
Black border threshold set to 0.01 (3)
Not creating any smoothing
Effect directory can not be loaded: /opt/hyperion/effects
Initializing Python interpreter
Segmentation fault (core dumped)

Any idea what is wrong?
Thank you!
Reply
#68
spidev0.0 is only on pi.
Reply
#69
(2015-05-25, 14:25)illiac4 Wrote: spidev0.0 is only on pi.

This was easy, hyperion is now running using the proper configuration. Thank you for your help.
Reply
#70
(2015-05-25, 07:30)cavemandaveman Wrote: Finally figured it out! Had to change it to a 10 led set up.

https://github.com/apollo40/Lightpack.tv...onfig.json
This helped a lot.

Btw, what's the significance of the x-11 file?

with the x-11 file, hyperion also work in the Kodi menu, otherwise it only work if you start a video file.


I try to make a remote key to disable/enable hyperion.

I found this code
Code:
#!/bin/sh
SERVICE='hyperiond'
if ps | grep -v grep | grep $SERVICE > /dev/null
then
killall hyperiond
curl -v -H "Accept: application/json" -H "Content-type: application/json" -X POST -d '{"id":1,"jsonrpc":"2.0","method":"GUI.ShowNotification","params":{"title":"Hyperion","message":"Disabled","image":"/storage/hyperion/hyperion.png"}}' http://youropenelecip:8080/jsonrpc
else
/storage/hyperion/bin/hyperiond.sh /storage/.config/hyperion.config.json </dev/null >/dev/null 2>&1 &
curl -v -H "Accept: application/json" -H "Content-type: application/json" -X POST -d '{"id":1,"jsonrpc":"2.0","method":"GUI.ShowNotification","params":{"title":"Hyperion","message":"Enabled","image":"/storage/hyperion/hyperion.png"}}' http://youropenelecip:8080/jsonrpc
fi

but I cant make it work, any hint to get it woking on Openelec?
Reply
#71
(2015-05-25, 14:50)mind12 Wrote:
(2015-05-25, 14:25)illiac4 Wrote: spidev0.0 is only on pi.

This was easy, hyperion is now running using the proper configuration. Thank you for your help.

If I would like to use X11 for the menu etc, how can I compile and configure it under Ubuntu?
Reply
#72
https://github.com/tvdzwan/hyperion/blob...eLists.txt
Reply
#73
What´s the difference between the normal binary and the x11 one?

Btw. after installing my new arduino yesterday i wasn´t able to get hyperion running on isengard so i figured out that i first had to install kodibuntu 14.0, compile hyperion and upgrade to isengard to get it work. Wink
Reply
#74
x11 can also render menu light the normal one just when video is playing.
Reply
#75
(2015-05-29, 06:54)illiac4 Wrote: x11 can also render menu light the normal one just when video is playing.

can i take the x11 binary from one of the openelec packages for my kodibuntu?
Reply
  •   
  • 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  • 9
  •   



Logout Mark Read Team Forum Stats Members Help
[Tutorial] Hyperion Ambilight on Linux and OpenELEC x641
This forum uses Lukasz Tkacz MyBB addons.