Bug Full automatic scan doesn't work
#1
The actual new problem
Check the first post on page 2

The original post
Is there a way (just as for fanart, images and trailers) to force an overwrite of the data when (re)scraping the whole movies? The reason I ask is quite simple: I scraped all my movies with IMDB in english, but now I'd like to rescrape it with TMDB with german plot and info, but it doesn't rescrape the whole stuff. How can I do that?
Reply
#2
You can use the custom scraper (Medien Scrapen -> Benutzerdefinierter Scraper).
Reply
#3
Tried it but this doesn't overwrite content and data that is already there, or do I miss something?
Reply
#4
Nobody any ideas?
Reply
#5
(2013-12-25, 13:37)Tormentor667 Wrote: Nobody any ideas?
Make sure:
1. That you did not lock any fields you want to scrape in Settings
2. That you enabled scraping of fielfs i.e. plot field in global scraper settings:
Image

3. Now enable TMDB DATA Scraper, put APIKEY in scraper settings, change language to german and enable scraping of fields.Also make sure that TMDB scraper is placed after IMDB Scraper:
Image
Now Ember will scrape the german plot from TMBDB and overwrite exisiting plot. Hope this helps!
Reply
#6
Thanks for the help, this is what my settings look like:
[img=http://abload.de/thumb/2013-12-25_202705w6crx.png]
[img=http://abload.de/thumb/2013-12-25_202730pxca9.png]
...though it isn't perfectly working. It works for new movies but not for old ones, they stay english.

I have Ember 1.4.0.0 if that helps.

EDIT
When I manually rescrape them it works and I get a german description, though right-clicking and rescraping 2500 movies sounds like a terrible job to me Sad
Reply
#7
(2013-12-25, 21:29)Tormentor667 Wrote: Thanks for the help, this is what my settings look like:
[img=http://abload.de/thumb/2013-12-25_202705w6crx.png]
[img=http://abload.de/thumb/2013-12-25_202730pxca9.png]
...though it isn't perfectly working. It works for new movies but not for old ones, they stay english.

I have Ember 1.4.0.0 if that helps.

EDIT
When I manually rescrape them it works and I get a german description, though right-clicking and rescraping 2500 movies sounds like a terrible job to me Sad

I just noticed that 1.4 doesn't work correct with my movie.nfo scheme, it works fine with FRODO settings. Can you check that setting.
I guess you're using automatic scraping ? All Movies -> Automatic -> only NFO?
Reply
#8
I am using FRODO settings and actually with "All Movies > Automatic > All", just as in the following screenshot
[img=http://abload.de/thumb/2013-12-26_141125iounc.png]

But as stated, it doesn't work.

*EDIT*
I also noticed that Ember actually doesn't touch any of the movies when scraping all, in case they already have NFO, Poster and Fanart. The whole list of movie titles runs through at the bottom status bar in about 15 seconds with doing any scraping.
Reply
#9
(2013-12-26, 15:12)Tormentor667 Wrote: I am using FRODO settings and actually with "All Movies > Automatic > All", just as in the following screenshot
[img=http://abload.de/thumb/2013-12-26_141125iounc.png]

But as stated, it doesn't work.

*EDIT*
I also noticed that Ember actually doesn't touch any of the movies when scraping all, in case they already have NFO, Poster and Fanart. The whole list of movie titles runs through at the bottom status bar in about 15 seconds with doing any scraping.

How are you Nfo-files named? Also can you upload/send your advancedsettings.xml and settings.xml so I can take a look?
Reply
#10
The NFO files are named moviename.nfo (e.g. Ben Hur.nfo if the movie-file is named Ben Hur.avi)

Concerning the advancedsettings.xml and the settings.xml, are you sure you need those? I am not doing any scraping via XBMC, only via Ember.
Reply
#11
Okay, after playing around for some more time I noticed that Ember seems to have a problem with the automatic scraping in general. I have abozt 2500+ movies in my list and when I do the automatic scraping, this is what happens:
  • Works fine for the first 50 - 100 entries (random)
  • Stops working without an error message
  • When restarting the scraping, it runs through the whole list (status bar displays the titles) in about 30 seconds but without doing any work
  • Restarting Ember makes it work again (for yet another 50-100 entries, but from the beginning)
My workaround was that I mark my whole list and doing the job several times, unmarking what has been scraped and continueing. But that was a tedious job actually (had to do it about 40-50 times). I have no idea if that's a problem with the scraper, the source or the list itself.
Reply
#12
(2013-12-29, 13:58)Tormentor667 Wrote: Okay, after playing around for some more time I noticed that Ember seems to have a problem with the automatic scraping in general. I have abozt 2500+ movies in my list and when I do the automatic scraping, this is what happens:
  • Works fine for the first 50 - 100 entries (random)
  • Stops working without an error message
  • When restarting the scraping, it runs through the whole list (status bar displays the titles) in about 30 seconds but without doing any work
  • Restarting Ember makes it work again (for yet another 50-100 entries, but from the beginning)
My workaround was that I mark my whole list and doing the job several times, unmarking what has been scraped and continueing. But that was a tedious job actually (had to do it about 40-50 times). I have no idea if that's a problem with the scraper, the source or the list itself.

Are you using ODFB Scraper? Sounds to me that at a certain amount of scraped movies one of the scrapers returns nothing to Ember, and with OFDB you have a limit of 80 movies per hour before you can use that scraper again (IP is blocked)
Reply
#13
I am using TMDB Scraper with my own API key, does it have a similar restriction? If yes, can Ember be adjusted to just delay more between each movie?

I doubt that this is the reason, as when I restart Ember, I can continue with scraping the regular way though.
Reply
#14
Sorry for the push, but I still haven't found a solution.
Reply
#15
(2014-01-03, 10:35)Tormentor667 Wrote: Sorry for the push, but I still haven't found a solution.

Sorry for late reply - so the problem are not movies that cannot be scraped (because after restart you can scrape them) - can you send/upload the EmberLogs so I can take a look - really sounds weird Smile
Reply



Logout Mark Read Team Forum Stats Members Help
Full automatic scan doesn't work0
This forum uses Lukasz Tkacz MyBB addons.