Solved xbmcbuntu-12.2.Intel-AMD.iso checksum mismatch
#1
I've been trying to download XBMCbuntu to try it out, but the file I keep downloading doesn't match the checksum posted on the website.

For XBMCBuntu 12.2 Intel-AMD, the checksums posted on the website are:

SHA-1 Hash: d b36eae0b4ae2e778e62d6a4cf667b02711df361
MD5 Hash: f683b54c9bc6e4b41c3ef55b122bc23a

However, the file I consistently download is:

SHA-1 Hash: 7A54AC675C585A333093DCD85E06B39C415CCE16
MD5 Hash: 72399FBF77DA2DCE95DEFD5F6B1AD986

I've tried the main download link and a mirror, each multiple times, but the checksum never matches. What's going on?

I had to put a space in the sha-1 so the forum wouldn't try to turn it into a github link.
Reply
#2
I am currently investigating this, thanks for bringing it up.

steps taken in the investigation so far:

1) manual MD5sum at server console:
f683b54c9bc6e4b41c3ef55b122bc23a xbmcbuntu-12.2.Intel-AMD.iso
conclusion: the manual md5sum comes up with the same as the MD5 mirrorbrain calculates and reports - eg mirrorbrain calculates the MD5 correctly.

2) File downloaded from one of the mirrors:
This is different, has a checksum of 72399fbf77da2dce95defd5f6b1ad986

3) Filesizes:
Identical, 709885952 bytes

4) Rsync between main server and mirror sees no difference.
Reply
#3
Just a heads up, you can't actually download it from the main server while there are valid mirrors available - that is by design.

5) downloading the xbmcbuntu-12.2.Intel-AMD.iso from one of the mirrrors to a temp dir on the main mirror to do a comparison between the two files.
Reply
#4
EDIT: disregard this, see two posts down.

Ok. I figured out what went wrong.

During the initial (hastily) sync to the new server the timestamps were not copied. These are taken into account when doing md5sum.
It appears some of our mirrors skip timestamp checks (not a good thing) and haven't synced these 'changed' files.

I am now trying to figure out a way to set the old files back to their old timestamps without touching the newer files and without copying over old (and now 'missing' data) from our old server.
If anyone has a great idea, let me know Smile
Reply
#5
EDIT: although nice to have, disregard this - see one post down.

Using some smart rsync switching i managed to copy the timestamps for existing files only from old server to new server.
Running forced hash updating on the server. It should get the same hash you got when downloading. (In an hour or so)
Reply
#6
I have just positively found a binary difference (3 bytes) between the correct file hosted on our servers and the file located on some of our mirrors.
Reply
#7
Thanks! Now the md5 matches. f683b54c9bc6e4b41c3ef55b122bc23a
Reply
#8
with your mirror, but not with the other half - unless all mirrors now sync up we still have an issue.
Reply
#9
Ok, so I downloaded it and got an MD5sum of f683b54c9bc6e4b41c3ef55b122bc23a. Which is supposedly the correct file. However, turns out that f683b54c9bc6e4b41c3ef55b122bc23a is the corrupt one and 72399fbf77da2dce95defd5f6b1ad986 is the functioning one. I get squashfs errors all over on f683b54c9bc6e4b41c3ef55b122bc23a but 72399fbf77da2dce95defd5f6b1ad986 (I found an old torrent) installs just fine.

Sorry, looking back on this post it seems very confusing, basically the file now going to all the mirrors is actually corrupt, the one thought to be corrupt was the correct one.
Reply
#10
Hi


The install crashes and it is not the cd media, I have tried to install in a virtual image from the ISO and it still crashes
I have only been able to download For XBMCBuntu 12.2 Intel-AMD,iso and the md5sum is f683b54c9bc6e4b41c3ef55b122bc23a for all the images that I have downloaded, where can I find and image that works?

Where can I find an image with the following md5sum 72399FBF77DA2DCE95DEFD5F6B1AD986, that works according to the reply?

Thanks
Reply
#11
Great. It seems I spend ages making sure all mirrors have a corrupt version because of a wrong report on which MD5 was working.

Expect it fixed within a few days - I still have the other one and need to make sure it gets pushed to all mirrors. This time however I am going to make sure it actually works by installing it in a VM first.
Please have a little patience Smile
Reply
#12
POST DELETED AS Kib HAD ISSUES WITH IT, DIRECT ANY COMPLAINTS TO Kib
Reply
#13
I have removed the corrupt file from the mirrors.
I'll put the correct and verified working file back, with a slightly different name. That way you will always get the correct one and the downstream mirrors will be forced to redownload.
Reply
#14
md5sum xbmcbuntu-12.2.Intel-AMD.2.iso
72399fbf77da2dce95defd5f6b1ad986

You can check the mirrorlist for this file to see whether it has been mirrorered already. This will take approximately one day.
Reply
#15
Fair enough to "Kib" for his views.

In future I shall not bother to inform the project of any findings and keep the information to myself.

Please do not edit my posts, if you wish any kind of contribution from me in the future.

FYI I am a long time supporter of Linux and kernel developer (check sources for my credits from work done over 18 years ago in kernel) as well as package maintainer of a number of OSS packages, I welcome the kind of information I provided to any of my projects, IMHO feedback is vital from the userbase.

I shall now delete/remove my previous post completely.

If you want to edit my post, I'm just going to delete it, because it not longer represents my views but those of my censor!
Reply
 
Thread Rating:
  • 1 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
xbmcbuntu-12.2.Intel-AMD.iso checksum mismatch51