•   
  • 1
  • 5
  • 6
  • 7
  • 8(current)
  • 9
  •   
AMLogic hardware video decoding in nightly builds
(2014-03-16, 22:10)davilla Wrote: Nothing is wrong with XBMC, it runs the GUI in 720p. Always has and always will until GLES improves enough to get decent fps from the GUI. Video is rendered my hw to a different video plane that has nothing to do with GLES.

This is just for AML, right? I'll add it to the Android FAQ (wiki) if so. Does the firmware/Android resolution have any impact in it?

For example, if someone has an AMLogic box where the Android FW is set to 1080, does/should XBMC still render the GUI for aml hardware at 720? Or the reverse, if the Android FW/XBMC GUI is set to 720, connected display is in 1080, video will be in 1080?
Reply
i might as well chuck my box in the bin then.. the people that make my box are usless with updates and support etc
"People don't care how much you know until they know how much you care”
Reply
(2014-03-17, 00:34)epicdsl Wrote: i might as well chuck my box in the bin then.. the people that make my box are usless with updates and support etc

Check out sites like freaktab.com and such. I'm learning a lot of this for the first time myself, and I've found that the community driven Android sites are often much more awesome for firmware updates than the official companies.
Reply
(2014-01-11, 08:45)VictorDUA Wrote: No. If amlogic enable I don't have picture at all only sound. Player do not switch to full screen and when I try to play movie it's played background and only sound. If I manually switch full screen I have black screen and sound. When I turn amlogic off - everything fine except HW.

Hi
I have same problem did u fix it if yes can u explain me how you fix it.
Thanks
Reply
(2014-03-17, 03:27)Ned Scott Wrote:
(2014-03-17, 00:34)epicdsl Wrote: i might as well chuck my box in the bin then.. the people that make my box are usless with updates and support etc

Check out sites like freaktab.com and such. I'm learning a lot of this for the first time myself, and I've found that the community driven Android sites are often much more awesome for firmware updates than the official companies.

thanks mate i ended up finding one on that site for my box and it has fixed the issue... well kind of when i press 0 it stills showing skipped frames etc and the video is out of sync just enough to annoy me but no way near as bad as on that other firmware.. i shall just be patient and wait to see as gotham is improved hopefuly 1080p playback will be as well Big Grin
"People don't care how much you know until they know how much you care”
Reply
(2014-03-17, 09:44)epicdsl Wrote:
(2014-03-17, 03:27)Ned Scott Wrote:
(2014-03-17, 00:34)epicdsl Wrote: i might as well chuck my box in the bin then.. the people that make my box are usless with updates and support etc

Check out sites like freaktab.com and such. I'm learning a lot of this for the first time myself, and I've found that the community driven Android sites are often much more awesome for firmware updates than the official companies.

thanks mate i ended up finding one on that site for my box and it has fixed the issue... well kind of when i press 0 it stills showing skipped frames etc and the video is out of sync just enough to annoy me but no way near as bad as on that other firmware.. i shall just be patient and wait to see as gotham is improved hopefuly 1080p playback will be as well Big Grin

Which box/firmware worked for you? I've got an ATV520E and I'm running some unreleased 1080 firmware from Geniatech. I got the link to it from either here or on another forum.

Any way I seem to have the same issue AC3 and AAC files drop the fps down around 13 and the audio plays but is not in sync. It's strange cause I can play ac3 files from the internal player just fine.

Which firmware are you running now? I might give it a try.
Reply
My box is a blue times mx5 and the custom firmware is Dharmageddon3 ..there is a link for it on that freaktab site. They have some on there for your model I believe hope that helps

after i rebooted my box the issue went away it seems to be alot in sync now .. still some dropped frames but not as many if you pause it then try play the movie again its out of sync but u just stop the movie and play again and it goes back to in sync so far so good... xbmc for lyfe yo Laugh
"People don't care how much you know until they know how much you care”
Reply
The 13 beta 2 works great on the AMLogic box, thanks guys for the excellent work. However, the following issues are noticed:

1. DVD menu in some of the DVD iso doesn't work (about half of my collection) - When I play the files, after the intro, it shows a black screen with background music, I can still select the menu items and play the video. Is it something that can be fixed in the future? iOS/Mac version (12.3) have no such problem at all. Playing iso files is a major advantage of XBMC over plex. Hope XBMC continue to support this important feature.

2. When I play Bluray iso, there are some audio sync issue. 1080p TS file has no such problem.

3. Still can't change the resolution to 1080p (only 720p is select), although the android setting is already selected to 1080p.

I am using MyGica V520E, I believe the chipset is Amlogic MX
Reply
(2014-03-18, 14:14)bigpen23 Wrote: The 13 beta 2 works great on the AMLogic box, thanks guys for the excellent work. However, the following issues are noticed:

1. DVD menu in some of the DVD iso doesn't work (about half of my collection) - When I play the files, after the intro, it shows a black screen with background music, I can still select the menu items and play the video. Is it something that can be fixed in the future? iOS/Mac version (12.3) have no such problem at all. Playing iso files is a major advantage of XBMC over plex. Hope XBMC continue to support this important feature.

2. When I play Bluray iso, there are some audio sync issue. 1080p TS file has no such problem.

3. Still can't change the resolution to 1080p (only 720p is select), although the android setting is already selected to 1080p.

I am using MyGica V520E, I believe the chipset is Amlogic MX


Both those issues are addressed earlier on this page

The xbmc interface runs at 720p but if have a keyboard plugged into your box hit o and it will show you 1920x1080 if you are watching a 1080p video

The DVD menu is a known bug

Hope that helps
"People don't care how much you know until they know how much you care”
Reply
Thanks a lot, hope it will be fixed soon.
Reply
Originally I thought I was just having problems with AC3 and AAC. The video plays fine with the internal player (com.farcore....) but with xbmc I get around 13 fps the audio seems to play fine.


I'm trying to play this dts file from here:
http://www.auby.no/files/video_tests/h26...nsters.mkv

Posted Logs here:
http://xbmclogs.com/show.php?id=153448

Running this firmware:
http://www.geniatech.com/down-eng/androi..._1080p.zip
Reply
will this support the tronsmart vega s89?
Reply
sorry,why this version with hardware video decoding feature need root?
i can not play the video with full screen by this version,may be because my TV box is not rooted?
Reply
The devices don't need to be rooted as per say.. But the people who make your box who created your ROM need to have given correct permissions to certain files.. Those files are listed earlier in the thread.. Having a rooted device is goo because you can fix the permissions to those files your self.. If your device is having playback issues .. ask the maker of your box for rooted ROM.. If not find custom firmware on the net that is rooted for your device hope this helps mate
"People don't care how much you know until they know how much you care”
Reply
(2014-05-02, 16:32)epicdsl Wrote: The devices don't need to be rooted as per say.. But the people who make your box who created your ROM need to have given correct permissions to certain files.. Those files are listed earlier in the thread.. Having a rooted device is goo because you can fix the permissions to those files your self.. If your device is having playback issues .. ask the maker of your box for rooted ROM.. If not find custom firmware on the net that is rooted for your device hope this helps mate

when i use xbmc 12 formal release ,can play with full screen,but version 12 do not support hardware decodingSad
can someone tell me if xbmc 13 formal release can play in full screen without root?
Reply
  •   
  • 1
  • 5
  • 6
  • 7
  • 8(current)
  • 9
  •   



Logout Mark Read Team Forum Stats Members Help
AMLogic hardware video decoding in nightly builds1
This forum uses Lukasz Tkacz MyBB addons.