•   
  • 1
  • 2
  • 3(current)
  • 4
  • 5
  • 11
  •   
Release Video Explorer 3.0.0.61: Critical Bug Fixes
#31
@millercentral:

No, no plans for that.

That would be moving away from the focus of the application, which is to manage the media itself, at source.

Any manipulation of the XBMC database itself, directly, would be completely out of scope for this application and I also don't believe that it's a good idea for anything to modify the XBMC database other than XBMC itself.

What I might do, however, is make the NFO file editing capabilities that I currently have far more powerful and make it possible to manipulate other parts of the NFO file.

There again though, I didn't do that to begin with because most of the information you need in the NFO files is automatically downloaded from the online databases exactly as you need it anyway.

I've allowed for editing of Genres and Movie Sets because those are the 2 things that I fould that I constantly wanted to customize myself.

I'm not sure what you would be wanting to directly manipulate in the XBMC MySQL database ?

In my opinion, you should update your NFO files at source and then refresh your movies from the NFO files in order to update the XBMC database.

I do admit, however, that XBMC doesn't currently allow for easy re-scanning of media in place and that only being able to refresh a single movie at a time is also tedious, so there is some work that needs to be done to XBMC itself to improve that too, but I do believe that should be corrected in XBMC, and not be worked around in a 3rd party app.

Hopefully XBMC v13 is going to introduce some improvements to re-scanning of media in place and batch refreshing of movies.
Reply
#32
v2.1.4.0 - Released 22/01/2014
-------------------------------------------

1. The Remux form will now allow you to tick "Delete original file on success" if the source file is NOT an MKV.

2. Some small bug fixes and improvements related to the remux logic and refreshing of movie information.

3. You can now use the "Rename 3D movie" feature on any movie that is loaded irrespective of whether VideoExplorer already recognises the movie as a 3D movie or not.

4. Both the "Reload Metadata" and "Refresh Poster Thumbnail" features now have proper error handling and logging wrapped around them in case something goes wrong.
Reply
#33
Thanks for sharing the application.
Reply
#34
v2.1.5.0 Released- 22/01/2014
------------------------------------------

1. Enhanced the Remux form so that if you remux a non MKV file to MKV, and tick the "Delete original file on success" tickbox, and VideoExplorer fails to delete the original file after the remux completes for some reason, it will now be handled correctly and when you return to the main grid, the main grid will refresh and show the new remuxed file automatically and not the old file, despite the delete having failed.

If the delete fails, you will end up with 2 files in the folder, the original and the remuxed file.


2. Fixed some nasty bugs related to files that have no metadata (nfo files) and therefore load without any associated Genres.

In this case you end up with an empty Genre list on the right, but the Filter buttons for Genres were still active and if you filtered on an empty list you could end up with an empty main grid but rows still existing in memory, and that would lead to exception errors being thrown if you then started to click any of the tabs in the metadata area to view Artwork or Genres and Movie Sets.

None of that should now be possible anymore, buttons should now disable if now Genres are found, and the UI should clear and reset properly now, in a safe way without any orphaned row or object references being left in memory.


3. Audio Channel Count fix : The MediaInfo parsing library has been updated to now also consider "Original Channel Count" when determining how many channels an audio stream has.

Both Containers and Audio Streams return channel counts and if those values differ then MediaInfo returns both values and it is advisable to use the value reported by the Audio Stream itself and override the value reported by the Container.

Up until now VideoExplorer has always only reported the value returned by the Container but after consulting with the MediaInfo developers I have changed it to also consider the value retrieved from the Audio Stream itself, if that value is returned by MediaInfo.
Reply
#35
NOTE RE: Object Caching

VideoExplorer uses what I refer to as object caching to drastically speed things up and make movie loading ridiculously fast after they'e been loaded at least once without caching (to be cached).

The caching is a simple concept. When I load a movie the normal way, not from cache, it takes time because I have let MediaInfo interrogate the movie and then I have to unpack the resutls of that interrogation into a whole hierarchy of objects in memory, which are then in turn bound to the various grids in VideoExplorer.

Obviously, if you can get away with doing all that only once, and from then on just keep reloading that same object hierarchy from somewhere directly, without MediaInfo getting involved again, things will be a LOT faster.

In an application like VideoExplorer you can get away with that because most of the time users will be re-loading movies they've already loaded before, a lot, because people will tend to load entire folders full of movies at a time, that aren't really changing very often.

I take advantage of that fact and I serialise the object hierarchy that contains all the information returned by MediaInfo to disk so that the next time that same movie is loaded again I can just deserialise that info straight from disk and NOT do a full MediaInfo parse on that movie file again.

The speed improvement from doing that is dramatic.

THE PROBLEM is that you need to be aware that this is going on because IF something does change about a given movie, then obviously any cached data about that movie will NOT be valid any longer.

If you remux a movie or remove header stripping from movies from within VideoExplorer that will trigger an automatic update of the cache for the relevant movies so that any changes made to the movie as a result of the remuxing will automatically be persisted to the cache.

In addition to that, VideoExplorer caters for you relocating movies and moving them around on your disks. If it has a movie cached and you relocate that movie, it will STILL use the correct cached object when you load that movie from it's new location AND VideoExplorer will automatically update the cached object to reflect the new location immediately. In other words, it automatically updates and repairs the cache for you, to a certain extent.

And in addition to that. sometimes when I release a new version of Video Explorer I do something that alters the way a particular value that appears in a particular column on one of the grids is calculated or derived internally, or I add a new column altogether, and that can also make any cached data become at least partially invalid.

To work around those problems there are several things I've done:

1. I give you the tick box labelled "Use Info Cache" (top right under the Search Filter) to allow you to very easily force VideoExplorer to ignore the cache and do a full re-load and full MediaInfo interrogation on all Movies that you load.

2. When I release a new version of VideoExplorer and I know that I've done something that is going to invalidate some of the information in the cache, I flip a special switch on my side that forces VideoExplorer to clear your object cache completely ONCE ONLY after the new version runs for the first time. It will ONLY do that once and then the flag resets to off.

That will happen without you knowing or being prompted and I make that decision.

3. I have added an option to the right-click menu of the main grid to allow you to "Clear Object Cache" whenever you like. That will instantly delete every single cache object for you and ensure that ANYTHING you load form that point on will be parsed by MediaInfo again and re-cached.

IN SUMMARY

If you are seeing any weird values on the grids, or suddenly a particular column on one of the grids has no values in it after an update, or anything similar, always clear the object cache (or untick the "Use Info Cache" tickbox) and reload your movies and see if that resolves the issues.

I try my best to make things backward compatible and to make upgrades seamless, but it's hard to always get it perfectly right for everybody.

If, after clearing your cache and reloading, you are still having issues, then please post your issues here so that I can look into it for you and fix it.
Reply
#36
v2.1.6.1 Released - 26/01/2014
-------------------------------------------

1. Fixed bug related to clearing the grid: If you cleared the grid and then clicked on the Artwork or Metadata tabs you would get an exception error because the grid still had it's ActiveElement set, but there were no longer any rows on the grid.

2. Improved the intial row selection after a fresh movie load. The first visible row will now be selected automatically, regardless of any grouping and sorting applied.

3. Added an extra check when clicking the Filter button in the Genre Filter area. If no Genres are ticked on the Genre list VideoExplorer won't even bother to filter anymore, it will tell you to tick at least one Genre first.

4. Some small code optimisations and code cleanup in various places.

5. The "Refresh" button is now labelled "Search" to be consistent with the "Search Filter" terminology used on the right for the File Extension filter list that directly affects the results returned when you click that button.

6. The Filter and Clear Filter buttons under the Genre List have been renamed to clearly indicate that they only affect Genres.

7. After Remuxing a movie, or Removing Header Stripping from movies, the object cache will automatically be updated for those movies now.

8. After Remuxing a movie, or Removing Header Stripping from movies, metadata will immediately be reloaded and reflect on any visible and relevant grids immediately now.
Reply
#37
I'm always getting a error with the download from google drive on my server with Win Server 2008 R2.
It seems to be working on my Win 8.1 machine. Both connected to the internet and on the same network.
The setup stops with following error message:
Image
and here's the log:
Code:
The following properties have been set:
Property: [AdminUser] = true {boolean}
Property: [InstallMode] = HomeSite {string}
Property: [NTProductType] = 3 {int}
Property: [ProcessorArchitecture] = AMD64 {string}
Property: [VersionNT] = 6.1.1 {version}
Running checks for package 'Windows Installer 4.5', phase BuildList
Looking up path for special folder 'WindowsFolder'
Running check with folder 'C:\Windows\System32' and file 'msi.dll'
Attempting to find file 'C:\Windows\System32\msi.dll'
File version is '5.0.7601.17807'
Setting value '5.0.7601.17807 {version}' for property 'VersionMsiDll'
The following properties have been set for package 'Windows Installer 4.5':
Property: [VersionMsiDll] = 5.0.7601.17807 {version}
Running checks for command 'WindowsInstaller4_5\WindowsXP-KB942288-v3-x86.exe'
Result of running operator 'VersionGreaterThanOrEqualTo' on property 'VersionMsi' and value '4.5': true
Result of checks for command 'WindowsInstaller4_5\WindowsXP-KB942288-v3-x86.exe' is 'Bypass'
Running checks for command 'WindowsInstaller4_5\WindowsXP-KB958655-v2-x86-ENU.exe'
Result of running operator 'VersionGreaterThanOrEqualTo' on property 'VersionMsiDll' and value '4.5.6001.22299': true
Result of checks for command 'WindowsInstaller4_5\WindowsXP-KB958655-v2-x86-ENU.exe' is 'Bypass'
Running checks for command 'WindowsInstaller4_5\WindowsServer2003-KB942288-v4-x86.exe'
Result of running operator 'VersionGreaterThanOrEqualTo' on property 'VersionMsi' and value '4.5': true
Result of checks for command 'WindowsInstaller4_5\WindowsServer2003-KB942288-v4-x86.exe' is 'Bypass'
Running checks for command 'WindowsInstaller4_5\WindowsServer2003-KB958655-v2-x86-ENU.exe'
Result of running operator 'VersionGreaterThanOrEqualTo' on property 'VersionMsiDll' and value '4.5.6001.22299': true
Result of checks for command 'WindowsInstaller4_5\WindowsServer2003-KB958655-v2-x86-ENU.exe' is 'Bypass'
Running checks for command 'WindowsInstaller4_5\WindowsServer2003-KB942288-v4-x64.exe'
Result of running operator 'VersionGreaterThanOrEqualTo' on property 'VersionMsi' and value '4.5': true
Result of checks for command 'WindowsInstaller4_5\WindowsServer2003-KB942288-v4-x64.exe' is 'Bypass'
Running checks for command 'WindowsInstaller4_5\WindowsServer2003.WindowsXP-KB958655-v2-x64-ENU.exe'
Result of running operator 'VersionGreaterThanOrEqualTo' on property 'VersionMsiDll' and value '4.5.6001.22299': true
Result of checks for command 'WindowsInstaller4_5\WindowsServer2003.WindowsXP-KB958655-v2-x64-ENU.exe' is 'Bypass'
Running checks for command 'WindowsInstaller4_5\Windows6.0-KB958655-v2-x86.MSU'
Result of running operator 'VersionGreaterThanOrEqualTo' on property 'VersionMsiDll' and value '4.5.6001.22308': true
Result of checks for command 'WindowsInstaller4_5\Windows6.0-KB958655-v2-x86.MSU' is 'Bypass'
Running checks for command 'WindowsInstaller4_5\Windows6.0-KB958655-v2-x64.MSU'
Result of running operator 'VersionGreaterThanOrEqualTo' on property 'VersionMsiDll' and value '4.5.6001.22308': true
Result of checks for command 'WindowsInstaller4_5\Windows6.0-KB958655-v2-x64.MSU' is 'Bypass'
'Windows Installer 4.5' RunCheck result: No Install Needed
Running checks for package 'Microsoft .NET Framework 4 (x86 and x64) and Update for .NET Framework 4 (KB2468871)', phase BuildList
Reading value 'Version' of registry key 'HKLM\Software\Microsoft\NET Framework Setup\NDP\v4\Full'
Read string value '4.5.50938'
Setting value '4.5.50938 {string}' for property 'DotNet40Full_TargetVersion'
Reading value 'ThisVersionInstalled' of registry key 'HKLM\Software\Microsoft\Updates\Microsoft .NET Framework 4 Extended\KB2468871'
Read string value 'Y'
Setting value 'Y {string}' for property 'KB2468871Full_Installed'
The following properties have been set for package 'Microsoft .NET Framework 4 (x86 and x64) and Update for .NET Framework 4 (KB2468871)':
Property: [DotNet40Full_TargetVersion] = 4.5.50938 {string}
Property: [KB2468871Full_Installed] = Y {string}
Running checks for command 'DotNetFX40KB2468871\dotNetFx40_Full_x86_x64.exe'
Result of running operator 'ValueEqualTo' on property 'InstallMode' and value 'HomeSite': true
Result of checks for command 'DotNetFX40KB2468871\dotNetFx40_Full_x86_x64.exe' is 'Bypass'
Running checks for command 'DotNetFX40KB2468871\dotNetFx40_Full_setup.exe'
Result of running operator 'ValueNotEqualTo' on property 'InstallMode' and value 'HomeSite': false
Result of running operator 'VersionGreaterThanOrEqualTo' on property 'DotNet40Full_TargetVersion' and value '4.0.30129': true
Result of checks for command 'DotNetFX40KB2468871\dotNetFx40_Full_setup.exe' is 'Bypass'
Running checks for command 'DotNetFX40KB2468871\NDP40-KB2468871-v2-x86.exe'
Result of running operator 'ValueNotEqualTo' on property 'ProcessorArchitecture' and value 'Intel': true
Result of checks for command 'DotNetFX40KB2468871\NDP40-KB2468871-v2-x86.exe' is 'Bypass'
Running checks for command 'DotNetFX40KB2468871\NDP40-KB2468871-v2-x64.exe'
Result of running operator 'ValueNotEqualTo' on property 'ProcessorArchitecture' and value 'amd64': false
Result of running operator 'ValueEqualTo' on property 'KB2468871Full_Installed' and value 'Y': true
Result of checks for command 'DotNetFX40KB2468871\NDP40-KB2468871-v2-x64.exe' is 'Bypass'
'Microsoft .NET Framework 4 (x86 and x64) and Update for .NET Framework 4 (KB2468871)' RunCheck result: No Install Needed
Launching Application.
URLDownloadToCacheFile failed with HRESULT '-2146697208'
Error: An error occurred trying to download 'https://googledrive.com/host/0B9N9faZA-SrxMC1MQnhHSGNxdnM/VideoExplorer.application'.
Any idea?
Reply
#38
@MasterPhW:

It's hard to say just from the log, but it does seem to be clearly indicating that it's having a problem downloading the required files, which would seem to imply that the problem is that your server is somehow blocking the download.

Firewall settings maybe ?

None of that originates from any of my custom code, that is all being generated by the Microsoft 1-Click Installer code.

Nobody else has reported anything similar and that error being logged is very explicitly reporting a download failure and a failure to retrieve the required files.

Could it be that your Server is blocking HTTPS for some reason ?
Reply
#39
@MasterPhW:

Some info on that error here:

http://social.msdn.microsoft.com/Forums/...formssetup

Possible solution here:

http://community.office365.com/en-us/for...50924.aspx

"you should check to clear the option "Warn if changing between secure and not secure mode" from your Internet Explorer(IE) Tools--Internet Options--- Advanced--Security.

If the setup URL of the ClickOnce application being installed is redirected from a non-secure to a secure site (or vice-versa), the installation would fail due to the Internet Explorer warning. Therefore, please make sure to remove the redirection completely and point to the actual setup URL."
Reply
#40
I've unchecked the "Warn if changing between secure and not secure mode" setting and also tried with disabled firewall, but none of them fixed it sadly.
But when I installed it on my Win 8.1 machine and just moved it over to the Server 2008 R2 one, it started without problems.

So if there are more users out there, which aren't able to get it downloaded, it would be great, if you could also add a zip package with the needed files.
Mark it as "for the advanced users", because they would need to check the requirements them self, but they could run it. Wink
Reply
#41
The problem with a zip package is that i constantly have to manually update the zip and then users have to manually update their installations.

The 1-click installer auto updates.

The problem you are having is specific to Windows Server it would seem. I need to get to the bottom of what is causing the problem at some point.

Im also looking at switching to a different installer, so that would solve the problem I suspect.
Reply
#42
@MasterPhw:

Just did some more reading on the server problem. The issue is definitely server config.

http://robindotnet.wordpress.com/2010/06...eployment/

http://msdn.microsoft.com/en-us/library/ms228998.aspx

"Some Web servers might block files with extensions such as .dll, .config, and .mdf. Windows-based applications typically include files with some of these extensions. If a user attempts to run a ClickOnce application that accesses a blocked file on a Web server, an error will result. Rather than unblocking all file extensions, ClickOnce publishes every application file with a ".deploy" file extension by default. Therefore, the administrator only needs to configure the Web server to unblock the following three file extensions:
.application
.manifest
.deploy
However, you can disable this option by clearing the Use ".deploy" file extension option on the Publish Options Dialog Box, in which case you must configure the Web server to unblock all file extensions used in the application."

Also see here for Microsoft guidelines re things that affect click once installers:

http://msdn.microsoft.com/en-us/library/fb94w1t5.aspx
Reply
#43
v2.1.7.0 released - 30/01/2014
-----------------------------------------

1. Added a new "Movie Info" tab that will show things like Plot, Rating, Tagline, Actors etc. about the movie. The information is read from nfo files found in the same folder as the movies files.

Image
Reply
#44
v2.1.8.0 Released - 02/02/2014
-------------------------------------------

1. Installer changed from ClickOnce to InnoSetup / Netsparkle install system.

v2.1.8.0 will be the last version released as a ClickOnce Installer.

v2.2.0.0 Released - 02/02/2014
-------------------------------------------

1. First release using the new InnoSetup / Netsparkle install system.


Please note that as of this release VideoExplorer will no longer be distributed as a ClickOnce installer.

From this point on VideoExplorer will be distributed using a new install system that is more powerful and more flexible.

The new installer will automatically update VideoExplorer the same as the ClickOnce installer after the initial install.


The new installer can be downloaded from any one of the following 3 locations:

http://www.deventerprise.net/Download/Vi..._Setup.exe

http://brutaldev.com/file.axd?file=Video..._Setup.exe

https://googledrive.com/host/0B9N9faZA-S..._Setup.exe
Reply
#45
v2.2.1.0 Released - 02/02/2014
-------------------------------------------

1. Small bug fix. Bottom of the main grid was being hidden behind the panel below it and the summary row and horizontal scrollbar were not visible.
Reply
  •   
  • 1
  • 2
  • 3(current)
  • 4
  • 5
  • 11
  •   
 
Thread Rating:
  • 1 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
Video Explorer 3.0.0.61: Critical Bug Fixes51