Bug EPG problems
After recently updating my OpenElec build from this thread http://forum.xbmc.org/showthread.php?tid...pid1587283 half the channels were missing from the EPG, although they all still were listed in the Channels list. I tried resetting the PVR database, the EPG database, disabling and re-enabling the tvheadend service and client addons to no avail.

I then went to the Web GUI and tried disabling Skip Initial Scan, Skip Service Availability Check, enabling Idle Scanning and saving and then toggling all those settings back once it had finished scanning all the muxes. That resulted in a couple of extra channels appearing in the EPG and I thought it was fixed but later realised that a lot were still missing. I then updated tvheadend to 4.1.1 and still couldn't get the EPG sorted.

At some point it got itself sorted and is currently showing all the channels but others have reported similar problems http://forum.xbmc.org/showthread.php?tid...pid1587226 and it's hard to know whether the tvheadend addons or the core of OpenElec is the cause, so it would be great if we could get some feedback from the devs on this.

Another issue is that previously when trying to go backwards from the current time, it would block it and open a popup menu instead but now I'm able to scroll back to the start of the day, which is confusing. I also notice that the EPG doesn't tend to be at the current time, so that the first segment/programme is actually for a programme that's already finished and I have to move to the next block along to select/start the current programme, so if this could be changed so that the start of the EPG is always the current time that would be nice. The programme titles also only seem to "stick" to the start of their respective blocks, so that if it's a long film and it's 1/4 or 1/2 way through or more, the block for that channel/programme doesn't show any text, which is rather confusing.
Thanks doveman2, I just tried toggling those settings in the web-app and it fixed the problem. However, I misread you instrutions slightly. I disabled "Autodetect muxes", "Skip initial scan" and "Skip service availability check when mapping". I then restarted the Pi and all the channels were listed again in the EPG. I did not enable "Idle Scanning" and I did not rescan the muxes. So, by process of elimination, to fix the problem you just need to disable one or both of "Skip Initial Scan" and "Skip Service Availability Check" and then do a restart. Strangely, this work-around seems to be persistent; after re-enabling these settings and restarting the Pi the EPG still grabs all the channels.
Yeah, I wasn't really sure which of those options did the trick, so glad you managed to get yours working again too. As you say, after toggling the options back to how they were (which I believe is necessary to prevent constant continuity errors in the log and other problems), it continues to work fine, which is quite strange.
Today the EPG is missing channels again Sad
I narrowed it down to "Skip Initial Scan". With this enabled (using the new Gotham builds and new TVheadend service and client addons) Tvheadend misses some channels in the EPG. After disabling this option and restarting, the EPG is fixed.
Report it on the tvheadend bug tracker.
It's not clear if it's a backend issue though, as the channels all show in the channel list in both the Web GUI and XBMC and the EPG in the Web GUI wasn't missing any channels when I had the problem either, so it looks like it may be more a addon/XBMC integration issue and the sticky for this sub-forum says "This thread is really for issues with the XBMC-PVR TVH addon (pvr.hts) and general TVH-XBMC integration issues" and only that backend bugs should be reported here https://tvheadend.org/projects/tvheadend...acker_id=1

@Hip-Gnosis, I accidentally hadn't reset my options, for tuner1 at least as I never had to change them for tuner2 to fix the problem, so I still have Skip Initial Scan disabled, Idle Scanning, Monitor Signal Quality and Full Mux Reception enabled, so that explains why I haven't seen the problem resurface (I don't see the continuity errors back in the log with those options, which is surprising but I don't have debug logging enabled so maybe they only show up with that). I'll try enabling Skip Initial scan again and see if it triggers the problem for me again too.
Well I haven't seen any missing channels since enabling "Skip Initial Scan" again, although I also left "Idle Scanning" and "Full Mux Reception" enabled. I've disabled the last two of those again now so I'll see what happens over the next few days.

I did have some issues with entries in the EPG though, such as an episode of The Simpsons showing as being 7 hours long and similar mistakes with other episodes but doing a "Reset EPG" fixed those, so I'm not sure they were related to the TVheadend settings.
Actually I rebooted earlier after it froze whilst watching/recording TV and after that half the channels were missing again. I also have the problem that tvheadend is pushing the CPU to 100% now and I haven't found any options to fix this, so I'm trying to revert to an earlier build but this is made difficult by the fact that the SMB share to Update disappears after rebooting whilst I'm trying to copy the files to it!
I'd been away for 2 weeks and just got back to find that the EPG is missing channels again despite leaving 'skip initial scan' disabled. Simply rebooting the Pi did not fix the problem. I've now toggled this setting from disabled to enabled and back to disabled (rebooting the pi in-between) and the channels are back.

Also, when the problem occurs, the channels are missing from the Tvheadend web-app (not just XBMC on the Pi as I initially thought).

I too have been having issues with Openelec reporting %100 cpu usage at idle. It seems that this is indeed being caused by Tvheadend. When I disable the Tvheadend service (via XBMC->settings->addons->services) CPU usage drops to ~%19. Interestingly, when I restart the service, CPU usage remains at ~%19. It is only when I boot up the Pi with Tvheadend enabled that the CPU usage locks at %100.

My best guess is that these problems were introduced around the time of this build:

These issues persist on the most recent build:

Can I provide further info? How can I provide logs from Tvheadend?
Like I said you should report it on tvheadend's bug tracker since both those issues (missing channels and high CPU usage) seem to be tvheadend's fault.

The logs are available in /var/log/syslog, you can parse out the relevant stuff to a separate file by running "grep tvheadend /var/log/syslog > newfile". There are some tricks to enable more verbose logging but I can't remember them at the moment.
I'd say you're right Negge.
I've reported these issues at the Tvheadend site.


Logout Mark Read Team Forum Stats Members Help
EPG problems0
This forum uses Lukasz Tkacz MyBB addons.