Resolved: Can't get LIRC to work with TopSeed 1784:0006
#1
I had an HP branded Remote and Transceiver working just fine. I built a box for my brother and gave him my Transceiver and ordered another for myself. The replacement is slightly different in appearance, and obviously has a different chipset. It is a TopSeed eHome with device ID 1784:0006. I am using Ubuntu 12.04 with kernel 3.8.0-33. I have spent 3 weeks trying to get this #!#? thing to work but with no luck.

* It works fine on Windows 7 with XBMC
* It seems that the kernel driver is not properly generating scan codes. Using ir-keytable -t I get different scan codes for the same keypress.

sudo ir-keytable
Found /sys/class/rc/rc0/ (/dev/input/event3) with:
Driver mceusb, table rc-rc6-mce
Supported protocols: NEC RC-5 RC-6 JVC SONY SANYO LIRC other
Enabled protocols: NEC RC-5 RC-6 JVC SONY SANYO LIRC other
Repeat delay = 500 ms, repeat period = 125 ms

The following was generated for multiple presses of the "DOWN" key. Sometimes more than one event was generated for a single key press.
@Smeagol$ sudo ir-keytable -t
Testing events. Please, press CTRL-C to abort.
1388716867.580815: event MSC: scancode = 4007c2
1388716867.580815: event sync
1388716867.644822: event MSC: scancode = 1001
1388716867.644822: event sync
1388716868.476828: event MSC: scancode = 400
1388716868.476828: event sync
1388716869.692843: event MSC: scancode = 400
1388716869.692843: event sync
1388716870.652840: event MSC: scancode = 400
1388716870.652840: event sync
1388716870.972834: event MSC: scancode = 800f
1388716870.972834: event sync
1388716871.452841: event MSC: scancode = 400
1388716871.452841: event sync
1388716872.732845: event MSC: scancode = 2003c10
1388716872.732845: event sync
1388716873.660861: event MSC: scancode = 400
1388716873.660861: event sync
1388716875.676886: event MSC: scancode = 400
1388716875.676886: event sync
1388716875.996875: event MSC: scancode = 4007
1388716875.996875: event sync
1388716879.420888: event MSC: scancode = 400782
1388716879.420888: event sync
1388716879.484904: event MSC: scancode = 1001
1388716879.484904: event sync

I have tried disabling lircd, disabling the kernel drivers, switching from USB 3 to USB2, rebooting, irw, mode2. I have read tons of LIRC articles trying to pin this down but without any luck. I have the source code for lirc, including mceusb.c for my distribution and release. I even had a second transceiver sent. I have not yet tried compiling with debug tracing. Nor have I tried tweaking the "aeps" and "eps" args in /usr/share/lirc/remotes/mceusb/lircd.conf.mceusb.

I am very close to just junking this remote and getting another.

I appreciate any suggestions, or leads. I started to post to LIRC.org, but I don't think they own the mceusb.c code.
Reply
#2
The problem was that I was running it on USB3. It works fine with USB2. The port which I thought was USB2 was actually USB3. Note that HP uses the same part number/model even though the chipset is different. In my case, the chipset was based on Topseed, identified by Ubuntu as 1784:0006. I had another HP remote which worked fine on USB3 with the same part number, but different chipset. Part Number: TSGI-IR01 Model: 5070-2584.
Reply

Logout Mark Read Team Forum Stats Members Help
Resolved: Can't get LIRC to work with TopSeed 1784:00060
This forum uses Lukasz Tkacz MyBB addons.