Thread Rating:
  • 1 Vote(s) - 5 Average
Search keeps popping up?
#1
Okay I've been having this issue for a while now and it's just finally become enough of an annoyance to come ask for advice. Every 30 minutes or so of inactivity xbmc will pop up a search dialogue. So basically any time I leave it sitting when I come back I'll have to hit escape to close the search box before doing what I'd like to do, and multiple times during a movie it will come up and I'll have to find the remote and dismiss the box. I don't have any idea what's causing it to come up. When searching keyboard.xml nothing shows up for 'search' except a blank multimedia keyboard key browser_search, which is set to do nothing. I don't have a keyboard or mouse plugged in, just IR receiver for my harmony remote. This issue has been going on for a while, using various gotham nightlies. I'm currently on the january monthly of gotham and still having the issue. Any ideas as to what would cause search to come up? I'm using Ace skin, but have the issue regardless of skin selection (i've tried default confluence and transparency! as well)
Reply
#2
I am having this same issue on Gotham alpha 11 and Windows Vista. Also using a Harmony remote FWIW.
Reply
#3
Can either of you get us a debug log (wiki) of when this happens?
Reply
#4
I tried but get a script failed for XBMC Log Uploader.
Reply
#5
I disabled a bunch of add-ons and it seems to have fixed it. I will try to figure out which was the culprit.

Also, going to get rid of Vista soon!
Reply
#6
I had no idea people where still using vista. Are there still people that use Windows M.E as well?
[Image: widget]
HTPC: Motherboard: Asus F2A85-V, CPU: AMD A10 6800K, RAM: Kingston XMP BEAST 16GB, Samsung 840 EVO 250GB, LG CH12NS30 Blu-Ray drive, Samsung, and WD various 2 and 3TB for storage, Windows 8.1, one for all remote/FLIRC, Logitech z906 surround system.
Reply
#7
I was hoping to run xbnc on windows 3.1. Am I out of luck?
If I have helped you or increased your knowledge, click the 'thank user' button to give thanks :) (People with less than 20 posts won't see the "Thank you" button.)
Reply
#8
I've gone in and gotten xbmc.log from my user directory a couple minutes after the issue came up (it came up twice within about 30 minutes, so when my show ended I exited xbmc and made a copy of the log file). Is this the file you need to look at? Am I just able to upload the full file to dropbox or something, or should I only include certain parts and just copy/paste here, etc?
Reply
#9
all of it to pastebin.

Oh and it needs to be a DEBUG log.
If I have helped you or increased your knowledge, click the 'thank user' button to give thanks :) (People with less than 20 posts won't see the "Thank you" button.)
Reply
#10
um...it's really big. I turned on debug and watched a couple tv shows waiting for it to pop up, and when it finally did I waited for the show to end then exited xbmc and pulled the log. It's about 27mb (covering about 2.5 hours)... Here's a dropbox link, but pastebin is freezing every time I try to paste it in. I could try just around the time the error occurred and pastebin that, but wasn't sure if more information was necessary. Here's a link to the dropboxed log file: The search box randomly popped up at around 5:37 pm

https://www.dropbox.com/s/8gow95rmnzmfblk/xbmc.log
Reply
#11
(2014-01-24, 01:05)lazyboy0172 Wrote: um...it's really big. I turned on debug and watched a couple tv shows waiting for it to pop up, and when it finally did I waited for the show to end then exited xbmc and pulled the log. It's about 27mb (covering about 2.5 hours)... Here's a dropbox link, but pastebin is freezing every time I try to paste it in. I could try just around the time the error occurred and pastebin that, but wasn't sure if more information was necessary. Here's a link to the dropboxed log file: The search box randomly popped up at around 5:37 pm

https://www.dropbox.com/s/8gow95rmnzmfblk/xbmc.log

i can't make much soup out of it, but this is my interpretation...

there's an upnp process running in the background.
it seems to scan(?) all your media sources and your installed addons too.

when it gets to the addons, it actually runs them.
one of the addons (plugin.video.trailer.addict) pops up a search dialog when it starts.


perhaps someone more knowledgeable in the upnp area could shed a light on this:
Quote:17:37:38 T:1916 DEBUG: UPnP Translated id to 'plugin://plugin.video.trailer.addict/?mode=0&name=%5B+Search+%5D'
17:37:38 T:1916 INFO: Received UPnP Browse Metadata request for object 'plugin://plugin.video.trailer.addict/?mode=0&name=%5B+Search+%5D'
17:37:38 T:1916 DEBUG: Preparing upnp object for item 'plugin://plugin.video.trailer.addict/?mode=0&name=%5B+Search+%5D'
17:37:38 T:1916 DEBUG: UPnP: Building didl for object 'plugin://plugin.video.trailer.addict/?mode=0&name=%5B+Search+%5D'
17:37:38 T:2680 DEBUG: UPnP Translated id to 'plugin://plugin.video.trailer.addict/?mode=0&name=%5B+Search+%5D'
17:37:38 T:2680 INFO: UPnP: Received Browse DirectChildren request for object 'plugin://plugin.video.trailer.addict/?mode=0&name=%5B+Search+%5D', with sort criteria
17:37:38 T:2680 DEBUG: XFILE::CPluginDirectory::StartScript - calling plugin Trailer Addict('plugin://plugin.video.trailer.addict/','33','?mode=0&name=%5B+Search+%5D')
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#12
when I saw all the upnp stuff I turned that off. I only had it enabled in case I wanted to watch from ps3 instead of xbmc. I'll keep an eye on it and see if it comes up again, and if it does I'll get another debug log up. Thanks for looking! If there's anything else I can do that would be helpful, I'd be happy to do so
Reply
#13
Hmmm I've also experienced strange XBMC behavior which looks like someone controls it remotely. Search dialog popping up randomly, movie list switching to thumbnail mode by itself etc. Now that I think about it this started happening some time after I bought a new LG Smart TV and connected it to my LAN but somehow I've never realized this before that this might actually be the culprit Smile. I've always had UPnP turned on in XBMC because I've been trying to use Bubble UPnP on my phone and only other active UPnP device right now in my network is the TV. I've switched off UPnP support in XBMC and I'll observe if the strange behavior continues.
Reply
#14
Did you ever find resolution to this problem? UPNP and new LG Smart TV could be precisely the culprits here. I switched to the Gotham monthly a while back and I started to get this Search pop-up few times per show. I also have the weird behaviour of movie list switching view mode for no reason. I've always attributed fault to Gotham but now it's in Beta and I haven't seen any changes. Now that you mention it I changed my TV around the same time I switched to Gotham.

Anyway, I'll try turning off the UPnP. Thanks for the idea.
Reply
#15
Hi,

I've been having the exact seem problem for weeks now. Been searching the internet since....
Turned off Upnp, let's hope this caused the problem.

Als on an LG smarttv with simplink controller.
Reply
 
Thread Rating:
  • 1 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
Search keeps popping up?51