Problems with DVD playback (video errors, menu not usable)
#1
Question 
Hi!
I'm using my Raspberry for about a month and tried several things (including a little overclocking) and I'm sure at the beginning DVD playback wasn't an issue - but now it is. (and of course I've bought the license for MP2 and VC1 codec).
I've picked one of my dvd's just for demonstration purposes, in the end I've problems in each dvd.

Please take a look at the video showing the problems:
# the video of the universal-trailer that starts directly at the beginning of the dvd-playback disappears after a couple of seconds, but comes back a few seconds later.
# after the trailer there should be immediatly the first dvd-menu for language selection - but it's not coming...
# (in other dvd images I sometimes get the menu, but when I choose an item from the menu nothing happens.. playback locks up and I can stop it - but no chance to navigate through the menu as expected)

Heres the video:
RaspberryPi DVD playback error
(at the beginning you can see the RPi with the USB-Stick where the dvd is stored, the XBOX-IR-Receiver and the original DVD Wink

It needs a password: raspberry

So at first I though it might be a bad rip, but as you can see on the video it's possible to play the .vob file that contains the trailer without any problems - only when it's played as part of the dvd it makes problems, so the files are correct.

I've tried the following things:
# play directly the disc with a connected dvd.drive >> same-error
# play from the ripped folder >> error (as seen in the video)
# play from a ripped iso file >> same-error

I've tried 4 different distributions on different sd cards with different version (frodo and gotham builds):
# raspbmc
# openelec
# xbian
# raspbian-xbmc
and I get exactly the same problem in each of them.

I also tried 2 different TVs and different power supplies, different sources (USB, network SMB and network NFS), XBMC install to sdcard and to usb stick... but nothing made a difference.

But I can play the rips successfully on XBMC-Windows, XBMC-Android and XBMC-Openelec-Generic-x86 - so the ripped files are not damaged.

Any ideas?

I'm running out of ideas... ordered a 2nd RPi yesterday so I can compare results on another unit.... but it will take a few days until I get it.

Can this be a hardware defect? But in case it is - why can I play the VOB file without a problem and only when played using the dvd-structure the problem occurs? And why is everything else working? In case it's not a hardware defect - why can't I find anything about this issue on the net?

If not the slightest idea what else I could try....
Reply
#2
Have you tried changing the setting to 'Attempt to skip introduction before DVD menu'? It's under 'System>Video>DVDs'

I've found enabling this works for some of my rips, while disabling it works for others.

If that doesn't do it, you may want to post the log file. http://wiki.xbmc.org/index.php?title=Log_file/Easy
Reply
#3
Tried that option, but doesn't make a difference.

Somehow I was under the impression that RPi should support dvd-iso playback already, but I think I've been wrong and it's a known error that dvd menu playback is not working reliable at the moment (at least in the xbmc wiki I've found this as known issue ).

Is this something that will get fixed until the final release of gotham?

Here you can find the debug log with the directly-to-dvd-menu option enabled: debug log (the dvd menu is not displayed)
Reply
#4
Hi!

Just tried to most current Gotham-RaspBMC Build with 'dvdplayer' as default player (instead of the former omxplayer) and now the introduction-video of my test dvd plays without problems!

But the DVD menu ist still not really useable - here's the current Logfile

Although I can only see a black screen, it's possible to navigate to the different menu-items using the arrow keys.

I think only menu't with a video in the background are displayed properly, all menu-pages with just a still picture are unuseable?

When I just press ENTER on my remote I can get into the main menu, and from there I can also open for example the 'chapter' submenu - but as this has only a still-picture it's again not displayed - but when moving around with the cursor-buttons I can see the selection-marker moving from item to item (although no item's are visible). So navigation seems to be working, but the background pictures are not displayed.

Is this something that will get fixed before the final Gotham release?

Thanks in advance!
Reply
#5
Hi,

so I've found someone who has the same problem ;-)
I've tried also a lot of things (different xbmc versions on raspberry pi) and I've always the same problem:
I've a lot of TV recordings which where finally ripped toDVD's. The DVD structure is copied on a NAS.
The DVD contains a simply menu (no audio or video playback). It's only a static background jpg and for example 13 menu items.
(Each item is a recorded TV series)
The NAS Share is mounted to the raspberry pi (currently running nightly build of gotham).
The DVD structure runs well on XBMC on Windows 7 and Windows 8.1. IT's also played by other DVD Players (e.g. VLC, Windows Media Center)
So the DVD must be ok)
Codecs on Raspberry Pi are both enabled

But when I start the dvd on raspbmc (gotham nightly) the menu isn't shown. It's simply black, but the menu is there in the background.
I can blindly choose a menu item and than the according movie is shown
Other DVDs (with a video trailer and menu with background video or animated menu) works well.
So I also think that there's only a problem, when you have a "static" background menu.

I also raised a Post in a other forum:
http://forum.stmlabs.com/showthread.php?tid=12880

I also tried omxplayer and dvdplayer within raspbmc gotham nightly, makes no difference, same error

So maybe we could be in contact for future?
Maybe we find a solution together?

Regards

Helmar
Reply
#6
@Helmar: As I'm not a developer and therefore quite helpless when such problems occur I did the only thing that seems to be possible: wait and hope that someone else will solve the bugs Smile

Although I haven't tried the latest Openelec nightly from Milhouse it seems as if there's now a fix for our problem available - take a look at the last line in the 'Build highlights' section here : http://forum.xbmc.org/showthread.php?tid...pid1619652

Will try it tomorrow Smile
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Problems with DVD playback (video errors, menu not usable)00