IPTV Simple Pvr addon
#16
I think the streams that Daki wants to run on XBMC are from the same provider that I use, nettv-plus (based in Austria). And yeah, they won't run on XBMC. For some reason the provider has found a way to block XBMC from beeing used as a client.
Those streams do work fine on other apps such as vlc, simpletv, browsers, ipad2, atv2, ect. On vlc we need to change the http-user-agent in order for them to work, but that does not work in xbmc.

I even downloaded the source of xbmc, and changed the user-agent strings (where I found them) and compiled my own version, but no luck Smile

Created a topic about it as well, with debug loggs, but no one replyed...
http://forum.xbmc.org/showthread.php?tid...pid1586341
HTPC Server - Windows 8.1 + XBMC Helix | Intel QuadCore, 4GB RAM, 4 TB SATA
Intel NUC D54250WYK - Windows 8.1 + XBMC Helix | Logitech Harmony 750
Samsung UE8005 | Bluetooth keyboard & mousepad
Reply
#17
According to the bug report on videolan.org the stream is broken, that's why it doesn't work. And judging by the URLs this providers actually uses an Enigma2 box to serve streams? That sounds like a horrible idea.
Reply
#18
Yeah Maniac is right, I use Nettv plus Smile but I also did see a guy who got it to work through xbmc. There is a video on youtube of it so I thought I might be able to get someone to help to get it working. A couple other people told me that it can be done but they dont work with xbmc unfortunately. I will gladly post the log here in just a little bit Smile
Reply
#19
Ok here is the debug log: http://xbmclogs.com/show.php?id=109320

I use an m3u list that is slightly different then the one I use in the log above^^, and that list works perfect in VLC. Unfortunately every list I have tried has given the same result for XBMC, the channel starts to load (says working) when I click on it, but nothing happens.

@Maniac

I am curious, what do you prefer or think is best to use to watch nettv plus? I dont really want to buy their box, so I was looking into the atv2 because it seems like a simple choice, So I was curious to see what you think about it? Smile
Reply
#20
The problem with NetTVPlus is not related to the "user-agent" string. I've been investigating the traffic and discovered that the problem is connected to bad handling of HTTP 302 header. So, when you enter URL for NETTV stream, the server redirects you to giving you a temporal authentication URL. XBMC uses 3-4 years old cURL library and the problem has been fixed in the new releases.

To confirm this, you can try add the following URL in your playlist:
http://185.20.36.233:8080/stream/?fw=tru...layer=http

And the stream will certainly appear.

However, the problem is reported and apparently is fixed:

4067 (PR)

https://github.com/xbmc/xbmc/commit/e5a6...215f4674cb

I think that patch is already included in last nightly releases.

If that does not work, a simple solution suggested by one of the members of this forum would be to write a script that takes care of the authentication for you and returns a m3u8 (HLS) type response back to XBMC for it to resolve.

m3u file would be like:

#EXTINF:-1 tvg-id="Nettv" tvg-name="nettv" tvg-logo="Nettv", Nettv
http://<some ip>/yourscript?channel=nettv<or any other parameter you need passed>

Your script would do the necessary authentication against Net TV and retrieve the correct playback url. Take this url and format it into a m3u8 format and send it back to IPTV. Theortically this should work.

Regards,
Alex
Reply
#21
Hi Alex,
I didn't see your post until now. Sorry about that. Very interesting what you are saying here. I have been testing on the latest nightliy of Gotham 13.0 beta1, and the issue is still the same.

The thing is that the stream URL that you added is just a "demo-stream", available to everyone just to test the service. It is not authenticated. This stream allways worked with XBMC, vlc and other apps.

The problem is when starting to use the authenticated channels. (We change the &u=user1 parameter to our own user\password). Then they won't run. Not even in VLC untill we change the http-user-agent.
At the bottom are the debug results while testing an authenticated channel in XBMC, with and without user-agent string (None of them work, but there are differences in the log).

Can you explain a bit more regarding the last part, creating a script that will authenticate the stream url and pass the correct one to xbmc? Got an example?

Without "|User-Agent=SomeValueHere":
Code:
INFO: XCURL::DllLibCurlGlobal::easy_aquire - Created session to http://185.20.36.232
ERROR: CCurlFile::FillBuffer - Failed: HTTP response code said error(22)
NOTICE: CCurlFile::FillBuffer - Reconnect, (re)try 1
ERROR: CCurlFile::FillBuffer - Failed: HTTP response code said error(22)
ERROR: CCurlFile::CReadState::Connect, didn't get any data from stream.
ERROR: XFILE::CFileCache::Open - failed to open source <http://185.20.36.232:8080/stream/.........>
ERROR: CDVDInputStreamPVRManager::Open - error opening [http://185.20.36.232:8080/stream/...........]
ERROR: CDVDPlayer::OpenInputStream - error opening [pvr://channels/tv/All TV channels/6.pvr]
NOTICE: CDVDPlayer::OnExit()
NOTICE: CDVDPlayer::OnExit() deleting input stream


With "|User-Agent=SomeValueHere" & without "&fw=true" parameter:
Code:
INFO: XCURL::DllLibCurlGlobal::easy_aquire - Created session to http://185.20.36.232
DEBUG: CDVDInputStreamPVRManager::Open - stream opened: http://185.20.36.232:8080/stream/........|User-agent=Mozilla
NOTICE: Creating Demuxer
NOTICE: Thread FileCache start, auto delete: false
INFO: CFileCache::Process - Hit eof.
DEBUG: ------ Window Init (DialogBusy.xml) ------
DEBUG: ffmpeg[EC8]: Format mpeg detected only with low score of 25, misdetection possible!
DEBUG: CDVDDemuxFFmpeg::Open - probing detected format [mpeg]
DEBUG: CDVDDemuxFFmpeg::Open - avformat_find_stream_info starting
ERROR: ffmpeg[EC8]: Truncating packet of size 276 to 40
DEBUG: ffmpeg[EC8]: [mpeg] probed stream 1 failed
DEBUG: ffmpeg[EC8]: [mpeg] parser not found for codec none, packets or times may be invalid.
ERROR: ffmpeg[EC8]: [mp2] Header missing
INFO: ffmpeg[EC8]: [mpeg] decoding for stream 0 failed
DEBUG: ffmpeg[EC8]: [mpeg] Could not find codec parameters for stream 0 (Audio: mp2, 0 channels, s16p): unspecified frame size
DEBUG: ffmpeg[EC8]: [mpeg] Consider increasing the value for the 'analyzeduration' and 'probesize' options
DEBUG: ffmpeg[EC8]: [mpeg] Could not find codec parameters for stream 1 (Video: none): unspecified size
DEBUG: ffmpeg[EC8]: [mpeg] Consider increasing the value for the 'analyzeduration' and 'probesize' options
ERROR: ffmpeg[EC8]: Truncating packet of size 276 to 40
WARNING: could not find codec parameters for pvr://channels/tv/All TV channels/6.pvr
ERROR: CDVDDemuxFFmpeg::Open - error probing input format, pvr://channels/tv/All TV channels/6.pvr
ERROR: Previous line repeats 8 times.
ERROR: CDVDPlayer::OpenDemuxStream - Error creating demuxer
NOTICE: CDVDPlayer::OnExit()
NOTICE: CDVDPlayer::OnExit() deleting input stream
HTPC Server - Windows 8.1 + XBMC Helix | Intel QuadCore, 4GB RAM, 4 TB SATA
Intel NUC D54250WYK - Windows 8.1 + XBMC Helix | Logitech Harmony 750
Samsung UE8005 | Bluetooth keyboard & mousepad
Reply
#22
(2014-01-09, 18:16)Daki Wrote: Ok newest version of xbmc installed and and iptv simple enabled as well. When I add my m3u list, everything loads and all the channels show up when i go over to live tv. When I try to play any channel it starts to load and then nothing happens. Why would this be happening? Im guessing my m3u list is not set up correctly?

Hi,
Please help me I also plugin iptv simple enable.. but I dont know how to add m3u list and where can I download it plzzz tell me how to do it,, I m very thankful to you

(2014-01-09, 12:12)Maniac Wrote: IPTV simple is included in Frodo 12.3 and in latest Gotham version. You select it while installing XBMC, and you enable it under addons.

Works fine here.

Hi,
Please help me
Using xbmc fordo 12.3, enable iptv simple plugin and no channels in live tv list help me how to add channel from m3u list,, I m newer to xbmc

, I m very thankful to you
Reply
#23
@furqansaeed18: you can't be bothered to read the main IPTV plugin thread, which naturally explains everything you need to do? It would have taken you less time than it took you to create an account and write this post. I'm guessing you googled something like "free TV XBMC" and stumbled upon this thread thinking there's some magic way of getting a bunch of TV channels.
Reply
#24
Anyone have the link to add pvr iptv on xbcm
I have others pvr but i need the iptv to watch chanel from brazil
if anyone can help me
I need the link to add using the zip
thanks
Reply
#25
I dont have iptv simple client on my xbmc G-Box Midnight
Anyone can help me instal from add source and zip file??
Reply
#26
Can none of you read and use the forum's search feature? There is a main thread for the plugin which has everything you need.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
IPTV Simple Pvr addon00