OpenElec RPi Gotham - Tvheadend Service Interfers with IR remote.
#1
Hi

I've been having a strange issue with the TvHeadend service for OpeneElec on my Raspberry Pi.

On the stable build (3.2.4 / Frodo) everything works well. But i've been trying recent dev builds of Gotham and have been getting strange problems which disappear when I stop the TvHeadend service.

When the system starts up at first I can use my remote control as normal, then over the next few minutes it becomes less and less responsive to the point where I have to press a button maybe ten or more times before the gui responds.

If I ssh into the Pi and kill the TvHeadend process the remote goes back to normal working for a while, but again slowly becomes unresponsive after TvHeadend restarts.

If I disable the service completely in the Add-On settings I do not see the issue at all.

I've tried two separate remote control systems, the first using a GPIO receiver with LIRC and the other a FLIRC USB adaptor which emulates a normal USB keyboard (no LIRC) - both behave the same. A wireless USB keyboard is not effected and seems to work fine.

TvHeadend is used with a generic IT9135 USB TV adaptor plugged straight into the RPI's USB port. And the PSU has plenty of capacity being 3 amps, so don't think that is the likely issue.

As I said, the system works fine with Frodo, but I would like to get it working in Gotham.

Any ideas? Thanks.
Reply
#2
I'm not sure if related but have you tried a different dongle ?
The generic ITE IT9135 dongles that I've tried never worked well with the RPi.

The IT9135 based WandTV seems to work ok and also a Realtek RT2832U based dongle (the "Mini form factor" not the full stick size).
Reply
#3
(2014-01-14, 04:39)dhead Wrote: I'm not sure if related but have you tried a different dongle ?
The generic ITE IT9135 dongles that I've tried never worked well with the RPi.

The IT9135 based WandTV seems to work ok and also a Realtek RT2832U based dongle (the "Mini form factor" not the full stick size).

No I've not tried another dongle but will at some point soon if I can find one to borrow.

However, I found that my current dongle worked surprisingly well with Frodo, it's when trying the dev builds of Gotham that I've had this problem.
Reply
#4
Just my .02, but I think you might have answered your own question.

I would suggest trying a powered usb hub. Plug all the usb devices into it. See if that makes a difference.

**I don't have a Pi, and I don't have a usb tv dongle, but I've seen COUNTLESS threads about Pis and multiple usb devices causes issues.
Reply
#5
(2014-01-24, 17:39)00b5 Wrote: Just my .02, but I think you might have answered your own question.

I would suggest trying a powered usb hub. Plug all the usb devices into it. See if that makes a difference.

**I don't have a Pi, and I don't have a usb tv dongle, but I've seen COUNTLESS threads about Pis and multiple usb devices causes issues.

Ah yes - good idea. I will try a powered hub soon and report back.
Reply
#6
Finally tried this with a powered USB hub and it has made no difference.

As I said this setup worked fine with Frodo and older builds of Gotham so it appears to be related to something recently introduced in either OpenELEC, TVHeadend or Gotham.

I have to choose between either my having my IR remote or Live TV working. Or I guess I could go back to an older version and accept the performance hit from that Sad
Reply
#7
As always, no one can do anything but speculate unless you provide a debug log.
Reply
#8
Hi, I've experienced the same problem on Raspbian. I use gpio based ir receiver and it looks interfered by tvheadend module handling dvbt (guess due to no such behaviour while dvb-t is removed, this not handled by tvheadend).

All was working fine until I installed Gotham in place of Frodo. I was forced also to perform rpi-update due to noise issue on Gotham.

So when tvheadend is down, irw shows perfect ir work, when tvheadend is up and running ir works fine until tv scann proces is finished and tvheadend_grabber stops and kdvb-ad-0-fe-0 starts.

How to collect useful debug information? Please provide steps what shall I follow, so I provide necessary logs.

Cheers
/Rafal

--------------------------------------------
Loaded firmware with kernel 3.10.38 and problem disappeared. There must be some change impacting GPIO between 3.10 and 3.12.18. Something used by kdvb-ad-... workis in a way, so GPIO is disturbed.

/R
Reply
#9
Same here, with an avermedia tv tuner (usb), tvheadend backend 4.0.5 and i tried openelec and an up to date osmc this week. Same problems, the ir remote works fine through gpio, but when live tv (client) is running it turns less responsive. Any idea? Have you fixed this problem?
Reply
#10
I just bought a Hauppauge 950Q usb tuner, and my MCE R6 remote that I've been using through gpio is suffering the same problem. It can't control the tuner by itself, and it's hopeless trying to control the tuner by the gpio. The good part though... the raspberry pi can be controlled by the tuner and it's own remote.. no need for the gpio ir receiver anymore. Smile

The remote that came with the 950Q isn't the best though.. it's a credit card sized unit, not much bigger than the pi itself, and not much thicker. I'm afraid I'll break it.. lol. Luckily though, I have an actual full sized remote from an older Hauppauge pci-e unit that works. Smile

But then I just found out about Kore.. an app for Android phones and tablets, that not only gives you a touch screen remote, but you can view your music and video libraries, as well as the live tv epg. You can even select and jump to your video addons.. all on the smartphone or tablet, without interfering with the current program onscreen. It's pretty cool. Smile
Reply
#11
Hi,
anybody had any luck with this problem?
I am currently using Raspberry Pi 3, with RemotePI for IR receiver through GPIO 18. I have OpeneElec 7.0 beta 3 installed. For DVB-T signal, I use PCTV QuatroStick Nano and latest Tvheadend avaliable on OpenElec.
And every time I start watching TV or start recording, navigating with remote is almost impossible. If I run irw, not all button presses are registered.
Reply



Logout Mark Read Team Forum Stats Members Help
OpenElec RPi Gotham - Tvheadend Service Interfers with IR remote.0
This forum uses Lukasz Tkacz MyBB addons.