Did Gotham lose auto download first sync?
#16
Oh I hate this! Auto download first sync was really an awesome feature.
Reply
#17
I hate this too, so I restored by backup and downgraded to Frodo. I sure hope this feature gets added back after Gotham release.
Reply
#18
(2014-02-03, 19:41)amet Wrote: probably not, we are still deciding.

problem is that if you use more than one search language there is no way to specify which "sync" to download ... so maybe adding it only if one language is searched for?

There is an preferred/default subtitle language option on the video/subtitle menu. I created a PR to pass this param to our services.
(We can select default subtitle service from the menu too).

If we know the default service and the default language, I think we can decide what subtitle need to be downloaded.

What do you think? Is it a right way?
Can we re-enable/re-implement the "auto download first sync" feature, after my PR was merged?
These aren’t the droids you’re looking for...
Reply
#19
My vote to bring back auto sync subtitles - was a really awesome feature.
Reply
#20
Yeah. Automatic subtitle downloading is the reason why Im not moving from Frodo 12.3 to Gotham RC1.
Id like to see this option making comeback.


Even better, Id like to have plugin, which would download automaticly subtitles for ALL the entrys in library. Like once a day.
And if anyone has somekind of program that does this for them outside of xbmc, Id like to know.

Ive tried S-Subs and Subtitle Monster. I Didnt like them.
Reply
#21
I found it. This holy grail is called... Subliminal. Downloads subtitles automatically every night.
Great pythonscript. Better than anything plex/xbmc has thrown us.
Reply
#22
I created a pull request about the first sync subtitle downloading. I hope it'll accepted soon by the xbmc team.
If you have time please test it and let me know if something goes wrong.
These aren’t the droids you’re looking for...
Reply
#23
(2014-05-04, 13:18)fape88 Wrote: I created a pull request about the first sync subtitle downloading. I hope it'll accepted soon by the xbmc team.
If you have time please test it and let me know if something goes wrong.

Hi. I'm sorry for probably sounding stupid, but how could I test your solution? (I'm not a programmer but I could create some file copy-paste inside the script , change some lines inside it and put it where it's needed if this is what required)

In general, I would like to add my opinion to those who think that the auto download is important. I recently installed the XBMC (used Bsplayer before) and it's truly impressive. But I used to auto download function and without it XBMC is not perfect as it could be.
Reply
#24
Hi!
Thanks. You need to compile first.
But I hope it will merge soon into the official xbmc repo. After that you can test it on the nightly builds.
These aren’t the droids you’re looking for...
Reply
#25
The subtitles are working great in Gotham, and it feels really clean to have these services installed (and maintained) as separate addons.

I was a big fan of this "auto-download first sync" feature because it picked the correct subtitles in 95% of the times with a single remote keypress and without interrupting the video - the subtitles just magically appeared. It really contributed to convenience and user experience in my opinion.

The OpenSubtitles search results still contain this 'sync' tag, and there is a 'preferred subtitle language'. These two should allow XBMC to select the 'first' match right?

Just wanted to mention that I'm also looking forward to see this feature return sometime in future.
OS: Windows 7 64-bit
XBMC: Frodo 12
Skin: Confluence
Reply
#26
Here is a Gotham Openelec 4.0 build (Generic.x86_64) with the patches from fape88 if anyone wants to try:

It would be nice to have the plugin only show the subtitles dialog if no sync sub is found.. basically how it was in frodo

https://dl.dropboxusercontent.com/u/3910...20ea5e.tar
Reply
#27
Thanks!

(2014-05-13, 20:13)Steini Wrote: Here is a Gotham Openelec 4.0 build (Generic.x86_64) with the patches from fape88 if anyone wants to try:

It would be nice to have the plugin only show the subtitles dialog if no sync sub is found.. basically how it was in frodo

https://dl.dropboxusercontent.com/u/3910...20ea5e.tar
These aren’t the droids you’re looking for...
Reply
#28
Here is a build with Openelec 4.0.1 - XBMC 13.1 Beta (Generic.x86_64)
https://dl.dropboxusercontent.com/u/3910...3f2566.tar
Reply
#29
My PR was merged yesterday. So hopefully you can try it with nightly builds
These aren’t the droids you’re looking for...
Reply
#30
(2014-05-18, 17:55)fape88 Wrote: My PR was merged yesterday. So hopefully you can try it with nightly builds

I just updated to today's nightly build on my Ubuntu machine:
XBMC 14.0-ALPHA1 Git:6f96ff2 (Compiled: May 19 2014)

I was using the old Aeon Nox (4.0) skin in Frodo 12.3, where you could just press enter twice to download the first sync subtitle. I upgraded to the new Aeon Nox 5: Redux skin to enable Advanced/Expert settings and be compatible with the new subtitle plugins.

If your pull request with the auto download first sync feature was merged yesterday and I updated to today's nightly build, how do I enable it? I am using only the Opensubtitles.com plugin at the moment. I tried with the default Confluence skin as well.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Did Gotham lose auto download first sync?00