•  Previous
  • 1
  • 16
  • 17
  • 18
  • 19(current)
  • 20
  • Next 
 
Thread Rating:
  • 6 Vote(s) - 4.33 Average
Release - service.subtitles.subscene
(2017-01-19, 11:38)macmpi Wrote: Is this plugin still maintained? (this error seems much common over the last few months)
Thanks!
Hello everyone and sorry for my lack of response in the last months. I didn't want to abandon the plugin, but I just didn't get around to maintain it. To be honest, the last issue I investigated seemed to be an issue with the updated Python version in Kodi 17 beta, and I figured to wait this one out until the final version or an RC was released.

However, I think I'll find some hours this weekend to look into the latest issues. As always I'd prefer a complete debug log (wiki), as it is much easier to figure out you problems if I can reproduce your actual searches.
Also, if some coder likes to help out, I will gladly accept pull requests at https://github.com/manacker/service.subtitles.subscene

Cheers
Reply
My log from the error in the addon

http://pastebin.com/HxjjSR2e
Reply
(2017-01-19, 12:02)CrowleyAJ Wrote: To be honest, the last issue I investigated seemed to be an issue with the updated Python version in Kodi 17 beta, and I figured to wait this one out until the final version or an RC was released.
Thanks for the note.
Actually the earlier issue suddenly showed up in 16.1 Jarvis, after several months of fine use: it does not work anymore since (tested on OSX/macOS and LibreElec/Pi).

Thanks for your help.
Reply
For me the plugin stopped working a few weeks ago. The problem was a python issue, an error opening a url with urllib2. It was similar to the one reported for the YouTube plugin here.

The solution was to upgrade two python packages. In my system (Ubuntu) I did it with the commands:

sudo pip install pyopenssl --upgrade
sudo pip install cryptography --upgrade

Then you should restart kodi. You may need to run the commands without sudo, depending on how you are using Python. I assume it's similar in Windows.
Reply
Feature request:

Option to hide Hearing Impaired or Non Hearing Impaired
Option to sort by uploaded date and Ascending & Descending
Reply
Great add-on, thank you! However, I encountered a small bug. In case a download contains 2 files or more usually the wrong (smallest) one is selected and put in the movie folder. This of course means there is no sub available.

An example can be found here.
Reply
watch gallery


Been having this problems since January or so at least. And I kept checking into this thread - I think I have seen a few mentions of one having issue here and there, but nothing defentive.

I run into this problem pretty consistently, especially for releases that has special characters (see photo for an example - the red hearts) - I suspect those are causing subscene addon to have errors.

Is this a known issue? If not, I can look into attaching debug log.

Edit: Actually, I decided to go ahead and add the debug log of the error. Here: https://pastebin.com/zjRU7d5J
Reply
it is possible to use this to automatically set subtitle for my video addon?
Reply
bug in search_manual function, if in listItem year is not defined it will do search_manual but the problem it will not replace space with "+" sign or "%20", so subscene will return "HTTP Error 400. The request is badly formed"
suggested change, in def search_manual(...): replace
Code:
url = main_url + "/subtitles/release?q=" + search_string + '&r=true'
with
Code:
url = main_url + "/subtitles/release?q=" + urllib.quote_plus(search_string) + '&r=true'
Reply
I guess there is no longer anyone maintaining the subscene addon?

I have listed a bug above (my last post in this thread) with debug log attached, with a pattern identified of the issue and it is preventing me from having adddon work at all for majority of time. I have to constantly go to the subscene website and manually download the file and add it into Kodi library.

Not sure what else to do, and I'd like to keep using subscene. It appears I have the latest version
Reply
is it possible to add double subtitle support ?
where one language is displayed on the top and another on the bottom?
i've been using online services for a while but it would be awsome to have it inside kodi.

some sites that i tried:
http://www.dualsubtitles.com/
https://pas-bien.net/2srt2ass (source code https://github.com/vincentremond/2srt2ass/)
Reply
This is not working for me anymore. It always gives me "No subtitles found" for titles that I know have subs on subscene. I'm on 1.7.1

Pastebin: https://pastebin.com/4mmWpWDt
Reply
(2017-07-20, 19:36)rpgmaker Wrote: This is not working for me anymore. It always gives me "No subtitles found" for titles that I know have subs on subscene. I'm on 1.7.1

Pastebin: https://pastebin.com/4mmWpWDt

I am having the same problem since a few days ago. Deleting and reinstalling the add-on doesn't solve it. Tested it by retrieving subtitles that I had done successfully before. The Opensubtitles add-on still works for me, but Subscene is much better for the language I want.
Reply
This is not working for me either. How do you get that debug log? Never mind! Found it!
Reply
Okay... Did some troubleshooting and I think openelec/kodi is missing some SSL/TLS features:
https://gist.github.com/TvL2386/32bcc6d1...e1-txt-L19

I modded the geturl method in /storage/.kodi/addons/service.subtitles.subscene/resources/lib/SubsceneUtilities.py (line 105) for debugging:
except ValueError as e:
log(__name__, e)
Instead of:
except:

Doing `curl https://subscene.com` works, so I am thinking it has something to do with python and SSL...
To be continued.
Reply
  •  Previous
  • 1
  • 16
  • 17
  • 18
  • 19(current)
  • 20
  • Next 



service.subtitles.subscene4.336