•   
  • 1
  • 127
  • 128
  • 129(current)
  • 130
  • 131
  • 277
  •   
OpenELEC Testbuilds for RaspberryPi Part 2
(2013-12-14, 23:01)MilhouseVH Wrote: Not sure about decreasing the nice level in OpenELEC, though as everything runs as root I don't see why you shouldn't be able to do that.

My suspicion was right that OpenELEC doesn't handle "above normal" thread priorities. I've added this commit to piaudio_sink:
https://github.com/xbmc/xbmc/pull/3840

Note: this will affect omxplayer, which runs audio thread above normal priority, as well as the AE Sink,
so it may be worth testing if hard streams play better or worse than before with this change.
(2013-12-15, 19:52)allan87 Wrote: This build is crash city for me. I suspect my audio settings are implicated, but attempting to change any of these settings (even being in the menu) causes a crash. Even turning on debug logging causes a crash.

Could you try moving .xbmc out of the way and see if it is still crashy with no custom settings.
If that is okay, then can you start enabling your usual settings, and try to spot what setting makes it start crashing.
(2013-12-15, 19:54)Koloss Wrote: Thanks, i must nothing change for popcornmix changes in this build?

Correct, you don't need to make any changes as I've added the necessary changes to the system advancedsettings.xml. You would only need to make changes if you had added conflicting settings to your own advancedsettings.xml (ie. by duplicating the entire system as.xml file, but hopefully nobody is stupid enough to do that these days).
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2013-12-15, 20:16)MilhouseVH Wrote: Tested this, and it's solved the "brief silence" problem just before switching tracks - gapless tracks are now played totally gapless (without cross-fade) just as they should be. Many thanks! Smile

Excellent.I don't tend to use the Pi for music, but I know gapless is a frequent request, so this is +1 for the Pi Audio Sink code.
(2013-12-15, 20:12)Koloss Wrote: I updated and i start a movie the screen is black!

The problem setting is: Vertical Blank synchronisation! When i change this then i have a picture!
The setting does not matter: enabled, disabled or driver
(2013-12-15, 20:28)Koloss Wrote: The problem setting is: Vertical Blank synchronisation! When i change this then i have a picture!
The setting does not matter

So now, does it fail on any of "always enabled", "enabled during video playback", "disabled", "let driver choose"?
If it works on all of those now, but didn't before, then hmm...

BTW, "always enabled" is the default (and correct) setting.
My setting before update the build: let driver (i saw let driver before change the setting in the new build)
(2013-12-15, 20:33)Koloss Wrote: My setting before update the build: let driver (i saw let driver before change the setting)

But if you put it back to "let driver choose" now, do you get black screen?
(2013-12-15, 20:19)popcornmix Wrote: My suspicion was right that OpenELEC doesn't handle "above normal" thread priorities. I've added this commit to piaudio_sink:
https://github.com/xbmc/xbmc/pull/3840

Note: this will affect omxplayer, which runs audio thread above normal priority, as well as the AE Sink,
so it may be worth testing if hard streams play better or worse than before with this change.

Hoped I wouldn't have to do another build so quickly! Smile

I've updated my previous post with build 1512b which includes this patch.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
No, i have in always setting a correct screen, after update i must only one change this setting!

.ts files very fast start, thanks! #1412b build
Final build of the day, #1512c includes "Don't allow passthrough and dual audio" commit in piaudio_sink - now fully up to date with all newclock3 and piaudio_sink commits. See post #1920 for details.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
@popcornmix: Please can you comment the joystick support in the xbmc on pi? I am using Frodo, mostly rbej's builds.


(2013-12-14, 01:31)Goofy2 Wrote: I tried to use an old xbox wired controller, it was recognized by OS and xpad driver is loaded, XBMC is checking the device, but that's it. Is there a joystick support compiled in the raspberry xbmc? I couldn't find joystick option in the GUI and modifying guisettings.xml didn't help.

Code:
23:15:51 T:3044286992   DEBUG: Checking device: /dev/input/event2
23:15:51 T:3044286992   DEBUG: Checking device: /dev/input/event3
23:15:51 T:3044286992    INFO: Found input device /dev/input/event3
23:15:51 T:3044286992    INFO: opened device 'Generic X-Box pad' (file name /dev/input/event3), m_bSkipNonKeyEvents 0
23:15:51 T:3044286992   DEBUG: Checking device: /dev/input/event4
23:15:51 T:3044286992   DEBUG: Checking device: /dev/input/event5
When i fast forward 8x or faster in .ts file! I have a gray artefact screen, when play in 1-2 seconds the screen is correct! The problem is, i cannot see when i must click play!
First off, awesome work with the Gotham builds, MilhouseVH. I've been using them for a few weeks now and wanted to thank you.

Also, I've noticed a bit of a bug that I wanted to mention here, and see if any of you have experienced it as well. In short, have any of you tried playing music in OpenElec lately?

Every time I try, my RPi starts freaking out around the 4 minute mark. By that I mean the CEC adapter message keeps popping up over and over and the music stutters. After about another minute, my RPi completely freezes. I've been experiencing this behavior for about the last 5-6 builds at least.

Video works absolutely fine. It's very strange!
Needless to say I've never had that happen, a debug log (wiki) from when it happens would help.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
  •   
  • 1
  • 127
  • 128
  • 129(current)
  • 130
  • 131
  • 277
  •   



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi Part 223
This forum uses Lukasz Tkacz MyBB addons.