•   
  • 1
  • 149
  • 150
  • 151(current)
  • 152
  • 153
  • 277
  •   
OpenELEC Testbuilds for RaspberryPi Part 2
Hit a personal record of 50 days consecutive up time and only stopped it to upgrade. Stability and performance is amazing now! I remember in the early testing days it was good going if I could hit a week uptime without reboot or need to re-image. Thanks heaps to all that put in time and effort to this project and got it where it is now.

(2014-01-04, 21:13)Wanderlei Wrote: Just wondering if there is a way to output mono audio to all speakers?

In the options there is a setting to output stereo to all speakers but it doesn't do the same for mono. (Official 3.2.3)

Upgraded to Official 3.2.4 and this no longer a issue, when playing mono audio tracks sound will come from all speakers.
(2014-01-07, 20:25)rbej Wrote: [rbp/omxplayer] Never trust pts in avi files
is there any patch available for never trusting pts in h264 live streams?
(2014-01-07, 18:13)xbs08 Wrote: Could you explain the benefits of using ARM to decode video?

The benefit is you can decode any video that ffmpeg supports, so if you have files that don't play due to an unsupported video codec, then you may be interested.
The problem is the arm is do weak to play any video you are likely to want to play. You won't play standard SD videos on the ARM.
I believe Doctor-X reported a Sorenson Spark 480x400 video "plays mostly okay".
(2014-01-07, 21:15)Wanderlei Wrote: Hit a personal record of 50 days consecutive up time and only stopped it to upgrade. Stability and performance is amazing now! I remember in the early testing days it was good going if I could hit a week uptime without reboot or need to re-image. Thanks heaps to all that put in time and effort to this project and got it where it is now.

(2014-01-04, 21:13)Wanderlei Wrote: Just wondering if there is a way to output mono audio to all speakers?

In the options there is a setting to output stereo to all speakers but it doesn't do the same for mono. (Official 3.2.3)

Upgraded to Official 3.2.4 and this no longer a issue, when playing mono audio tracks sound will come from all speakers.

Which version are you on?
(2014-01-07, 21:18)deejayq Wrote:
(2014-01-07, 20:25)rbej Wrote: [rbp/omxplayer] Never trust pts in avi files
is there any patch available for never trusting pts in h264 live streams?

With latest firmware there is a hack where you can do this by setting config.txt option "avoid_fix_ts=0".
It does make some streams worse, but you could try it.
Firmware needs to be Jan 3rd or newer.
(2014-01-07, 21:21)FAMMAR Wrote: Which version are you on?

Was 3.2.3 now 3.2.4.

--------------------------------------------------------------------------------------

I have quick question about fast forwarding audio tracks. I listen to audiobooks and some tracks are quite long, 1 hour or 1.5 hours long ,etc.

With 3.2.3 it would fast forward about 50% through the track then skip to the next track and start playing that.

With 3.2.4 it would fast forward about 25% through the track then playback completely stops.

Is this normal behavior or default setting? If so, can it be altered or stopped?
(2014-01-07, 21:22)popcornmix Wrote: With latest firmware there is a hack where you can do this by setting config.txt option "avoid_fix_ts=0".
It does make some streams worse, but you could try it.
Firmware needs to be Jan 3rd or newer.
how do i install the latest firmware?
i have
Code:
vcgencmd version
Dec  2 2013 20:30:23
Copyright (c) 2012 Broadcom
version 0334d765c5cb144589b4d7a4ac68ae8f136491e1 (clean) (release)
My last Frodo build have:

Code:
OpenELEC:~ # vcgencmd version
Jan  6 2014 21:16:43
Copyright (c) 2012 Broadcom
version b00bb3ae73bd2799df0e938b7a5f17f45303fb53 (clean) (release)



(2014-01-07, 21:20)popcornmix Wrote:
(2014-01-07, 18:13)xbs08 Wrote: Could you explain the benefits of using ARM to decode video?

The benefit is you can decode any video that ffmpeg supports, so if you have files that don't play due to an unsupported video codec, then you may be interested.
The problem is the arm is do weak to play any video you are likely to want to play. You won't play standard SD videos on the ARM.
I believe Doctor-X reported a Sorenson Spark 480x400 video "plays mostly okay".

yes this is correct my release can play those videos that dont have hardware decoding over omx, and yes arm dont have enough horse power but sd videos that i have play just fine
(2014-01-07, 22:15)rbej Wrote: My last Frodo build have:

Code:
OpenELEC:~ # vcgencmd version
Jan  6 2014 21:16:43
Copyright (c) 2012 Broadcom
version b00bb3ae73bd2799df0e938b7a5f17f45303fb53 (clean) (release)

what about Gotham? can i extract the files from your build and upload them to the FAT partition ?
New OpenELEC Gotham build: #0107 (obsolete)

This new build includes updated Jan 6 firmware, all other build details the same as #0106 build.

Code:
rpi512:~ # vcgencmd version
Jan  6 2014 21:16:43
Copyright (c) 2012 Broadcom
version b00bb3ae73bd2799df0e938b7a5f17f45303fb53 (clean) (release)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2014-01-07, 21:22)popcornmix Wrote: With latest firmware there is a hack where you can do this by setting config.txt option "avoid_fix_ts=0"

shouldn't this be avoid_fix_ts=1? because we don't trust pts and we want to order the packets fifo
(2014-01-07, 23:19)deejayq Wrote: shouldn't this be avoid_fix_ts=1? because we don't trust pts and we want to order the packets fifo

No. The default is 1 (check with vcgencmd get_config avoid_fix_ts).
(2014-01-07, 22:21)Doktor-X Wrote: yes this is correct my release can play those videos that dont have hardware decoding over omx, and yes arm dont have enough horse power but sd videos that i have play just fine

I was curious about this and tried your build. With my (overclocked) system, it actually performed better than I expected.
It did play the standard SD (less than 640x480) avi files perfectly well.

Unfortunately we're not quite there for raw DVD playback. With passthrough enabled (which doesn't work from dvdplayer but could be made to) I got ~20fps.
Without passthrough or with any GUI stuff up it dropped to about half that. So I don't think this is a goer, but it would have solved the DVD menus problem.

But for unsupported codecs, like DivX 3 that were popular when all videos were SD, this does have possibilities.
I'll have a think about whether using DVDPlayer is best, or if adding software video decode to OMXPlayer makes more sense, but there could be something interesting here.
@popcornmix any ideas about that DTS passthrough issue ? I pasted tvservice output here: http://forum.xbmc.org/showthread.php?tid...pid1592893
  •   
  • 1
  • 149
  • 150
  • 151(current)
  • 152
  • 153
  • 277
  •   



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi Part 223
This forum uses Lukasz Tkacz MyBB addons.