•   
  • 1
  • 164
  • 165
  • 166(current)
  • 167
  • 168
  • 277
  •   
OpenELEC Testbuilds for RaspberryPi Part 2
(2014-01-20, 19:00)MilhouseVH Wrote: For passthrough you also need (in config.txt):
Code:
no_hdmi_resample=1
hdmi_stream_channels=1
And make sure "speaker layout" is set to "2.0". You will still get 5.1 with AC3/DTS.
why do we have to set this in config.txt? the option in settings does not work anymore?
(2014-01-21, 09:00)deejayq Wrote: why do we have to set this in config.txt? the option in settings does not work anymore?

omxplayer explicitly signals passthrough audio, and it goes through a separate code path compared to non-passthrough (PCM) audio.
The Pi audio sync uses ffmpeg to encapsulate the passthough audio in a stereo PCM stream, and the GPU doesn't know when it's passthrough.
These config.txt options make sure the GPU code doesn't break passthrough. At some point these options will be either made default, or switched on/off as appropriate by Pi audio sink.
so even if i don't use dvdplayer do you think it would be a good idea to set those values in config.txt and speaker layout to 2.0?
(2014-01-21, 06:13)allan87 Wrote: Not a good experience with this build, with either omxplayer or DVD Player as default.

Just to be sure, if omxplayer is set as the default video player, and you never use dvdplayer, and you reboot, things are still worse than usual with omxplayer?

If so, I don't believe this is due to recent changes on newclock3 and may be upstream changes.
Can you confirm if latest chimney build behaves the same? Can you identify the exact chimney build that introduced the instability?

If things only get worse after running dvdplayer, I believe there may be a memory leak provoked when dvdplayer runs out of memory and doesn't clean up properly.
This will make xbmc behave badly until the next reboot.
dvdplayer uses a little more GPU memory than omxplayer, so I'd suggest gpu_mem=256 on a 512M Pi for now.
(2014-01-21, 13:23)popcornmix Wrote:
(2014-01-21, 06:13)allan87 Wrote: Not a good experience with this build, with either omxplayer or DVD Player as default.

Just to be sure, if omxplayer is set as the default video player, and you never use dvdplayer, and you reboot, things are still worse than usual with omxplayer?

If so, I don't believe this is due to recent changes on newclock3 and may be upstream changes.
Can you confirm if latest chimney build behaves the same? Can you identify the exact chimney build that introduced the instability?

If things only get worse after running dvdplayer, I believe there may be a memory leak provoked when dvdplayer runs out of memory and doesn't clean up properly.
This will make xbmc behave badly until the next reboot.
dvdplayer uses a little more GPU memory than omxplayer, so I'd suggest gpu_mem=256 on a 512M Pi for now.
- on the Milhouse build, omxplayer played choppy even after I deleted the dvdplayer lines from advancedsettings and rebooted (so that omxplayer was the default again). I had not yet commented out the special config.txt lines for passthrough, however. I don't know if that made a difference.
- to be clear, the choppy playback issue and instability issue are two different things. I did not have the choppy, tearing, out of sync playback in the Pi Chimney build.
- I did have spontaneous reboots in playback on milhouse and pi chimney in builds from yesterday. I will have to test earlier pi chimney builds to see if the issue was introduced earlier.
- These are the settings from config.txt which, I understand, have always set gpu at 256 with a 512 MB pi:
Code:
# default GPU memory split (do not change if you do not know what you are doing)
  gpu_mem=128

# SDRAM size based GPU memory split, uncomment and setup to override 'gpu_mem'
gpu_mem_256=128
gpu_mem_512=256
(2014-01-11, 01:01)michbeck100 Wrote: Does the commit bb25d06 mean that automatic switching the TV in 3D mode is supposed to be working?

If yes, it doesn't work on my LG TV. It was working with Frodo, though. All my movies either contain 3DSBS or 3DTAB in the filename. Also the "Adjust framerate..." option is on. Am i missing something?

Thanks for your great work!

Did someone recognize my post? Automatic 3D switching still isn't working for me. It would be great if someone could tell if it works for him.
(2014-01-20, 22:30)popcornmix Wrote:
(2014-01-20, 22:18)janaha Wrote: ...

When you are getting the static, does switching inputs on receiver or power cycling receiver have any effect?
Do you get static with DTS and AC3 files?

None of the suggestions works
The dts passthough lag is also present in rbej frodo build, but subs are working
My 2nd pi running OE 3.2.3 does NOT have lag with dts passthrough

EDIT :

Tested the sd card from my 2nd pi on my main pi.Still lags
Disabled OC,Lag

Maybe a defective unit?
(2014-01-21, 15:56)michbeck100 Wrote:
(2014-01-11, 01:01)michbeck100 Wrote: Does the commit bb25d06 mean that automatic switching the TV in 3D mode is supposed to be working?

If yes, it doesn't work on my LG TV. It was working with Frodo, though. All my movies either contain 3DSBS or 3DTAB in the filename. Also the "Adjust framerate..." option is on. Am i missing something?

Thanks for your great work!

Did someone recognize my post? Automatic 3D switching still isn't working for me. It would be great if someone could tell if it works for him.

Hi,

I've the same Problem... Frodo = auto switch ... gotham = no chance...
There was only one version which popcornmix did at an answer to a post of mine, but since then something must be broken, so that the autoswitch doesnt work anymore.... But i ve hope Big Grin

So i am, like you, stuck on Frodo for a while and hope that the first official beta or the final version of Gotham is out and it works then...

Sadly.... Confused
With latest build DVD ISO playback seems to be working very well for me (just using HDMI audio, no passthrough) with smooth playback and menus working correctly (no green pulsing as on earlier build). However I'm seeing interlacing effects in both OMX and DVDplayer.

In DVDPlayer I have no option to switch deinterlace on and in OMXPlayer the option is there but neither 'Auto' or 'On' appear to have any effect.
(2014-01-21, 17:29)RichG Wrote: With latest build DVD ISO playback seems to be working very well for me (just using HDMI audio, no passthrough) with smooth playback and menus working correctly (no green pulsing as on earlier build). However I'm seeing interlacing effects in both OMX and DVDplayer.

In DVDPlayer I have no option to switch deinterlace on and in OMXPlayer the option is there but neither 'Auto' or 'On' appear to have any effect.

Good to hear it's working. Deinterlace is not supported in dvdplayer currently and will require a reasonable amount of work to plumb it in. It is planned.
I don't believe anything should have changed with omxplayer. Interlace should be supported as before. Perhaps posting an xbmc.log when playing interlaced content will give some clues.
Looks like I found a workaround for the DTS passthrough lag and subtitle not enabling.

From in-video subtilte menu I enabled subs, but they didn't show up.
Then I went to the audio menu and toggled "enable passthrough"
Now, subs are enabled and video is lag free.

Maybe partially a receiver issue?

Pi-->Onkyo tx-sr608-->Samsung tv

EDIT : Added log from the workaround if it helps
http://xbmclogs.com/show.php?id=113861
(2014-01-21, 16:36)SSC_Jarod Wrote:
(2014-01-21, 15:56)michbeck100 Wrote:
(2014-01-11, 01:01)michbeck100 Wrote: Does the commit bb25d06 mean that automatic switching the TV in 3D mode is supposed to be working?

If yes, it doesn't work on my LG TV. It was working with Frodo, though. All my movies either contain 3DSBS or 3DTAB in the filename. Also the "Adjust framerate..." option is on. Am i missing something?

Thanks for your great work!

Did someone recognize my post? Automatic 3D switching still isn't working for me. It would be great if someone could tell if it works for him.

Hi,

I've the same Problem... Frodo = auto switch ... gotham = no chance...
There was only one version which popcornmix did at an answer to a post of mine, but since then something must be broken, so that the autoswitch doesnt work anymore.... But i ve hope Big Grin

So i am, like you, stuck on Frodo for a while and hope that the first official beta or the final version of Gotham is out and it works then...

Sadly.... Confused

It was working for me in Gotham, but haven't tried recently. I've actually got mine set to pressing the green button on my remote, as I have my Pi linked to the serial port on my LG, and I adjust brightness, contrast, colour as well as switch to 3D for optimal settings.
I cannot find .img files... where can I find them?

No - I cannot build them myself.
(2014-01-21, 21:09)marc.bau Wrote: I cannot find .img files... where can I find them?

No - I cannot build them myself.
http://netlir.dk/rbej/builds/
New OpenELEC Gotham build: #0122 (obsolete)

Code:
# uname -a
Linux rpi512 3.12.8 #1 PREEMPT Wed Jan 22 13:53:10 GMT 2014 armv6l GNU/Linux

# vcgencmd version
Jan 10 2014 16:54:51
Copyright (c) 2012 Broadcom
version efa116b5c8859c352322cb27e13baccbea583ef7 (clean) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20140122135243-r17116-gc79f518

Based on tip of XBMC master (4ea0a7f, changelog) and tip of OpenELEC master (c79f518, changelog) with the following modifications:
  • Includes newclock3 commits (except for b39f0e9 which I've replaced with a static spinner)
  • Includes PR3875: Allowing https in HLS variant selection
  • Excludes the OpenELEC fernetmenta patches (due to conflict with newclock3)
Notes:
  1. Build includes PR:4049 (with equivalent change for omxplayer) and PR:4051. Both pull requests are now included in newclock3. While using dvdplayer, seeking (bigjump/smalljump) seems a bit problematic when displaying srt subtitles - maybe PR4049 and PR4051 don't play well together as PR4051 on its own seemed fine. Seeking in omxplayer with srt subtitles seems unaffected.
  2. PR:3546 (fix for season art) is also now included in newclock3
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
  •   
  • 1
  • 164
  • 165
  • 166(current)
  • 167
  • 168
  • 277
  •   



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi Part 223
This forum uses Lukasz Tkacz MyBB addons.