•   
  • 1
  • 8
  • 9
  • 10(current)
  • 11
  • 12
  • 13
  •   
Release ESPN 3 Fork
(2015-02-16, 19:16)jasperguy Wrote: Wondering if there are any update on this addon? I am on the 1.0.2 release ESPN 3 and not able to resolve any links.

Does living in Canada have anything to do with it?

Android MBOX, MXIII,
KODI 14.1
1GB Ram / 8GB
Quad core, 4K display

I'm not sure, but I don't think ESPN3 is available outside the US. Are you able to access the content on the ESPN3 website?
Kodi 17.6 on Dell Optiplex 980 Lubuntu 18.04 | Kodi 18 on HTPC Lubuntu 18.04 | My Add-ons | My Repo
Reply
Anyone else getting playback failed and script errors? Running Kodi 14.2 I'm getting playback failed errors on live events and script failed errors on replays. Log file here.

The same events play without issue on another system that is still running Gotham.

EDIT: Ok, so I fixed my own problem. I found the librtmp.so.0 file on my system (located here: /usr/lib/i386-linux-gnu), then made a copy of it and renamed it librtmp.so.1 and events seem to be playing ok now. If anyone else is having the same problem, give this a try.
Kodi 17.6 on Dell Optiplex 980 Lubuntu 18.04 | Kodi 18 on HTPC Lubuntu 18.04 | My Add-ons | My Repo
Reply
Not working for me... Script failed msg when trying to play any video. Running Helix 14.1 on Windows. Located in the U.S.

Here is the relevant error in the log file:

14:58:08 T:2116 NOTICE: ESPN3: get_html: https://espn-ws.bamnetworks.com/pubajaxw...d=domestic
14:58:08 T:2116 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
- NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
Error Type: <type 'exceptions.AttributeError'>
Error Contents: 'NoneType' object has no attribute 'find'
Traceback (most recent call last):
File "C:\Users\leejk\AppData\Roaming\Kodi\addons\plugin.video.espn_3\default.py", line 400, in <module>
PLAYESPN3(url)
File "C:\Users\leejk\AppData\Roaming\Kodi\addons\plugin.video.espn_3\default.py", line 185, in PLAYESPN3
PLAY(url,'n360')
File "C:\Users\leejk\AppData\Roaming\Kodi\addons\plugin.video.espn_3\default.py", line 218, in PLAY
if not authstatus.find('successstatus'):
AttributeError: 'NoneType' object has no attribute 'find'
-->End of Python script error report<--
14:58:09 T:3808 ERROR: Playlist Player: skipping unplayable item: 0, path [plugin://plugin.video.espn_3/?url=%26partnerContentId%3D2346517%26eventId%3D176-223020%26contentId%3D38273783&mode=4&name=02%2F22+-+01%3A00+PM+-+Carquest+Auto+Parts+NHRA+Nationals]
Reply
(2015-02-26, 06:15)leejk Wrote: Not working for me... Script failed msg when trying to play any video. Running Helix 14.1 on Windows. Located in the U.S.

Here is the relevant error in the log file:

can you please give a full log next time using either pastebin.com, or something equivalent.

i'm starting to notice that sometimes ESPN does not give all necessary information to display the show.

this is the line of code that i need to see.
Code:
https://espn-ws.bamnetworks.com/pubajaxws/bamrest/MediaService2_0/op-findUserVerifiedEvent/v-2.1?playbackScenario=FMS_CLOUD&channel=espn3&partnerContentId=2350030&eventId=&contentId=&rand=0.2326014324459418&cdnName=PRIMARY_AKAMAI&identityPointId=wow:&playerId=domestic

if anything after the = sign is blank:
i.e. - contentID=
then the show will not play.

unfortunately nothing we can do about this. seems like something screwy on their end.

just noticed this with the Southern Illinois vs. #8 Wichita State (Quarterfinal #1) (MVC Men's Tournament) game.
looking at -- http://espn.go.com/watchespn/feeds/start...nnel=espn3
and the first line is:
Code:
<event id="2350030" type="live" bamContentId="" bamEventId="" mediaState="MEDIA_ON">
Linux Mint 18 LTS 64-bit - Kodi 17 Beta6
Odroid-C2 - Libreelec v7.90.009
Reply
Hello,

Here is a full log: http://goo.gl/h4X6FH

I just started Kodi and picked a few random events to play, which all failed.

thx
Reply
(2015-03-07, 16:20)leejk Wrote: Hello,

Here is a full log: http://goo.gl/h4X6FH

I just started Kodi and picked a few random events to play, which all failed.

thx

your:
Code:
identityPointId=

is blank.
who is your ISP?
unfortunately there have been problems with some of the big name providers; Comcast, TWC, Verizon.

i know some people have found ways to work around it. if you let us know your ISP, maybe we can help.
Linux Mint 18 LTS 64-bit - Kodi 17 Beta6
Odroid-C2 - Libreelec v7.90.009
Reply
(2015-03-07, 19:27)locomot1f Wrote:
(2015-03-07, 16:20)leejk Wrote: Hello,

Here is a full log: http://goo.gl/h4X6FH

I just started Kodi and picked a few random events to play, which all failed.

thx

your:
Code:
identityPointId=

is blank.
who is your ISP?
unfortunately there have been problems with some of the big name providers; Comcast, TWC, Verizon.

i know some people have found ways to work around it. if you let us know your ISP, maybe we can help.

Yep, I was looking at this line and the identityPointId=invalid and the lack of an SWID threw up a red flag:

Code:
https://espn-ws.bamnetworks.com/pubajaxws/bamrest/MediaService2_0/op-findUserVerifiedEvent/v-2.1?playbackScenario=FMS_CLOUD&channel=espn3&partnerContentId=2346517&eventId=176-223020&contentId=38273783&rand=0.3082985293851810&cdnName=PRIMARY_AKAMAI&identityPointId=invalid:&playerId=domestic

Looks like the userdata.xml file needs to be updated with working info. Steps 2 & 4 on this page should be helpful. Steps 1, 3, & 5 are unnecessary.
Kodi 17.6 on Dell Optiplex 980 Lubuntu 18.04 | Kodi 18 on HTPC Lubuntu 18.04 | My Add-ons | My Repo
Reply
(2015-03-07, 19:27)locomot1f Wrote: your:
Code:
identityPointId=

is blank.
who is your ISP?
unfortunately there have been problems with some of the big name providers; Comcast, TWC, Verizon.

i know some people have found ways to work around it. if you let us know your ISP, maybe we can help.

Yeah I have TWC, and it looks like they block it... bummer. I wasn't aware of the potential provider issues.
Reply
(2015-03-10, 00:22)leejk Wrote:
(2015-03-07, 19:27)locomot1f Wrote: your:
Code:
identityPointId=

is blank.
who is your ISP?
unfortunately there have been problems with some of the big name providers; Comcast, TWC, Verizon.

i know some people have found ways to work around it. if you let us know your ISP, maybe we can help.

Yeah I have TWC, and it looks like they block it... bummer. I wasn't aware of the potential provider issues.

I have TWC internet and it works fine for me. You just need to get your userdata.xml file setup properly.
Kodi 17.6 on Dell Optiplex 980 Lubuntu 18.04 | Kodi 18 on HTPC Lubuntu 18.04 | My Add-ons | My Repo
Reply
(2015-03-10, 02:06)MetalChris Wrote: I have TWC internet and it works fine for me. You just need to get your userdata.xml file setup properly.

Hmmm... ok I'll pursue it a bit more then. After logging into the site as the page link you posted suggested, I could not watch anything on their site in my browser, so I assumed it was being blocked since I don't subscribe to any TWC TV channels.
Reply
(2015-03-10, 02:09)leejk Wrote:
(2015-03-10, 02:06)MetalChris Wrote: I have TWC internet and it works fine for me. You just need to get your userdata.xml file setup properly.

Hmmm... ok I'll pursue it a bit more then. After logging into the site as the page link you posted suggested, I could not watch anything on their site in my browser, so I assumed it was being blocked since I don't subscribe to any TWC TV channels.

I can't watch anything on the site either, but after following the steps at the link I provided the addon works for me.
Kodi 17.6 on Dell Optiplex 980 Lubuntu 18.04 | Kodi 18 on HTPC Lubuntu 18.04 | My Add-ons | My Repo
Reply
ive got the 1.0.4 release of espn3 (not sure if this is correct?) running on win8.1 and kodi 14.1, but I dont see in settings for this addon as to where I can login using charter account. it does have options for live/recorded bandwidth thouh
Reply
(2015-03-10, 02:28)MetalChris Wrote:
(2015-03-10, 02:09)leejk Wrote:
(2015-03-10, 02:06)MetalChris Wrote: I have TWC internet and it works fine for me. You just need to get your userdata.xml file setup properly.

Hmmm... ok I'll pursue it a bit more then. After logging into the site as the page link you posted suggested, I could not watch anything on their site in my browser, so I assumed it was being blocked since I don't subscribe to any TWC TV channels.

I can't watch anything on the site either, but after following the steps at the link I provided the addon works for me.

Sorry I coundn't find this yesterday, but the easiest way to get your userdata.xml info is to follow this link:

http://broadband.espn.go.com/espn3/auth/...format=xml

You can then save the page as userdata.xml (no caps) then edit it as suggested on this page. The only thing I had to edit was the affiliate name.

(2015-03-10, 22:25)opticalcarrier Wrote: ive got the 1.0.4 release of espn3 (not sure if this is correct?) running on win8.1 and kodi 14.1, but I dont see in settings for this addon as to where I can login using charter account. it does have options for live/recorded bandwidth thouh

The login options were removed for this version of the addon as they were only needed to access ESPN and ESPN2 content. Since this addon only works for ESPN3, there's no need to login. Just get your userdata.xml file setup properly and you should be good to go.
Kodi 17.6 on Dell Optiplex 980 Lubuntu 18.04 | Kodi 18 on HTPC Lubuntu 18.04 | My Add-ons | My Repo
Reply
Thank you Chris! That last bit of information you posted helped get it working.

rgds
Reply
(2015-03-14, 16:06)leejk Wrote: Thank you Chris! That last bit of information you posted helped get it working.

rgds

Excellent! Glad I was able to help.

Enjoy!
Kodi 17.6 on Dell Optiplex 980 Lubuntu 18.04 | Kodi 18 on HTPC Lubuntu 18.04 | My Add-ons | My Repo
Reply
  •   
  • 1
  • 8
  • 9
  • 10(current)
  • 11
  • 12
  • 13
  •   



Logout Mark Read Team Forum Stats Members Help
ESPN 3 Fork2
This forum uses Lukasz Tkacz MyBB addons.