Linux Openelec AMD - HD Audio help?
#1
Hi all,

Been playing with XBMC for a few months now, this is an awesome application, so please keep up the good work guys.

I built a HTPC just after xmas to stream my library from my media server.

My setup

AMD A4-5300 (RADEON HD7480)/MSI-FM2-A75MA-E35/Powercool HTPC-006
--> HDMI -->
AVR ONKYO TX-SR608
--> HDMI -->
PANASONIC TX-P50G20BA

I initially installed OPENELEC 3.2.4 GENERIC to set it all up, but then discovered issues bitstreaming HD-Audio formats into the receiver. TrueHD would drop out or silence every few seconds and DTS-HDMA would pop and click (and sometimes drop). After doing lots of reading on the forums I understood it was due to poor linux driver support from AMD but that was changing with new OSS drivers.

I read in multiple places that the 3.2.4 Generic OSS build was supposed to work flawlessly in this regard, so I tried an update by dragging the
SYSTEM.MD5, KERNAL, SYSTEM, KERNAL.md5 files from the release into the update folder on the HTPC and rebooted. That gave me an unusable GUI that was flickering/tearing/shearing so I assumed it didn't work with my hardware.

I was going to wait for OE 4.0 but I'm keen to rip my collection of Blurays and DVDs to the server, so I updated a few days ago (and have been with each new one) with the nightly build. The rendering of video looks to be improved though I will need to figure out how to set up XBMC properly with regard to video at some point - are there any guides?

I still had the problem with the HD-Audio, only now nothing was being passed through to the AVR. I read on one thread that some AVR's reject the bitstream unless at 60hz so I switched the video refresh rate to 60hz (from 50) and HD-audio was now passed through again. Don't understand why as OE 3.2.4 generic was able to do this at 50hz just with drops and pops and clicks.

I've messed around with all the settings, tried various combinations, but am still getting drops (less frequent) in TRUEHD, and pops and clicks in DTS-HD. I thought I'd found the right combination for DTS-HD with a the night build of 8/2/2014 (using Optimized passthrough 7.1) but I guess I didn't leave a movie running long enough to tell.

Has anyone got any suggestions?

As is usually requested I got debug logs from build OpenELEC-Generic.i386-devel-20140212205158-r17700-g56e8f72

From boot I went direct to play a movie with HD audio streams.

DTS-HD Optimized @ 60hz refresh

http://www.xbmclogs.com/show.php?id=130268

DTS-HD Best Match @ 60hz refresh

http://www.xbmclogs.com/show.php?id=130269

TRUEHD Optimized @ 60hz refresh

http://www.xbmclogs.com/show.php?id=130270

And for good measure

DTSHD Optimized @ 50hz refresh as I'm puzzled why I get no HD-Audio output at all

http://www.xbmclogs.com/show.php?id=130272

Can anyone help, apologies if the logs have got a lot of skin scripts in them, I did turn off a few things so they weren't just full of excess stuff. Let me know if you need anything else.

Thanks.
Reply
#2
Optimized / Best do not influence passthrough at all. These are PCM settings.

Please provide /usr/lib/xbmc/xbmc-xrandr | pastebinit

You currently try to play 24p Content (23.987 fps) at 60 hz. That will produce a stutter every some seconds and passthrough audio will shortly click or drop out. In order to really play it succesfully "in time" - you need to set your TV into 24p Mode. This can be automatically done by setting "Video -> Playback" and enable "Adjust Refreshrate to match Video" On Start / Stop (I need to see the xbmc-xrandr output before).
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#3
Hi Fritsch, thanks for looking at this for me.

That thought about 24p content had occurred to me, but as I am getting no hd-audio at all unless it is at 60hz I assumed there was a gap in my knowledge (which there undoubtedly is). There is no issue with pass through for non hd audio formats at any hz.

I'm not sure if you meant you need to see xrandr before movie started or during so please see

http://sprunge.us/jMBF (before) http://sprunge.us/aWiP (running)

So I can learn, can you tell me what you are looking for?
Reply
#4
Bad. Your AVR does not accept hd audio in that combination - have seen similar cases with denon AVRs ah lol! and Panasonic. No solution there yet. Only thing I can suggest: turn off dts-hd, truehd and use LPCM for those.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#5
I can do the LPCM for dts-hd and truehd formats until there is a solution.

One thing is confusing me, but maybe I need to clarify what you're telling me.

In OE 3.2.4 Generic my AVR will accept hd-audio bitstream at 24p but with the dropping and popping and clicking. There is sound and the DTS-Master lights up on the display.
here is the xrandr while hd audio movie running. http://sprunge.us/QeaX (I downgraded to make sure I didn't imagine it)

Is this because it is using the old drivers? When you say my 'AVR does not accept hd audio in that combination' - do you include the newer drivers as part of that combination? Is a solution improved drivers/further development of XBMC? And is that likely to happen eventually?

Theoretically, If i installed win7 and booted xbmc from there instead, do you think I would still have the same issue?

A lot of questions I know but I do appreciate your help.
Reply
#6
Thinking is of minor use, if you can test it out.

OE 3.2.4 uses the fglrx driver, which is completely different from the Radeon OSS drivers. So, that dts-hd does not work in 24p modes, needs filing a bug at bugs.freedesktop.org - which you are highly suggested to do. This needs fixing.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#7
Ok, will do. Thanks Fritsch.
Reply
#8
Sorry to bump this thread months after the last posting, but it looks like this is still a problem with at least Openelec.

Cincho - I can confirm that, while I have a similar problem to you i.e. HD audio only working at 60Hz playback, even for 23.976 material, HD audio does indeed play fine at all refresh rates on XBMC within Win7 using the same hardware setup. This does therefore point to a software/driver issue somewhere within the Openelec/Linux/XBMC implementation.

I noticed the bug you posted on freedesktop but it seems that it hasn't been looked at yet.

Fritsch - is it likely that this problem with 23.976Hz playback and HD not working (but 60Hz working) will be the same with the Ubuntu/Radeon OSS/VDPAU setup you described in your Howto, or is there something fundamentally different with the Ubuntu setup which allows HD audio playback at all refresh rates?

Thanks in advance.
Reply
#9
Will be the same. Try latest and greatest (oe latest beta) and reply to the bugreport.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#10
Bump from the dead. Recently made the switch from Win 8.1with Kodi 15.1 to the latest Kodibuntu (Kodi 14.0/stripped down ubuntu 14.04.3)

Same issues as the OP an tonhead. Using a refresh rate of 59.94 or 60Hz = dropping, popping and clicking. Any refresh other than that = no audio at all. PCM does work if I disable the receiver HD audio capability and or passthrough altogether.

Tried updating:
Kodi to 15.1
Kernel to 3.19

no dice.

Bug link: https://bugs.freedesktop.org/show_bug.cgi?id=75064

Hardware:
Mobo: ASUS A88XM-A (Audio: ALC887-VD/Video: AMD Radeon™ HD 7000/8000)
Receiver: HK AVR 3700
Reply
#11
Kernel 4.1.6 didn't help. Also noticed this appears to be limited to DTS-HD Master. Dolby TrueHD appears to be fine at 60Hz.
Reply



Logout Mark Read Team Forum Stats Members Help
Openelec AMD - HD Audio help?0
This forum uses Lukasz Tkacz MyBB addons.