Suddenly "No Hardware Present", no device path...
#1
Hey,

since this morning I get the error No Hardware Present, in the TVheadend Web interface I see the DVB-T adapter, but it does not seem to be correctly initialized:

Hardware
Device path:
Device name:
Host connection:
Frequency range:

, since no device path is found. It seems like the system still recognizes the USB stick, already checked dmesg, and is also listed under /dev/dvb/adapter0 ....

I already tried restarting tvheadend... I'm lost. And the Olympics are starting in 30 minutes....


I would be really happy for some ideas and tips

regards
Stefan
Reply
#2
Some more information, renamed dvbadapters in home/hts/.hts/tvheadend ... now tvheadend does not recognize my stick anymore....

the dmesg output, seems fine ?! :

[email protected]:~$ dmesg | grep dvb
[ 18.232369] dvb-usb: found a 'Hauppauge Nova-T Stick' in warm state.
[ 18.232414] dvb-usb: will pass the complete MPEG2 transport stream to the software demuxer.
[ 18.425226] dvb-usb: no frontend was attached by 'Hauppauge Nova-T Stick'
[ 18.460422] dvb-usb: schedule remote query interval to 50 msecs.
[ 18.460424] dvb-usb: Hauppauge Nova-T Stick successfully initialized and connected.
[ 18.460674] usbcore: registered new interface driver dvb_usb_dib0700
Reply
#3
A couple of hours in - maybe you've got this already - but my guess is that either you've unplugged/replugged or rebooted, and the adapter has moved to a different device number. It's a long-standing challenge with USB tuners.

Have a look here: http://www.mythtv.org/wiki/Device_Filenames_and_udev

Specifically, look towards the bottom - "Alternatives to udev for naming for DVB cards". The precise naming varies from distro to distro, but, if you're lucky, you can lock the tuner in place by adding something like this:

Code:
options dvb_usb_dib0700 adapter_nr=0

... probably in /etc/modprobe.d/dvb.conf or /etc/modprobe.d/options-dvb.conf

You can see if your stick supports the adapter_nr option by running modinfo <module name>, e.g.

Code:
modinfo dvb_usb_dib0700 | grep adapter_nr

... but I believe the dib0700 module is standard so should support it.
Reply
#4
Thanks for the tipp, I will give it a try.

But in the meanwhile I reinstalled tvheadend with no success, so I don't have to many hope that this will actually change something.


Even tried the Stick on another machine, with the same resutl, gets connected succesfully, but does not show up on tvheadend either. I'm really confused... If the Stick has "broken" overnight, why the hell is recognized correctly ?? ^^..
Reply
#5
So

Code:
options dvb_usb_dib0700 adapter_nr=0

does seem to rename the adapter, but without any success....
I tried to access the adapter using dvb-apps and get the following:

Code:
[email protected]:/etc/init.d$ scan -c
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
main:2745: FATAL: failed to open '/dev/dvb/adapter0/frontend0': 2 No such file or directory

Is this normal?
Reply
#6
Can't say that it *looks* normal!

What do ls -la /dev/dvb and ls -la /dev/dvb/adapter0 show?

(and, of course, you don't have to use 0 - not that it matters, but you probably want to use whatever tvheadend used to think it was).

The fact that it's sulking on another machine as well does suggest that it may have shuffled off this mortal coil. I suppose it may still mount and be partly recognised if only some part of it (e.g. the demodulator chip) has snuffed it.
Reply
#7
Hey,

so it getting more confusing. In the mean time, after reinstalling dvb-apps and running scan -c successfully the Stick worked for quite a few hours and a couple of restarts... Unfortunately, it stopped working again, without a restart....

ls -la /dev/dvb/adapter0:
drwxr-xr-x 2 root root 100 Feb 16 19:27 .
drwxr-xr-x 3 root root 60 Feb 16 19:27 ..
crw-rw----+ 1 root video 212, 0 Feb 16 19:27 demux0
crw-rw----+ 1 root video 212, 1 Feb 16 19:27 dvr0
crw-rw----+ 1 root video 212, 2 Feb 16 19:27 net0



when it is working, there is an additional entry for frontend0 .... it seems like it has something to do with that?!

I did not quit understand your last Post, what does:
The fact that it's sulking on another machine as well does suggest that it may have shuffled off this mortal coil. I suppose it may still mount and be partly recognised if only some part of it (e.g. the demodulator chip) has snuffed it.

I'm not a naative speaker an shuffled off this mortal coil and snuffed... seems a bit unclear ^^
Reply
#8
Apologies - "shuffled off this mortal coil" is a Shakespeare reference - it means "died". And "snuffed"... that's what you'd do to a candle to put it out... so it also means "died".

Either way, it means that perhaps a bit of your stick has stopped working, so the stick itself is recognised but the tuner isn't always. The only real tests are:

1. Try the stick on a different system (which you have), and
2. Try a different stick
Reply
#9
Bought a new WinTV Ministick (2) (new revision).... works like a charm.
Seems like the old stick is really broken... in his own weird way Confused
Reply
#10
Then to complete my journey through strange English ways of saying "dead", I can only suggest that your stick's not simply pining for the fjords: it's passed on - ceased to be - expired and gone to meet its maker - a stiff - bereft of life - it rests in peace. If you hadn't have nailed it down, it'd be pushing up the daisies. Its metabolic processes are now history; it's off the twig; kicked the bucket, run down the curtain and joined the choir invisible.

This is an ex-tuner.

:-)
Reply



Logout Mark Read Team Forum Stats Members Help
Suddenly "No Hardware Present", no device path...0
This forum uses Lukasz Tkacz MyBB addons.