•   
  • 1
  • 44
  • 45
  • 46(current)
  • 47
  • 48
  • 132
  •   
Intel NUC - Bay Trail (Celeron Generation CPU) - DN2820FYKH
thethirdnut:

Can you post the details (without reproducing anything that can be found in the vaapi thread)? I'm close to admitting defeat and going to Windows (since I'd like to retain a production install of XBMC). Thanks in advance.
Reply
After 45pages i don't understand how it works with bluray 1:1, 1080 and with aeon skin

Using open elec

Better to go with i3 version ?
Reply
0) Hardware
BOXDN2820FYKH0
-- upgraded bios to v25

ssd http://www.sandisk.com/products/ssd/sata/readycache/

memory - 1.35 V DDR3L 1066 MHz SDRAM SO-DIMM http://www.crucial.com/store/partspecs.a...1264BF160B

1) Base OS Install

install OS
-- use daily server_x64.iso, boot in UEFI mode with Legacy mode disabled
http://cdimage.ubuntu.com/ubuntu-server/daily/current/ used 21-Feb-2014 daily version on mine
-- use username xbmc !!! *** ### !!!
-- guided, use entire disk
-- manually pick packages option … ie pick nothing during install
-- once done also install open-ssh-server, usbmount

configure ssh with standard keys
set static ip
setup bash history search
verify SSD starting on proper sector, has TRIM enabled, etc
install iptables and config rules

-- removed above item details for brevity

updating to mainline kernel
http://kernel.ubuntu.com/~kernel-ppa/mainline/
https://wiki.ubuntu.com/KernelTeam/Mainl...lineBuilds

picked the 3.14.-rc4 directory and dloaded the following:
linux-headers-xxx_amd64.deb
linux-headers-xxx_all.deb
linux-image-xxx_amd64.deb

Once you have those downloaded they will need to be installed using dpkg:
sudo dpkg -i *.deb

pre [email protected]:~$ uname -a
Linux nuc1 3.13.0-12-generic #32-Ubuntu SMP Fri Feb 21 17:45:10 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

post [email protected]:~$ uname -a
Linux nuc1 3.14.0-031400rc4-generic #201402232235 SMP Mon Feb 24 03:36:35 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Make sure units reboots, universe doesn't explode, etc at this point.

2) installing XBMC as per Linux - vaapi-sse4

pre-req packages
sudo apt-get update
sudo apt-get install ssh python-software-properties software-properties-common udisks upower xorg alsa-utils mesa-utils git-core librtmp0 lirc libmad0 lm-sensors libmpeg2-4 avahi-daemon libnfs1 consolekit pm-utils libva1 vainfo libva-intel-vaapi-driver i965-va-driver
sudo apt-get dist-upgrade

lirc config
1) install initiated from above
-- Windows MCE Remote (new)
-- No IR TXr
2) test Remote & Lirc later if needed
-- irw
in terminal and press home MCE Home button. This should return "Home" in terminal

Allow every user (everyone) to start X11
Add xbmc user to relevant groups

upstart procedure /etc/init/xbmc.conf
/etc/security/limits.conf
/etc/polkit-1/localauthority/50-local.d/custom-actions.pkla
Installation of the wsnipex MESA repository which includes all relevant mesa patches also for HSW
Installation of the XBMC repository and its new packages
-- see guide

sensors & advancedsettings.xml config
sudo sensors-detect
-- pick yes to detect all, etc just let it do it’s thing

had to make .xbmc + .xbmc/userdata directories and then edited /home/xbmc/.xbmc/userdata/advancedsettings.xml
-- see guide for file details

put 3.14 kernel back since gets downgraded back to 3.13 during ‘dist-upgrade’ above
see above in part 1)

reboot
see if XBMC comes up automatically, etc

XBMC AV settings for Gotham aplha
System->Settings->System->Video Output:
Vertical Blank Sync: Always Enabled

System ->Video->Playback:
Adjust Refreshrate to match video: On
Sync Playback to Display: On
Sync Method: Video Clock (Drop/Dupe)

System ->Video->Acceleration:
Use HQ Scaler when scaling larger than: 20%
Render Method: Auto Detect
VAAPI: On *others OFF*

autofs - NFS install & config
add XBMC sources + add correct Library settings per type

-- removed above item details for brevity

cleanup
sudo apt-get autoclean
sudo apt-get autoremove
Reply
Wow! Thank you so much for taking the time!

Do I need to be running Gotham or can I use Frodo?
Reply
The guide installs Gotham.
If I helped out pls give me a +

A bunch of XBMC instances, big-ass screen in the basement + a 20TB FreeBSD, ZFS server.
Reply
You should use Gotham
| myHTPC |
Reply
The question is - is it required? I see that the repository doesn't seem to have Frodo.....
Reply
As of right now it's installing xbmc 2:13.0~git20140302.1205-91ebdf3-0trusty so March 2nd version of Gotham.

https://launchpad.net/~wsnipex/+archive/...nta-master

EDIT: not sure if REQUIRED or not...be best to ask on that thread specifically. It's working well for me so sticking with that.
If I helped out pls give me a +

A bunch of XBMC instances, big-ass screen in the basement + a 20TB FreeBSD, ZFS server.
Reply
Still struggling with a Harmony One and Win8.1

Had it all working bar the info and context menu, managed to play with the device options a bit too much, now it won't power on, gonna have to remove the device and set it up again.

Annoying bit is that even with debug logging enabled, the Info and Menu buttons don't seem to be sending anything that XBMC is picking up on, so possibly the consumer IR doesn't agree with the MCE commands the harmony is sending?

Might try installing the Intel drivers again.
Reply
(2014-03-03, 19:03)Roby77 Wrote: After 45pages i don't understand how it works with bluray 1:1, 1080 and with aeon skin

Using open elec

Better to go with i3 version ?

Great question, let's see if you can get an answer. Nod
Reply
(2014-03-03, 22:31)voip-ninja Wrote:
(2014-03-03, 19:03)Roby77 Wrote: After 45pages i don't understand how it works with bluray 1:1, 1080 and with aeon skin

Using open elec

Better to go with i3 version ?

Great question, let's see if you can get an answer. Nod

*Brief* test of a full / 1:1 BR rip - if that what you mean looked good. This was the Dark Knight Rises m2ts with HD-audio @ 24p. Confluence looks good. I'll try AEON tonight, but guessing not as smooth. This is not on OE, but feedback nonetheless.
If I helped out pls give me a +

A bunch of XBMC instances, big-ass screen in the basement + a 20TB FreeBSD, ZFS server.
Reply
(2014-03-03, 22:45)thethirdnut Wrote:
(2014-03-03, 22:31)voip-ninja Wrote:
(2014-03-03, 19:03)Roby77 Wrote: After 45pages i don't understand how it works with bluray 1:1, 1080 and with aeon skin

Using open elec

Better to go with i3 version ?

Great question, let's see if you can get an answer. Nod

*Brief* test of a full / 1:1 BR rip - if that what you mean looked good. This was the Dark Knight Rises m2ts with HD-audio @ 24p. Confluence looks good. I'll try AEON tonight, but guessing not as smooth. This is not on OE, but feedback nonetheless.

thank you

could you please test file of http://jell.yfish.us ?

over 90 to 120 please

i'm also interested with aeon skin


(2014-03-03, 22:31)voip-ninja Wrote:
(2014-03-03, 19:03)Roby77 Wrote: After 45pages i don't understand how it works with bluray 1:1, 1080 and with aeon skin

Using open elec

Better to go with i3 version ?

Great question, let's see if you can get an answer. Nod

let see how http://jell.yfish.us test goes Wink
Reply
I will when time permits. Question though: I don't believe I've seen a BR pass 30-40 Mbps AND max BR bit-rate is 54 Mbps so what's point of testing 90-100+ Mbps files?
If I helped out pls give me a +

A bunch of XBMC instances, big-ass screen in the basement + a 20TB FreeBSD, ZFS server.
Reply
(2014-03-03, 21:12)Fra-HTPC Wrote: Had it all working bar the info and context menu, managed to play with the device options a bit too much, now it won't power on, gonna have to remove the device and set it up again.

Annoying bit is that even with debug logging enabled, the Info and Menu buttons don't seem to be sending anything that XBMC is picking up on, so possibly the consumer IR doesn't agree with the MCE commands the harmony is sending?

Might try installing the Intel drivers again.
When you mentioned that you messed with the device options a bit too much, were you referring to the device options within the Harmony Remote configuration? If so, have you tried a standalone physical MCE remote? Modifying the device settings within the Harmony would imply some set of reasoning related to the transmitting device causing the issue. What is odd for me is that my Harmony One was already configured and working with my old Revo 1600 setup, so the main thing that changed in my setup is the receiving device/software which leads me to believe that something is different on the receiving end. I have been busy with other projects, but I think I have an out of box MCE remote (and receiver) that I could test against the NUC and could get my Revo back up as a control case.
Reply
(2014-03-03, 23:31)thethirdnut Wrote: I will when time permits. Question though: I don't believe I've seen a BR pass 30-40 Mbps AND max BR bit-rate is 54 Mbps so what's point of testing 90-100+ Mbps files?

you are right,but it's a test to see how powerful is this model of nuc

popcorn hour a300 goes perfect on a gigabit lan at 100 mbps if remember correctly

thank you

ps:legend of the guardians the owls of ga'hoole have in somen scenes a bitrate of 70mbps and more ( this is reported by pch)
Reply
  •   
  • 1
  • 44
  • 45
  • 46(current)
  • 47
  • 48
  • 132
  •   



Logout Mark Read Team Forum Stats Members Help
Intel NUC - Bay Trail (Celeron Generation CPU) - DN2820FYKH5
This forum uses Lukasz Tkacz MyBB addons.