• 1
  • 2
  • 3(current)
  • 4
  • 5
  • 36
(2014-03-24, 22:21)negge Wrote: @J3mm: you're changing the wrong files, the installed addons are in ~/.xbmc/addons.

Ah ok... so if I look in that directory, I don't seem to have anything related to per clients:
:~/.xbmc/addons$ ls
metadata.album.universal             plugin.video.iplayer                 script.module.elementtree        service.libraryautoupdate
metadata.artists.universal           plugin.video.netflixbmc              script.module.mechanize          service.qlock
metadata.common.allmusic.com         plugin.video.youtube                 script.module.parsedom           service.rom.collection.browser
metadata.common.amazon.de            repository.addonscriptorde-beta      script.module.requests2          service.skin.widgets
metadata.common.fanart.tv            script.aeonmq5.extrapack             script.module.simple.downloader  service.subtitles.opensubtitles
metadata.common.hdtrailers.net       script.artistslideshow               script.module.simplejson         service.xbmc.versioncheck
metadata.common.htbackdrops.com      script.artwork.downloader            script.moviequiz                 skin.aeonmq5
metadata.common.imdb.com             script.cinema.experience             script.playalbum                 skin.aeon.nox
metadata.common.last.fm              script.common.plugin.cache           script.playlists                 skin.amber
metadata.common.musicbrainz.org      script.cu.lrclyrics                  script.randomandlastitems        skin.bello
metadata.common.theaudiodb.com       script.facebook.media                script.rss.editor                skin.hybrid
metadata.common.themoviedb.org       script.favourites                    script.simpleplaylists           skin.nbox
metadata.musicvideos.theaudiodb.com  script.game.netwalk                  script.tv.show.next.aired        skin.pm3-hd
metadata.themoviedb.org              script.games.rom.collection.browser  script.tvtunes                   skin.transparency
metadata.tvdb.com                    script.globalsearch                  script.videolanguage             skin.xperience1080
packages                             script.module.beautifulsoup          script.xbmc.audio.mixer          skin.xperience-more
plugin.audio.di.fm                   script.module.buggalo                script.xbmcbackup                weather.wunderground
plugin.program.chrome.launcher       script.module.chardet                script.xbmc.debug.log
I've tried uninstalling the tvh add-on manager, and now I can't even add the old one back for some reason!?
Just unzip pvr.tvh to ~/.xbmc/addons, it will then show up under Disabled addons. And remove the ones from /usr/share/whatever/addons (if you've installed them using apt-get then use apt-get to remove them, otherwise just remove them manually).
(2014-03-24, 22:43)negge Wrote: Just unzip pvr.tvh to ~/.xbmc/addons, it will then show up under Disabled addons. And remove the ones from /usr/share/whatever/addons (if you've installed them using apt-get then use apt-get to remove them, otherwise just remove them manually).

Thanks - ok, it's showing up correctly but when I try enabling it, it fails, and the log shows:
21:08:48 T:2551151424   ERROR: Unable to load /home/me/.xbmc/addons/pvr.tvh/XBMC_pvr_tvh.pvr, reason: /home/me/.xbmc/addons/pvr.tvh/XBMC_pvr_tvh.pvr: wrong ELF class: ELFCLASS64
Have I got the wrong version?
$ uname -a
Linux zbox 3.5.0-46-generic #70-Ubuntu SMP Wed Jan 8 18:43:34 UTC 2014 i686 i686 i686 GNU/Linux
You're trying to use the 64-bit addon on a 32-bit system. You'll have to compile it yourself.
(2014-03-24, 23:44)negge Wrote: You're trying to use the 64-bit addon on a 32-bit system. You'll have to compile it yourself.

Gah of course... should have spotted that!

Ok so I've cloned and compiled from https://github.com/adamsutton/xbmc-pvr-addons
cd xbmc-pvr-addons
./configure --prefix=/home/me/.xbmc
sudo make install

It didn't put the files in the right places, so I moved them into .xbmc/addons and rebooted, just to make sure.

It's now reporting version 0.4 and is working, but no EPG...? Sad
You can't use --prefix that way, you're supposed to configure without a prefix, compile and then run "make zip" to create the ZIP files that can then be installed normally in XBMC. But it seems you got it working anyway.

Many people have complained about EPG issues, I suggest you reset the PVR database and if it doesn't work, enable the "Asynchronous EPG" option in the addon. I haven't had time to look at the EPG issues myself, it works fine for me at least with the async option.
Ok, so have enabled asynchronous EPG, but still no info. If I enable the trace it's definitely coming through - going bonkers in the log - excerpt here: http://pastebin.com/6khBBP7J

Also I just can't play recordings via the add-on. Never have, so perhaps not a version thing but it just breaks up as if I'm playing something it can't cope with (yet other 1080p media from server plays fine, if I map an NFS share it's happy). Gig ethernet wired to the backend, and the mem / cpu barely even registers. Debug trace of trying to play a recording here - there's something manic going on here I can't quite get my head around... http://pastebin.com/8Uawbsxp

BTW not sure where I got the --prefix idea from, I think it was from a tvheadend thread on compiling, but tvheadend.org has been down for quite a while so can't check some of the links I've got bookmarked...
Try resetting the PVR database, that should get you going.

What version of tvheadend are you using?
Resetting the PVR db doesn't do much unfortunately - keep trying that...


This appears to be where it gets stuck on the playback:

23:49:12 T:2042587968   DEBUG: ffmpeg[79BF6B40]: [mpegts] parser not found for codec none, packets or times may be invalid.
23:49:12 T:2042587968   DEBUG: Previous line repeats 1 times.
23:49:12 T:2042587968   ERROR: ffmpeg[79BF6B40]: [h264] non-existing SPS 0 referenced in buffering period
23:49:12 T:2042587968   ERROR: ffmpeg[79BF6B40]: [h264] non-existing PPS referenced
I was referring to the missing EPG, naturally resetting the database won't fix your recordings. It sounds like a bug in tvheadend, but there's no development for the stable version anymore so you'll have to try the master branch to see if it fixes the issue.
Yes, doesn't fix the EPG for me unfortunately. All the info is in the logs, but no EPG and no ability to watch recordings Sad I'm probably out of my depth but I switched from a Myth backend to TVheadend as I was having problems with Myth, and I think I've just jumped out of the frying pan into the fire Wink
Does the EPG work with the official pvr.hts addon?
(2014-03-26, 19:28)negge Wrote: Does the EPG work with the official pvr.hts addon?

Yes indeed. Of course, I can't guarantee I haven't broken it somehow else, but I don't believe I have at least Wink
As a last resort you could uncheck "Use EPG database" and then reset the whole PVR database once more. Also check the async option in the addon. That's the settings I use and it works fine.
I had a look today and I was completely unable to get the EPG to *not* appear. I tried all combinations of settings and all worked. Are guys completely sure you're using the very latest build (cause this bug was fixed some time ago)?
  • 1
  • 2
  • 3(current)
  • 4
  • 5
  • 36

Logout Mark Read Team Forum Stats Members Help
This forum uses Lukasz Tkacz MyBB addons.