Samplers not/wrong detected as albums
#1
Music 
Hi,

I installed v12 on Raspberry and it works like charm Smile But I have a very annoying problem:
My music library is on a NAS and hosted via SMB. It's organized in 2 seperated mainfolders via:
  • Artist/Album
  • Sampler

When I scan the sampler mainfolder the files get detected, but unfortunatly not as samplers but as albums and this gets really a mess due to the clutter of hundrets of sampler-artist pairs Sad
I already studied the web and some say that XBMC should recognize a sampler when multiple artists contributed to one album. I checked my lib and everything seems to be tagged properly, so what can be the issue? Any tips?
Reply
#2
Nobody an idea? Sad
Reply
#3
Is it "Various Artists" under Album Artist in the tag?
Reply
#4
No, it lists the artist who created the current track and splitsup the albums, so you have n times the album but for different artists:

* Bravo Hits 4 - Scooter - rebell yea
* Bravo Hits 4 - Kelly family - Angel
* ...

No idea why, as the album tag is equal in every file :/
Reply
#5
An album is unique if it has a unique album artist and unique album name.

If you get multiples it's because this is not satisfied. If all the songs are in the same folder and all have the same album tag, then it will be because the "resolve to various artists" stuff isn't working due to some of your tags. Examples might be: multiple songs having the same track number, songs with album artist tag set etc.
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


Image
Reply
#6
(2014-03-11, 15:02)Geowuff Wrote: No, it lists the artist who created the current track and splitsup the albums, so you have n times the album but for different artists:

* Bravo Hits 4 - Scooter - rebell yea
* Bravo Hits 4 - Kelly family - Angel
* ...

No idea why, as the album tag is equal in every file :/

I'm not sure I get exactly what you are saying, but what I have found that works for me is...
Album Artist = "Various Artists"
Album Title= Bravo Hits 4
Artist= Scooter
Song=rebell yea

(using your example)

B.
Reply
#7
Ok so now I got the reason for the issue:

Indeed my files had wrong tags, I guess a lot of them are due my use of puddletag. I fixed them now using EasyTAG.
I discovered that XBMC had esp. problems, when:

* Track IDs missed
* Artist varies, but Album artist set and always the same

Thanks for your patient folks!
Reply
#8
Glad you got it all working Smile
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


Image
Reply



Logout Mark Read Team Forum Stats Members Help
Samplers not/wrong detected as albums0
This forum uses Lukasz Tkacz MyBB addons.