•  Previous
  • 1
  • 23
  • 24
  • 25(current)
  • 26
  • 27
  • 36
  • Next 
 
Thread Rating:
  • 2 Vote(s) - 5 Average
Gotham Beta TESTING THREAD
No Fullscreen Playback of dvd iso or physical disc if playback of dvd.iso is started while music is playing -- easily reproducible.

1) Start playback of some music, then while music is playing, <- this is important music must be playing.
2) Start playback of any DVD iso or physical disc (by pressing PLAY DISC on main menu),

Issue..
You will notice that it wont start playback in full-screen.

Playback of other files in other containers are ok.

logs to follow but this is pretty much foolproof on Ubuntu Linux with Gotham builds or Master. This is posted so other users can have a change to experience this and post their feedback.
Reply
(2014-04-13, 19:11)uNiversal Wrote: No Fullscreen Playback of dvd iso or physical disc if playback of dvd.iso is started while music is playing -- easily reproducible.

1) Start playback of some music, then while music is playing, <- this is important music must be playing.
2) Start playback of any DVD iso or physical disc (by pressing PLAY DISC on main menu),

Issue..
You will notice that it wont start playback in full-screen.

Tested and confirmed... I guess. Playback loads fine, but with XBMC homescreen overlay. Fullscreen if highlighting the "background video", but I would still say this is clearly confirmed.

Tested with DVD iso image, loaded with Deamon Tools Lite (4.49.1.0356), playback with XBMC 13.0-BETA4 Git:20140405-ca6c289 . Windows 8.1 Pro, Intel HD4000.

Both music and iso image fetched from wired smb source.

Debug log: http://pastebin.com/1XgrR7TH
If I have helped you or increased your knowledge - please click the plus to the left below to give thanks
Reply
(2014-04-13, 12:47)lapino Wrote: My daughter is watching Frozen right now on the last beta (have the bluray ripped to mkv using makemkv). I noticed that dialog audio is sent to the rear speakers instead of the center/fronts. Is this a known bug? This is on a Mac (mini) on latest OSX. Tried the same movie on frodo and it works fine there, so I suppose it's a bug.

Anyone?
Reply
@lapino: No one has crystal ball handy - see the very first post: Debug Log
Reply
I'm note sure a debug log will make a difference (but could be wrong), everything plays fine and I get no errors or other problems. Audio is sent to all speakers, except front and back speakers seem to be swapped for some reason. Already checked my Mac Mini is speaker setup is ok and also checked XBMC settings. When I set the audio output to 2.0 the audio is sent to both L+R front speakers but when I set them to 5.1, the front/rear channels are somehow swapped.

Works fine in Frodo with same settings...
Reply
Then post a Debug Log when you are sure about it.
Reply
Here you go: http://xbmclogs.com/show.php?id=172817
(search for "frozen" to look for the movie I started)
Reply
What happens with that speaker test: https://dl.dropboxusercontent.com/u/5572...20Test.avi (please don't use passthrough for this test).
Reply
Ok, it seems my center speaker and rear left are swapped according to that testfile. I checked my receiver built-in test, and there each speaker gets the right signal, same with bluray dics from my bluray player, so it's definitely a xbmc issue. Also weird is that audio of the right surround speaker is seemingly output to the subwoofer (I don't get the shot sounds, but the rumbling)

So at is now according to that movie:
* front left+right = ok
* center = sent to left rear
* subwoofer = ok
* right rear = sent to subwoofer
* left rear = sent to center
Reply
Thx much for testing - I will forward to the Mac Audio devs - it looks like problem with the channel map / speaker mapping.
Reply
I just wonder if this is a problem specifically with me, kinda strange no one reported this (I suppose there are quite a bit of OSx users too no?)
Reply
Hehe - I also think that's something special here. Not sure if you did set a special speaker layout somewhere in the system? I am a linux dev, so I have no idea how or even if those settings can by changed by the OS.

The Channel Mapping on the DarwinOSX Sink uses a fixed lookup table
Code:
#define CA_MAX_CHANNELS 8
static enum AEChannel CAChannelMap[CA_MAX_CHANNELS + 1] = {
  AE_CH_FL , AE_CH_FR , AE_CH_BL , AE_CH_BR , AE_CH_FC , AE_CH_LFE , AE_CH_SL , AE_CH_SR ,
  AE_CH_NULL
};

All the in between channels are filled in, when e.g. a 5.1 or a 2.1 layout is needed.
Reply
(2014-04-14, 14:57)fritsch Wrote:
Code:
#define CA_MAX_CHANNELS 8
static enum AEChannel CAChannelMap[CA_MAX_CHANNELS + 1] = {
  AE_CH_FL , AE_CH_FR , AE_CH_BL , AE_CH_BR , AE_CH_FC , AE_CH_LFE , AE_CH_SL , AE_CH_SR ,
  AE_CH_NULL
};

@lapino - that! - in osx-midi-setup you can set the order of channels when seeting up the channel layout. Just make FL number 1, FR, number 2, Back Left number 3 and so on (same order as the quoted code). Does this fix the problem? (though it might screw up other flawed software Wink ).
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
Well, I checked osx-midi-setup and when I click on the speakers, the sound is sent to the correct one. I really don't think this is an osx issue since XBMC Frodo works just fine, it's only the Gotham Beta 3 that does this.
Reply
Then ignore my idea and keep on trying ... *sigh* ... i didn't tell you that your speakers are wired wrong - i told you to change the internal representation of its mapping to the one most macs are having be default (yours doesn't for some reason). If its only for a quick test so that we know where we can aim at in the future for implementing a proper channel map detection.
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
  •  Previous
  • 1
  • 23
  • 24
  • 25(current)
  • 26
  • 27
  • 36
  • Next 
 
Thread Rating:
  • 2 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
Gotham Beta TESTING THREAD52