20 Nov 2019 - TVDB Scraper v3.2.0 is now available which reinstates scraping. TVDB are still in the process of fixing a number of bugs so there may still be further breakages. See this post. 2901570 (post)

( SOLVED ) 3D Detection not working.
#1
Hi there.

After installing Gotham Beta 1. Not all of my 3d movies are getting detected. I am entering in FSBS/HSBS and both are not working. I try to add the Advancedsetting.xml with those flags and still will not work. the ones that do work prompt me with a select before playing movie. the file has the FSBS/HSBS in the file. I have even try to remove the FSBS/HSBS and would just play the file. So I am sure its something to with MKV file and way it must be setup? I tried using the MKV tag/header editor... I am not sure what I am looking for,

Any suggestionHuh Need any other info to assist me with the problem?

Thanks.
Reply
#2
Hmm I'm not sure about that. I was under the impression that the TV handled 3D detection. When my TV detects a SBS picture, it kicks in to 3D. I even have a problem playing SBS multiplayer games and have to disable it. I didn't think XBMC had anything to do with 3D detection, I could be wrong though. I did notice that XBMC has a new section regarding 3D controls which I haven't messed with too much. I wanted to set it up so that the GUI would be 3D when playing 3D movies like it's supposed to, but the toggle I found just put the TV into 3D mode, which I don't want because I'm not going to put on my 3D every time I use XBMC and just play 2D stuff.
Server: Synology Diskstation 1511+ with 8x WD Red NAS 3TB drives, DSM 5.2
Main HTPC: Home Built i3, 8GB RAM, Corsair 128GB SSD, nVidia 630GTX, Harmony Home Control, Pioneer VSX-53, Panasonic VT30 65" 3D TV, Windows 10, Isengard
Bedroom HTPC: Zotac-ID 41 8GB RAM, 128GB SSD, Rii micro keyboard remote, Samsung HW-E550, Sony 32" Google TV, OpenElec 6.0 beta 4
Reply
#3
@ patseguin ..... With the setting level to advanced.In the playback setting you will have an option to have xbmc to ask you to choose a 3d option or choose the prefered option when you want it to autoselect you choice of 3d. located in the system setting > Video output in advanced mode.

I believe i have seen an option in the playback setting when the 3d movie is over it will automatically turn off the 3d.

Hope that helps you..
Reply
#4
It does, I will check when I get home. Thank you. Sorry I couldn't help with your problem. :-(
Server: Synology Diskstation 1511+ with 8x WD Red NAS 3TB drives, DSM 5.2
Main HTPC: Home Built i3, 8GB RAM, Corsair 128GB SSD, nVidia 630GTX, Harmony Home Control, Pioneer VSX-53, Panasonic VT30 65" 3D TV, Windows 10, Isengard
Bedroom HTPC: Zotac-ID 41 8GB RAM, 128GB SSD, Rii micro keyboard remote, Samsung HW-E550, Sony 32" Google TV, OpenElec 6.0 beta 4
Reply
#5
Ok I tried that option and it does nothing. I selected autoselect and also ask. Nothing changes. The 3d movie plays but the UI is in 2d and virtually useless. I've tried this in confluence as I figured the default skin would have the support. Do I gave to re-rip my 3D movies or something? I just rip them in DVD Fab and the 3D ripper and rip it to MKV which always has done and does play as SBS in XBMC and the TV detects it and puts itself in 3D mode. I'd hoped and thought the UI would he in 3D as well but it's not. I know it's beta so maybe it's just not working yet?
Server: Synology Diskstation 1511+ with 8x WD Red NAS 3TB drives, DSM 5.2
Main HTPC: Home Built i3, 8GB RAM, Corsair 128GB SSD, nVidia 630GTX, Harmony Home Control, Pioneer VSX-53, Panasonic VT30 65" 3D TV, Windows 10, Isengard
Bedroom HTPC: Zotac-ID 41 8GB RAM, 128GB SSD, Rii micro keyboard remote, Samsung HW-E550, Sony 32" Google TV, OpenElec 6.0 beta 4
Reply
#6
I finally solved it on my end. Are you putting 3d in your filename so it triggers XBMC? i.e. movie (year).3d.hsbs.mkv
Server: Synology Diskstation 1511+ with 8x WD Red NAS 3TB drives, DSM 5.2
Main HTPC: Home Built i3, 8GB RAM, Corsair 128GB SSD, nVidia 630GTX, Harmony Home Control, Pioneer VSX-53, Panasonic VT30 65" 3D TV, Windows 10, Isengard
Bedroom HTPC: Zotac-ID 41 8GB RAM, 128GB SSD, Rii micro keyboard remote, Samsung HW-E550, Sony 32" Google TV, OpenElec 6.0 beta 4
Reply
#7
I have been using with the trigger names. i would use

moviename (3D) (year) FSBS.mkv
moviename (3D) (year) SBS .mkv

The triggers seems to be working for a few of them.... But not all of them.

The Confluence skin shows (listview). Title of movie and HD right beside it. the few that I do have working shows a 3D logo beside it. Could this be triggered by resolution set?

Any other suggestions? and thanks for the help.
Reply
#8
This appears to be a good place for me to ask this question.

Does the 3D filename recognition work in file directory mode as well library mode, or only in library mode?
Reply
#9
Thats a great Question. Umm When you play a movie and press info or pause. Does it show you the resolution the movie is or the type of audio. If not then I would have to say in Library mode. Best Guess. I would have to try Later. I will post my findings.
Reply
#10
I'm not sure how the detection works but moviename (year).3d.hsbs.mkv works perfectly for me.
Server: Synology Diskstation 1511+ with 8x WD Red NAS 3TB drives, DSM 5.2
Main HTPC: Home Built i3, 8GB RAM, Corsair 128GB SSD, nVidia 630GTX, Harmony Home Control, Pioneer VSX-53, Panasonic VT30 65" 3D TV, Windows 10, Isengard
Bedroom HTPC: Zotac-ID 41 8GB RAM, 128GB SSD, Rii micro keyboard remote, Samsung HW-E550, Sony 32" Google TV, OpenElec 6.0 beta 4
Reply
#11
I will give your layout a try... And see what happens. thanks for your help there. Patseguin. Let you know the results.
Reply
#12
I hope it works. I spent hours figuring this out so I know the ropes now. :-)
Server: Synology Diskstation 1511+ with 8x WD Red NAS 3TB drives, DSM 5.2
Main HTPC: Home Built i3, 8GB RAM, Corsair 128GB SSD, nVidia 630GTX, Harmony Home Control, Pioneer VSX-53, Panasonic VT30 65" 3D TV, Windows 10, Isengard
Bedroom HTPC: Zotac-ID 41 8GB RAM, 128GB SSD, Rii micro keyboard remote, Samsung HW-E550, Sony 32" Google TV, OpenElec 6.0 beta 4
Reply
#13
@Pasteguin... So I ended up figuring out it was my naming scheme that was the whole problem. the format I would use..

Movie (3D) (Year) HSBS.mkv

The format you gave me to try moviename (year).3d.hsbs.mkv. and it WORKS! I am thinking alot has to do with 3D as the trigger and hsbs is more like a switch. I was assuming it was the HSBS was the trigger. Well none the less it works and figure you should know...

Thanks again.
Reply
#14
Yeah I guess the same thing. Glad I could help. I stayed up late for hours figuring this out. I wish they would sticky my post or give better instructions with XBMC. I added my info to the wiki so maybe that will help.
Server: Synology Diskstation 1511+ with 8x WD Red NAS 3TB drives, DSM 5.2
Main HTPC: Home Built i3, 8GB RAM, Corsair 128GB SSD, nVidia 630GTX, Harmony Home Control, Pioneer VSX-53, Panasonic VT30 65" 3D TV, Windows 10, Isengard
Bedroom HTPC: Zotac-ID 41 8GB RAM, 128GB SSD, Rii micro keyboard remote, Samsung HW-E550, Sony 32" Google TV, OpenElec 6.0 beta 4
Reply
#15
Wink 
(2014-03-09, 15:22)patseguin Wrote: Yeah I guess the same thing. Glad I could help. I stayed up late for hours figuring this out. I wish they would sticky my post or give better instructions with XBMC. I added my info to the wiki so maybe that will help.

Old thread i know but just wanted to say thanks!! spent ages trying to work out why some of my 3D movies are detected as 3D  by Kodi and some not....simple file name change and i am in business. much kudos Blush
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
( SOLVED ) 3D Detection not working.00