Openelec RPi v3.95.1 bug thread?
#31
Different movie, last nights Milhouse build, complete log, still no sound: http://xbmclogs.com/show.php?id=150376
Reply
#32
(2014-03-16, 13:01)Forage Wrote: Different movie, last nights Milhouse build, complete log, still no sound: http://xbmclogs.com/show.php?id=150376

You should disable "extract thumbnail and video information" (http://wiki.xbmc.org/index.php?title=Settings/Videos).
You should set gpu_mem=128. 100 is too low for gotham.

However I think the problem is that the Panasonic VIERA G30 does not support DTS passthrough.
On Frodo if you requested a passthrough format the TV didn't report as supported, it would be disabled, and you would get downmixed stereo.
However we found that reporting of supported passthrough formats was unreliable, especially when HDMI splitters and optical output from TV were used,
so now, on Gotham, we'll do what you say whatever.

If this is the case, then disabling "DTS capable receiver" is the correct solution to get the same behaviour of Frodo.

Run "tvservice -a" to confirm if DTS passthrough is supported.
Reply
#33
(2014-03-16, 13:22)popcornmix Wrote: You should disable "extract thumbnail and video information" (http://wiki.xbmc.org/index.php?title=Settings/Videos).
You should set gpu_mem=128. 100 is too low for gotham.
Thanks for the suggestions, I'll give that a go.
The gpu_mem suggestion, however, is confusing. This was what I already had in my config.txt:
Code:
# default GPU memory split (do not change if you do not know what you are doing)
  gpu_mem=128

# SDRAM size based GPU memory split, uncomment and setup to override 'gpu_mem'
  gpu_mem_256=100
  gpu_mem_512=128
In both cases already set to 128 for my RPi.

(2014-03-16, 13:22)popcornmix Wrote: However I think the problem is that the Panasonic VIERA G30 does not support DTS passthrough.

...

If this is the case, then disabling "DTS capable receiver" is the correct solution to get the same behaviour of Frodo.

Run "tvservice -a" to confirm if DTS passthrough is supported.

Running that command gives me just
Quote:PCM supported: Max channels: 2, Max samplerate: 48kHz, Max samplesize 16 bits.
, on OE 3.2 as well as OE 4. Which would imply that it never worked in the first place... Which is strange, because when I started enabling that in the past, tests I performed back then where giving me a positive outcome that passthrough was working.

Here's a log where I try to use "Play using..." to start playing the movie on my TV through UPnP: http://xbmclogs.com/show.php?id=150403

I'm trying it with 2 different movies. Both end up with nothing. My TV, however, can play the same movies just fine when starting them either directly on my TV as well as through "AV Control Point" on my desktop machine. The latter functions as a UPnP control point as well.
Reply
#34
(2014-03-16, 13:42)Forage Wrote: Running that command gives me just
Quote:PCM supported: Max channels: 2, Max samplerate: 48kHz, Max samplesize 16 bits.
, on OE 3.2 as well as OE 4. Which would imply that it never worked in the first place... Which is strange, because when I started enabling that in the past, tests I performed back then where giving me a positive outcome that passthrough was working.
Yes, no DTS or AC3 passthrough is reported as supported. Frodo builds would have just behaved as if passthrough was disabled (downmixing to stereo).
Disable passthrough for the same behaviour as Frodo.

Quote:Here's a log where I try to use "Play using..." to start playing the movie on my TV through UPnP: http://xbmclogs.com/show.php?id=150403

I'm trying it with 2 different movies. Both end up with nothing. My TV, however, can play the same movies just fine when starting them either directly on my TV as well as through "AV Control Point" on my desktop machine. The latter functions as a UPnP control point as well.

Unlikely to be a Pi specific issue. Can you try the same with xbmc installed on another device (e.g. window PC).
If that fails, you are better off reporting this is a general xbmc thread (I know nothing about UPnP).
Reply
#35
OK thanks, for the feedback.

While you where typing a reply I was updating my previous post. I've updated the "gpu_mem" part because it was already set accordingly. Do your observations tell you otherwise or did you intent to use different numbers?
Reply
#36
(2014-03-16, 14:03)Forage Wrote: OK thanks, for the feedback.

While you where typing a reply I was updating my previous post. I've updated the "gpu_mem" part because it was already set accordingly. Do your observations tell you otherwise or did you intent to use different numbers?

You have gpu memory set to 128M. The gpu_mem_256 takes precedence on a 256M board. Change that setting to 128.
Reply
#37
(2014-03-16, 13:22)popcornmix Wrote: You should set gpu_mem=128. 100 is too low for gotham.
I'm curious, what symptoms have you found with less than 128MB? I'm thinking of using 64MB on my Pi, running both OpenElec and Subsonic, because Subsonic eats a lot of RAM. Do you think it would be okay if I never play videos? Music only.
Reply
#38
(2014-03-17, 05:05)spookybathtub Wrote:
(2014-03-16, 13:22)popcornmix Wrote: You should set gpu_mem=128. 100 is too low for gotham.
I'm curious, what symptoms have you found with less than 128MB? I'm thinking of using 64MB on my Pi, running both OpenElec and Subsonic, because Subsonic eats a lot of RAM. Do you think it would be okay if I never play videos? Music only.

1080p playback (especially when many reference frame or when deinterlace is enabled and sub/osd present can require more than 100MB).
The fanart from the library views can consumes significant gpu memory, especially when scrolling quickly.

The symptoms are OMX errors in debug log, and failure to play video or decode textures.

I've never tried as low as 64M. I doubt it will be reliable unless you are very constrained with what you do, but feel free to try.
Reply
#39
(2014-03-17, 13:18)popcornmix Wrote:
(2014-03-17, 05:05)spookybathtub Wrote:
(2014-03-16, 13:22)popcornmix Wrote: You should set gpu_mem=128. 100 is too low for gotham.
I'm curious, what symptoms have you found with less than 128MB? I'm thinking of using 64MB on my Pi, running both OpenElec and Subsonic, because Subsonic eats a lot of RAM. Do you think it would be okay if I never play videos? Music only.

1080p playback (especially when many reference frame or when deinterlace is enabled and sub/osd present can require more than 100MB).
Where 100/156 was already acceptable on a 256MB RPi, 128/128 didn't hurt but I didn't notice a significant improvement either (it's just 28MB more though). While I assume you don't want to go higher than 128MB on a 256MB RPi to leave some CPU mem, what would be the recommended amount of GPU mem on a 512MB RPi for Gotham? I can imagine going too high would be a waste of the possible additional CPU mem again. Note that I got a 512MB RPi now and I disabled background fan art so it's basically just for playback.
Reply
#40
(2014-03-18, 17:20)Forage Wrote: Where 100/156 was already acceptable on a 256MB RPi, 128/128 didn't hurt but I didn't notice a significant improvement either (it's just 28MB more though). While I assume you don't want to go higher than 128MB on a 256MB RPi to leave some CPU mem, what would be the recommended amount of GPU mem on a 512MB RPi for Gotham? I can imagine going too high would be a waste of the possible additional CPU mem again. Note that I disabled background fan art so it's basically just for playback.

I believe gpu mem of 128M is fine with default xbmc settings.

You may want to increase this on a 512M board if:
you are using dvdplayer at greater than dvd resolutions
you increase the default fanart resolutions
you enable the higher quality fanart setting in GUI
you switch to a heavier skin that can show more fanart at once
Reply
#41
I use 1080 fanart/720 poster art with
Code:
<fanartres>1080</fanartres>
  <imageres>720</imageres>
in advancedsettings.xml, and I've found that a minimum gpu_mem=170 is required to prevent XBMC from crashing when it runs out of GPU mem, so normally I just leave gpu_mem set to 256 and have no problems (obviously, this is on a 512MB Pi...)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Openelec RPi v3.95.1 bug thread?00
This forum uses Lukasz Tkacz MyBB addons.