Bug sporadic missing images in addon's default skin
#1
I've been seeing some issues with images randomly vanishing in my addon's default skin, and I'm curious if this might be a bug in Gotham. Has anyone else seen something like this?

My addon is TV Show Next Aired, and all its icons are separate png files (with one background jpg for good measure). The problem seems to happen the easiest if I have fanart enabled for the background, but disabling that doesn't guarantee that nothing will vanish. The image that vanishes the most often is the background texture for the focusedlayout's first image control, but that doesn't affect the background image for the other items lower down in the same list when the focus is moved. I've also seen the image vanish that is used for the background texture for the imagelayout (which affects all the items) and the background texture for the headings (which also affects all the items). Re-entering the dialog doesn't seem to change anything, but tweaking a setting (such as turning off the fanart background) will usually change things up a bit (perhaps getting everything to load).

Anyone know what might be going on? I tried creating a Textures.xbt file in the addon's media dir, but that seems to be something that doesn't work for an addon's media images. Any hints or a pointer at where to report a bug would be appreciated.

..wayne..
Reply



Logout Mark Read Team Forum Stats Members Help
sporadic missing images in addon's default skin0
This forum uses Lukasz Tkacz MyBB addons.