•   
  • 1
  • 4
  • 5
  • 6(current)
  • 7
  • 8
  • 15
  •   
Release Foscam HD - Video feed with camera controls, and motion/sound detection preview
#76
I've released 0.0.19 which adds checks for characters which will cause problems for this add-on but are allowed by Foscam. These characters are

{ } : ; ! ? @ \ /

for the password, and

@

for the user name.
Leopold's Repository: Home of LibreELEC Dev Updater ...
Reply
#77
(2014-09-22, 15:48)Leopold Wrote: Are you using a user account with admin privileges?

Next time I get to the installation location I will check that. Thanks!
Reply
#78
Crashes
Reply
#79
(2014-09-30, 16:11)xavier.ba Wrote: Crashes

What?
If I have helped you or increased your knowledge, click the 'thumbs up' button to give thanks :) (People with less than 20 posts won't see the "thumbs up" button.)
Reply
#80
(2014-09-30, 20:55)nickr Wrote:
(2014-09-30, 16:11)xavier.ba Wrote: Crashes

What?

Helpful critique isn't it. Tongue
Reply
#81
Hi, so I double checked and the account I am trying to connect with is a admin account. Here are the logs from when I try to connect.

18:08:40 T:4008 NOTICE: -->Python Interpreter Initialized<--
18:08:41 T:4008 NOTICE: script.foscam v0.0.19: http://192.168.0.202:88/cgi-bin/CGIProxy...******&pwd=***********
18:08:41 T:4008 NOTICE: script.foscam v0.0.19: <Response [200]>
18:08:41 T:4008 NOTICE: script.foscam v0.0.19: <CGI_Result>
<result>-2</result>
</CGI_Result>
18:08:41 T:4008 ERROR: script.foscam v0.0.19: Username or password error
18:08:44 T:3828 NOTICE: script.foscam v0.0.19: Sleeping for 5 seconds

I also double and triple checked the username and password for the account.

Thanks
Reply
#82
(2014-10-02, 06:15)sea3pea0 Wrote: Hi, so I double checked and the account I am trying to connect with is a admin account. Here are the logs from when I try to connect.

18:08:40 T:4008 NOTICE: -->Python Interpreter Initialized<--
18:08:41 T:4008 NOTICE: script.foscam v0.0.19: http://192.168.0.202:88/cgi-bin/CGIProxy...******&pwd=***********
18:08:41 T:4008 NOTICE: script.foscam v0.0.19: <Response [200]>
18:08:41 T:4008 NOTICE: script.foscam v0.0.19: <CGI_Result>
<result>-2</result>
</CGI_Result>
18:08:41 T:4008 ERROR: script.foscam v0.0.19: Username or password error
18:08:44 T:3828 NOTICE: script.foscam v0.0.19: Sleeping for 5 seconds

I also double and triple checked the username and password for the account.

Thanks

Try the http request in a browser and see what you get
Code:
http://192.168.0.202:88/cgi-bin/CGIProxy.fcgi?cmd=getDevState&usr=username&pwd=password
Leopold's Repository: Home of LibreELEC Dev Updater ...
Reply
#83
(2014-10-02, 07:43)Leopold Wrote: Try the http request in a browser and see what you get
Code:
http://192.168.0.202:88/cgi-bin/CGIProxy.fcgi?cmd=getDevState&usr=username&pwd=password

This is what I get:

<CGI_Result>
<result>-2</result>
</CGI_Result>
Reply
#84
(2014-10-03, 22:46)sea3pea0 Wrote:
(2014-10-02, 07:43)Leopold Wrote: Try the http request in a browser and see what you get
Code:
http://192.168.0.202:88/cgi-bin/CGIProxy.fcgi?cmd=getDevState&usr=username&pwd=password

This is what I get:

<CGI_Result>
<result>-2</result>
</CGI_Result>

OK so the problem is not related to the add-on itself. -2 means "Username or password error".
Leopold's Repository: Home of LibreELEC Dev Updater ...
Reply
#85
Well even though I could login with that username & password combo through the camera's webpage, I guess the cgi interface didn't like something about the username password combo I was using. So after creating a new user & password I got it working. Thanks for your help.
Reply
#86
(2014-10-04, 22:06)sea3pea0 Wrote: Well even though I could login with that username & password combo through the camera's webpage, I guess the cgi interface didn't like something about the username password combo I was using. So after creating a new user & password I got it working. Thanks for your help.
Could you paste your original url with the problem user/password into http://www.url-encode-decode.com/ and try the resultant encoded url? I'd be interested to know if this fixes it as I could do the same thing in the add-on. The Foscam documentation is a bit unclear about this.
Leopold's Repository: Home of LibreELEC Dev Updater ...
Reply
#87
I currently have two Non-HD Foscam (FI8910W) camera's that are not supported with this addon. I would love to buy a new one just to make this add-on work. In reading through the thread it appears there are some HD Foscam firwares/versions that don't work properly (if I read the comments right). Can anyone tell me if the below statement is still true? I was looking at one on ebay and wanted to save myself sometime if I could get the exact version that is guaranteed to work. Thanks everyone!


From OP

"I tested with a FI9821W V2 that I use as a baby monitor but it should work with any of the HD range, so anything with a model number starting with FI98."
Reply
#88
I still only have a FI9821W V2 so can only speak for that. I'm running the latest firmware (V-2.x.1.10_20140516) with a patch from Foscam applied to fix the audio.

All the FI98 models share the same API and rtsp URLs so should all work with this add-on. Hopefully others can reply with their actual experience of the other HD models. Does anyone use a FI9831W with this add-on?
Leopold's Repository: Home of LibreELEC Dev Updater ...
Reply
#89
(2014-10-05, 11:32)Leopold Wrote: Could you paste your original url with the problem user/password into http://www.url-encode-decode.com/ and try the resultant encoded url? I'd be interested to know if this fixes it as I could do the same thing in the add-on. The Foscam documentation is a bit unclear about this.

I tried pasting the encoded url into a browser but because the ip address was encoded as well it just opened up a google search for the encoded url. I also tried just encoding from "cgi" on instead of encoding the http://ipaddress:88/ part but that gave me a 404 error.
Reply
#90
(2014-09-20, 22:40)Leopold Wrote:
(2014-09-19, 07:27)vamana Wrote: I'm trying to install Foscam HD in XBMC 13.2 but couldn't. It says "Add-on is incompatible or has been marked broken in repository. Dependencies not met. Please contact Add-on author"

Is there any extra setting I need to do?

thanks
This should be fixed now.

I have the same message in 12.1, is 13 required for this add-on?
I just downloaded the repo from your 1st post and tried to enabled the add-on but it's listed as Broken.
Reply
  •   
  • 1
  • 4
  • 5
  • 6(current)
  • 7
  • 8
  • 15
  •   



Logout Mark Read Team Forum Stats Members Help
Foscam HD - Video feed with camera controls, and motion/sound detection preview1
This forum uses Lukasz Tkacz MyBB addons.