•   
  • 1
  • 7
  • 8
  • 9(current)
  • 10
  • 11
  • 15
  •   
Release Foscam HD - Video feed with camera controls, and motion/sound detection preview
@freddy12

latest firmware.
What about the fast forward trick, would it catch up to the latency?
In other words, without my fix, if you open the script from under programs and you fast forward for couple of second and hit play, would the delay go?
Reply
I also noticed that there is a random race condition, where you need to add a small sleep between the play and seek , so the seek API does not get triggered before the video started rendering.
Anyhow, verify that the FF trick and then we can look at the script
Reply
Solved the low level mic issue using the volume amplification setting in OSD!!! works like a charm!

Unfortunately there is no API call to set the volume amplification, so the only way we can automate this at launch time is using json rpc.

For whatever reason, the json python library, mainly the underlying is urllib2 is hanging when calling GUI.ActivateWindow, so instead I went the ugly route and used requests with a timeout set to 0.1

Here is an ugly quick code with no error checking, but you can get the idea. I will clean it up and send a pull request.

Code:
import requests
try:
    response = requests.get('http://192.168.1.134:8080/jsonrpc?request={ "jsonrpc": "2.0", "id": 1, "method": "GUI.ActivateWindow", "params": {"window": "osdaudiosettings"}}', timeout=0.1)
except:
    requests.get('http://192.168.1.134:8080/jsonrpc?request={ "jsonrpc": "2.0", "method": "Input.ExecuteAction", "params": { "action": "down" }, "id": 1 }')
    for x in range (1, 30):
        requests.get('http://192.168.1.134:8080/jsonrpc?request={ "jsonrpc": "2.0", "method": "Input.ExecuteAction", "params": { "action": "right" }, "id": 1 }')
    requests.get('http://192.168.1.134:8080/jsonrpc?request={ "jsonrpc": "2.0", "method": "Input.Back", "params": { }, "id": 1 }')
Reply
Ive tried the fast forwarding and didnt make much of a difference, is their some log i can send you that'll give you more of a idea of whats going on?
Reply
It's really strange that the Fast Forwarding trick is not working for you, I assume that the Foscam IE windows plugin works without delay? This should eliminate networking problem, the other thing is the XBMC version, I am running Gotham with Nvidia VDPAU , I wonder if this would make a difference on the ffmpeg

I made short video showing how it works for me.
First attempt was using the plugin as is, not sure how well you can see, but notice the delay was 3-4 seconds since I hit the arrow until the screen refreshes.
Second attempt, I enabled the setting to seek + amplification and notice the delay is around 0.3 seconds which is very acceptable.

http://youtu.be/RviMSpMAUSE

@leopard
Feel free to merge these changes https://github.com/danilll/script.foscam...y_take_one
A small polishing needs to be done which will involve making XBMC webserver, which is used by json rpc calls, configurable, right now it is hard-coded to localhost and 8080
Reply
(2014-11-21, 05:55)danillll Wrote: It's really strange that the Fast Forwarding trick is not working for you, I assume that the Foscam IE windows plugin works without delay? This should eliminate networking problem, the other thing is the XBMC version, I am running Gotham with Nvidia VDPAU , I wonder if this would make a difference on the ffmpeg

I made short video showing how it works for me.
First attempt was using the plugin as is, not sure how well you can see, but notice the delay was 3-4 seconds since I hit the arrow until the screen refreshes.
Second attempt, I enabled the setting to seek + amplification and notice the delay is around 0.3 seconds which is very acceptable.

http://youtu.be/RviMSpMAUSE

@leopard
Feel free to merge these changes https://github.com/danilll/script.foscam...y_take_one
A small polishing needs to be done which will involve making XBMC webserver, which is used by json rpc calls, configurable, right now it is hard-coded to localhost and 8080
ive done some more testing and if i actually go into the add on and use the fast forward trick it does catch up to the ie plugin after afew seconds but its more the motion detection thats so far behind because im using it at my front door it really shows the delay
Reply
(2014-11-21, 11:59)freddy12 Wrote: ive done some more testing and if i actually go into the add on and use the fast forward trick it does catch up to the ie plugin after afew seconds but its more the motion detection thats so far behind because im using it at my front door it really shows the delay

I haven't played with motion detection yet, but I assume you changed the frequency for checking the alarm in the plaugin section area?
I will test when I get a chance and let you know what I find.
Reply
howd you go with the finding?
Reply
We have enabled your ip cam viewer add on , from that point we put in the IP address but it disappeared, we do not know how to activate it, we have tried this on several devices but they are all the same., could you give us any advice please, looks like a great add on , thank you
Reply
have a TrendNet cam with only rtsp stream available (tv-ip311pi).
Is there a way to get it to work?

have a TrendNet cam with only rtsp stream available (tv-ip311pi).
Is there a way to get it to work?
Reply
(2014-12-03, 20:34)icefluffy Wrote: have a TrendNet cam with only rtsp stream available (tv-ip311pi).
Is there a way to get it to work?

have a TrendNet cam with only rtsp stream available (tv-ip311pi).
Is there a way to get it to work?

This addon is only for Foscam. If you just want to view the rtsp stream then check out IP Cam from my repo.

(2014-12-01, 06:51)carterlake Wrote: We have enabled your ip cam viewer add on , from that point we put in the IP address but it disappeared, we do not know how to activate it, we have tried this on several devices but they are all the same., could you give us any advice please, looks like a great add on , thank you

It's not clear what the problem is from your description. The only thing that comes to mind is that maybe you're not selecting OK to save the settings?
Leopold's Repository: Home of LibreELEC Dev Updater ...
Reply
Thx Leopold,

Installed IP CAM,

entered rtsp://192.168.1.100 in the settings of IP Cam.

Running it from the programs menu does nothing.
I can't seem to find where all the settings are being written.
this is the content of the setting.xml file:
<settings>
<category label="32001">
<setting label="32002" type="text" id="url"/>
</category>
<category label="32051">
<setting label="32052" type="enum" id="debug" lvalues="32053|32054|32055" default="0"/>
</category>
</settings>

can't find the hard coded values anywhere nor can i find the logs I enabled (I would like to know how it connects to the stream...)

is there a place where i can find more information on:
how it works, how to debug
how to configure it properly
how to use the functionalities...

PS:when launching a JSON request over http like http://192.168.69.199:8080/jsonrpc?request={"jsonrpc": "2.0", "id": 1, "method": "Addons.GetAddons"}
the IP Cam addon is not in the list my XBMC returns....
Reply
Did you save the settings by hitting "OK" after entering the url?

Did you enable the addon?

Settings are saved in userdata (wiki) under addon_data
If I have helped you or increased your knowledge, click the 'thumbs up' button to give thanks :) (People with less than 20 posts won't see the "thumbs up" button.)
Reply
I just tried it out with a Y-cam camera and it worked. Settings are stored in ~/.xbmc/userdata/addon_data/script.ipcam/settings.xml. Mine is

Code:
<settings>
    <setting id="debug" value="0" />
    <setting id="url" value="rtsp://user:[email protected]/live_mpeg4.sdp" />
</settings>
Leopold's Repository: Home of LibreELEC Dev Updater ...
Reply
(2014-12-04, 23:22)Leopold Wrote: I just tried it out with a Y-cam camera and it worked. Settings are stored in ~/.xbmc/userdata/addon_data/script.ipcam/settings.xml. Mine is

Code:
<settings>
    <setting id="debug" value="0" />
    <setting id="url" value="rtsp://user:[email protected]/live_mpeg4.sdp" />
</settings>

any chance you could merge the latest fastforward trick into the multi camera git, also when i try to install that i get a dependencie not met
Reply
  •   
  • 1
  • 7
  • 8
  • 9(current)
  • 10
  • 11
  • 15
  •   



Logout Mark Read Team Forum Stats Members Help
Foscam HD - Video feed with camera controls, and motion/sound detection preview1
This forum uses Lukasz Tkacz MyBB addons.