•   
  • 1
  • 196
  • 197
  • 198(current)
  • 199
  • 200
  • 266
  •   
  Thread Closed
Amazon Fire TV for XBMC
(2014-05-30, 17:57)underworld123 Wrote: 20MB is the default (http://wiki.xbmc.org/index.php?title=HOW...e_settings), so 24MB will not do you much good. I have it at 100MB and buffermode 1 and it works extremely well.
My only worry is that setting the buffer at 100 MB, thereby using 300 MB RAM, might cause issues. Have you checked how much free RAM your FTV has while playing a movie?
(2014-05-30, 19:10)elmerohueso Wrote:
(2014-05-30, 17:57)underworld123 Wrote: 20MB is the default (http://wiki.xbmc.org/index.php?title=HOW...e_settings), so 24MB will not do you much good. I have it at 100MB and buffermode 1 and it works extremely well.
My only worry is that setting the buffer at 100 MB, thereby using 300 MB RAM, might cause issues. Have you checked how much free RAM your FTV has while playing a movie?

Yeah, but at least on my end, setting it to 100MB buffer is actually only buffering about 63MB max.

And at 100MB you're only using about 50% or less RAM. You still have about 1 - 1.2GB free.

Forum Rules (wiki) | Banned add-ons (wiki) | Wiki (wiki) | Quick start guide (wiki)
(2014-05-30, 03:55)davidc502 Wrote: Hello,

I recently bought FireTV, and one of the main reasons was because I could install XBMC and connect to PlayOn. The install of XBMC was no issue, but I'm having problem with the playback.

1. From video served from MyMedia or any video chosen from any of the PlayOn channels stutter or are jerky.
2. Though videos from MyMedia are served in HD, any of the PlayOn channels are SD.

With a little research I found SPMC might be a better choice and ended up installing it on FTV. SPMC doesn't have issues with jerky playback, however it has the same problem of serving SD from any of the PlayOn channels.

Are these known issues between XBMC and PlayOn when running XBMC on FireTV?

Thanks,

David

Why do you want to use PlayOn rather than create the share directly?
(2014-05-30, 19:10)elmerohueso Wrote: [quote='underworld123' pid='1723613' ...nnnk

Mkk4ee Elm 9
555$@
3
=×4%_=4 default (http://wiki.xbmc.org/index.php?title=HOW...e_settings), so 24MB will not do you much good. I have it at 100MB and *jjii*jjj 4 and it works extremely well.
My only worry is that setting the buffer at 100 MB, thereby using 300 MB RAM, might cause issues. Have you checked how much free RAM your FTV has while playing a movie?
[/quote]

Mseww s, ?,,,&?!?
(2014-05-30, 20:16)Tinwarble Wrote:
(2014-05-30, 19:10)elmerohueso Wrote:
(2014-05-30, 17:57)underworld123 Wrote: 20MB is the default (http://wiki.xbmc.org/index.php?title=HOW...e_settings), so 24MB will not do you much good. I have it at 100MB and buffermode 1 and it works extremely well.
My only worry is that setting the buffer at 100 MB, thereby using 300 MB RAM, might cause issues. Have you checked how much free RAM your FTV has while playing a movie?

Yeah, but at least on my end, setting it to 100MB buffer is actually only buffering about 63MB max.

And at 100MB you're only using about 50% or less RAM. You still have about 1 - 1.2GB free.

Yes, the last time I checked, it had enough of free RAM.
(2014-05-30, 21:49)underworld123 Wrote:
(2014-05-30, 20:16)Tinwarble Wrote:
(2014-05-30, 19:10)elmerohueso Wrote: My only worry is that setting the buffer at 100 MB, thereby using 300 MB RAM, might cause issues. Have you checked how much free RAM your FTV has while playing a movie?

Yeah, but at least on my end, setting it to 100MB buffer is actually only buffering about 63MB max.

And at 100MB you're only using about 50% or less RAM. You still have about 1 - 1.2GB free.

Yes, the last time I checked, it had enough of free RAM.

Confirmed. I have used a much larger buffer than this, and have not had any problem. Here are my settings:
Code:
    <!--  maximize the video playback cache -->
     <buffermode>1</buffermode>
     <cachemembuffersize>209715200</cachemembuffersize>
     <readbufferfactor>4.0</readbufferfactor>

The buffer size comes from monitoring the Fire TV memory settings with XBMC Helix runnning.
This is good information. My one small issue right now is that I'll play a file from my NAS and it will start, buffer for a moment, then play perfectly. Sounds like I need to set buffermode 1.
(2014-05-30, 22:56)sspectre Wrote: This is good information. My one small issue right now is that I'll play a file from my NAS and it will start, buffer for a moment, then play perfectly. Sounds like I need to set buffermode 1.

Yes, I had a similar problem with 1080p files (my FTV is on WiFi). Increasing the cache to 100MB and changing the buffermode to 1 solved all problems Smile
XBMC has changed my life. Having said that...sometimes it makes me want to run away and curl up in a corner and cry.

I'm trying to get Flirc and a Harmony One to work with Gotham 13.2 beta on the FireTV. I loaded the keyboard.xml from the XBMC FireTV wiki and everything seemed to work except one thing. Now when I push the back button on the Harmony Remote OR the FireTV remote it takes me all the way back to the XBMC Home screen instead of just up one directory like it used to.

Here is the xml code I used:
Code:
<keymap>
        <global>
                <keyboard>
                        <key id="61656">ContextMenu</key>
                        <key id="61467">Back</key>
                        <key id="61637">FastForward</key>
                        <key id="61636">Rewind</key>
                        <backspace>PreviousMenu</backspace>
                </keyboard>
        </global>
        <FullscreenVideo>
                <keyboard>
                        <next_track>StepForward</next_track>
                        <prev_track>StepBack</prev_track>
                </keyboard>
        </FullscreenVideo>
</keymap>

Can someone please tell me how to change it back? Everything else is working wonderfully, but I've spent hours trying to figure this out to no avail.

Thanks!
Escape maps to "go to home screen"

Backspace maps to "go up one directory"
If I have helped you or increased your knowledge, click the 'thumbs up' button to give thanks :) (People with less than 20 posts won't see the "thumbs up" button.)
The fire tv runs xbmc very well. It's very quick, but there is a consistent and annoying bug .
The audio is always out of sync by about 1/4 second too slow. So you always have to change it in the audio menu for each item you watch. I have 2 fire tvs ( one running 13.2 and another 13RC1) and it's the same case with both.

I also have an apple tv2 and Raspberry pi and audio is spot on in sync with both. So this is definitely a problem with the fire tv.

Until there is a proper fix is there any way (maybe with XML code) to put the audio ahead by 250ms permanently for every video played? Any help/advice would really appreciated.
(2014-05-31, 14:55)Colin15150 Wrote: The fire tv runs xbmc very well. It's very quick, but there is a consistent and annoying bug .
The audio is always out of sync by about 1/4 second too slow. So you always have to change it in the audio menu for each item you watch. I have 2 fire tvs ( one running 13.2 and another 13RC1) and it's the same case with both.

I also have an apple tv2 and Raspberry pi and audio is spot on in sync with both. So this is definitely a problem with the fire tv.

Until there is a proper fix is there any way (maybe with XML code) to put the audio ahead by 250ms permanently for every video played? Any help/advice would really appreciated.

If the delay is the same for all videos then all you have to do is set the delay for one and then select "Set as default for all videos". No need to edit any xmls.

Forum Rules (wiki) | Banned add-ons (wiki) | Wiki (wiki) | Quick start guide (wiki)
(2014-05-31, 15:41)Tinwarble Wrote:
(2014-05-31, 14:55)Colin15150 Wrote: The fire tv runs xbmc very well. It's very quick, but there is a consistent and annoying bug .
The audio is always out of sync by about 1/4 second too slow. So you always have to change it in the audio menu for each item you watch. I have 2 fire tvs ( one running 13.2 and another 13RC1) and it's the same case with both.

I also have an apple tv2 and Raspberry pi and audio is spot on in sync with both. So this is definitely a problem with the fire tv.

Until there is a proper fix is there any way (maybe with XML code) to put the audio ahead by 250ms permanently for every video played? Any help/advice would really appreciated.

If the delay is the same for all videos then all you have to do is set the delay for one and then select "Set as default for all videos". No need to edit any xmls.
Thanks a lot. I didn't see any set to default option will look for it and report back.

Cheers
Colin
(2014-05-31, 15:47)Colin15150 Wrote: Thanks a lot. I didn't see any set to default option will look for it and report back.

Cheers
Colin

When the video is playing press the select/enter button on the remote, then select "Audio and subtitle settings", select the "Audio offset" and set your delay, then at the bottom of the settings menu you see the "Set as default for all videos".

Forum Rules (wiki) | Banned add-ons (wiki) | Wiki (wiki) | Quick start guide (wiki)
(2014-05-31, 07:08)nickr Wrote: Escape maps to "go to home screen"

Backspace maps to "go up one directory"

Thanks for the reply!
Adding that keyboard.xml was the first time I've messed with keymaps, so I'm more than a little clueless. Smile

So what do I need to change and where do I do it? In that xml file, or harmony settings, or Flirc GUI? I don't see escape in the xml, but that's definitely what's happening and I want it to stop. Smile

Thanks again!
  •   
  • 1
  • 196
  • 197
  • 198(current)
  • 199
  • 200
  • 266
  •   
  Thread Closed
 
Thread Rating:
  • 10 Vote(s) - 4.8 Average



Logout Mark Read Team Forum Stats Members Help
Amazon Fire TV for XBMC4.810